The strange case of Like Dead HP 41C Series Calculators


Hi all,

I'm having a strange problem.

Sometimes, when applying new batteries to the HP 41C series, they simply stop responding and die (even units that I've tested just a while ago and were perfectly working).

But if I wait some time with the batteries off (about a week I think) and then install batteries again, they suddenly return to life and work perfectly.

Has anybody noticed a similar behaviour? Any tips on how to solve it without having to wait all this time?


Edited: 10 May 2006, 4:41 p.m.


I've seen this once with an HP 41CX calculator. I had not used for about six months and could not get it to switch on. I reversed the batteries and it restarted. I can't be certain as it was some time ago but I think that the contents of the memory were lost.


Hi there.

Doesn't the reversing of the batteries damage the calculator?

Did you reversed all the batteries or just some?


If I recall correctly (from memory), the HP41C CPU board has a diode connected in series with the batteries, so reversing the batteries would have no effect (neither good nor bad).

I suppose such a diode is also present in halfnut models, but am not sure about it. I also think (not 100% sure) that this same device protects the VBat connection on the I/O ports.

A series diode causes a voltage drop (and, in fact, a little power loss). Such drop is dependent on the semiconductor element used. Most electronic devices made in the last decades are silicon (Si) based. Si has a forward voltage drop of about 0.7 volt.

However, the particular diode in the abovementioned circuit is a germanium (Ge) diode, which were more common in the 50s and the 60s. Germanium has only a 0.3 Volt forward drop, so HP showed once more a "thinking outside the current fad" attitude, protecting the calculator from misplaced batteries but also losing as little battery power as possible.

Germanium is far from obsolete, but you will not usually find this kind of detail and care in a consumer device.


Actually it is a Schottkey barrier diode with a 0.37V forward drop....


I apologize for the error. I recall I measured the forward voltage drop on my HP41C back in the '80s. The 0.3 Volt measurement made me suppose (wrongly) it was a germanium diode. At that time I didn't thought about a Schottky device. I should have considered that possibility; in those years I was regularly working with 74SXX TTL ICs repairing bit-slice CPU boards. Incidentally, some were AMD-based, but with AM2900s, not an Opteron there :-)

For the current discussion sake, any of both devices will protect the calculator from reversed batteries.

Edited: 23 May 2006, 7:32 p.m.


Remember, HP was the company that commercialized the Schottkey diode... before them they were very exotic things that lived in labs and sold for zillions.


I once wiggled the il module while using my first 41 and then it would only speak in conji. I called hp and they had me try a few things. nothing worked and they finally said that i had really pissed it off and should try taking out the batteries for a week and buying it flowers. No dice. I called back and they said i would have to leave the batteries out for six months. That worked, and is why i bought a second.


6 months !!!!


This is too much time.


Well, I'd really start to worry if it started speaking in katakana ;-)


My 41cv has same problem , somtime it can't detect the module , sometime hang on , somtime display " monster" symbol , but some time work properly . Do anyone tell me what's wrong of calculator and how to fix it.

Edited: 11 May 2006, 9:36 a.m.


Hi folks,

I don't have this problem with an HP41C but I do have it with my
MP3 player. It hangs when a fully charged battery is inserted -
most of the time. Sometimes it comes to life, though.

Best guess for the causation is a troublesome power-on reset
circuit. Very tempting for design managers to assign their design
to beginners as they apparently are simple. Alas, they are among
the most difficult circuits in the real world. This world is
littered with bad products whose POR circuit is the reason why
they drive their owners nuts.



This is a rather common thing to happen. I can usually get them to start up by taking the pack out and reinserting it after a while (usually no more than a minute). Then give it a hard reset (SHIFT+ON) a few times. Lather, rinse, repeat as needed. I also seem to have better luck alternating attempts with a N cell pack and a nicad pack. Sometimes I leave the battery in for several minutes and try again.

As a last ditch effort, you can open the machine and short out the big filter capacitors.


Hi, thanks.

Just one thing, isn't the Hard Reset the BACKSPACE+ON combination instead of the SHIFT+ON combination ?




I've add mixed result with this procedure.

For one, yes, it works in bringing the calculator back to life, but whenever I turn it off, it just stops working again and I have to complete the procedure again for it to turn on again :(

Possibly Related Threads...
Thread Author Replies Views Last Post
  Strange HP 25 Problem (Repair) Onur Ilkorur 5 2,018 12-06-2013, 05:13 PM
Last Post: Onur Ilkorur
  Strange Battery Icon during updaate of Prime Firmware. Harold A Climer 7 2,435 12-05-2013, 04:40 PM
Last Post: Michael de Estrada
  HP Prime Tutorial #4 is up (CASE/CHOOSE/INPUT) Eddie W. Shore 1 912 11-15-2013, 07:32 AM
Last Post: Davi Ribeiro de Oliveira
  HP PRIME : strange behavior when trying user key capability Damien 12 2,821 11-03-2013, 11:02 AM
Last Post: Joe Horn
  HP-10C Series Family Photo Max Stone 5 1,598 10-24-2013, 10:31 PM
Last Post: Eddie W. Shore
  Leather case for the HP-Prime Karl-Ludwig Butte 9 2,957 10-19-2013, 06:08 PM
Last Post: Eddie W. Shore
  HP Prime function APP - Strange limitation ! :o( dg1969 2 1,091 10-04-2013, 12:10 PM
Last Post: dg1969
  HP41CX: Strange serial #... Stephan Matthys 1 809 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  [WP34s] strange behaviour at number entry Dieter 12 2,630 06-06-2013, 05:36 PM
Last Post: Harald
  Strange battery leak Cristian Arezzini 0 699 06-03-2013, 09:49 AM
Last Post: Cristian Arezzini

Forum Jump: