Hourglass and Annunciator won't shut off


Some time ago, my 4-year-old got ahold of my hp48gx and had a heyday on the buttons. After I took it from him I realized that the hourglass and the annunciator were 'lit' and wouldn't shut off. My son had gotten it into the I/O menu and did something, but I have no idea what.

Now the annunciator and the hourglass characters on the lcd won't shut off and it's driving me crazy. I've tried a halt and a memory reset to no avail. Anybody know how to fix this?



Just put in new batteries;-)



Sorry not to mention that was the first thing I tried.



Does it respond to the keyboard at all? If not, you could try to force a warmstart by pushing a straightened paperclip into the small hole labeled "R" found by removing the upper right rubber foot on the back.



This happened to my 48G too. I asked about a solution at HP here in Melbourne, but it didn't work. It's still in the cupboard doing the same thing. Lost cause I'm afraid. Sorry I can't help, but if you get a solution, I'm sure it'll cure my problem too.
Good luck



Mine had been in this state for the better part of a year. The calculator works fine, with the exception of the loss of knowing when it is 'thinking' because the hourglass is on all the time.

Funny thing happened yesterday though...I tried some new things and actually got the characters to finally shut off. This is what I think happened originally: From the I/O menu the (don't know which menu pick) the calculator was set to receive transmission, pretty sure via IR. There it sat waiting to receive a signal. Then it goes thru an apparent timeout, but a flag must have been set somewhere that never really gets cleared, even after reset (I hadn't yet tried a hardware reset under the rubber foot).

Yesterday I again went to the I/O menu, picked "Transfer" -> Port: IR -> Type: Kermit -> Name: 'PPAR' (because it was there) -> then "RECV" on the menu bar. Same result, it waited until I cancelled and the characters are still there. Then I did exactly the same thing except this time I chose "SEND" as the final option. Then cancelled the action and the characters turned off. My '48GX is now back to normal! Must be a bug in their IR RECV routine.

I would like to know if Paul is able to fix his in the same manner.



A warmstart is only a partial reset. If you don't care about what's in memory... you can coldstart it and reset everything to factory defaults on a 48 with the three finger salute: With the unit on, press and hold the A and F keys, press and release the ON and finally release the A and F. Press the F key (NO) when presented with the question: Try to recover memory? That should clear all the I/R stuff and put it in a clean state.

In a few rare cases, I've seen a defective LCD cause some or all of the annunciators to stay on. That big thin piece of glass can fracture and/or break in really wierd ways.

Edited: 15 Mar 2006, 5:46 p.m.


I'll try this. Got nothing to lose by it. The unit is buried away and I'm still in mourning. If I can bring it back to life, you will be thanked ten fold.



Rick, was it just the busy annunciator (hourglass) on, or was there another one, such as the I/O annunciator (looks like an arrow pointing right)?

Pretty strange in any case, as a CANCEL (ATTN on 48SX/S) operation should abort any I/O, and Kermit and Xmodem transfers ordinarily time-out if not proceeding; I think after about a minute.

The CLOSEIO command might've been worth a try with something going wrong sith I/O, but turning the calculator off should close the I/O port anyway.

For the "Serial I/O" commands XMIT and SRECV (but not Kermit or Xmodem transfers), the STIME command sets the time-out. By default, the time-out is 10 seconds, but it can be set from 0.1 to 25.4 seconds, and 0 STIME disables the time-out entirely; that is, it'll wait "forever", or at least until the batteries go dead, if the command isn't completed or canceled.

An invalid IOPAR reserved variable in the HOME directory should cause an "Invalid IOPAR" error. IOPAR can be safely purged; if it doesn't exist, then the default IOPAR will be created the next time that it's needed.

I don't know of any problem with the RECV command, but earlier ROMs in the 48G series have a problem with the XRECV command. From the HP48 FAQs:

6.14. Why does XRECV not work sometimes? (GX)

Pre-Rev R. G Series 48's had a bug that would sometimes cause XRECV to
fail if there was not twice the amount of room free for the incoming
file. FXRECV, a fix for this bug, is available on the Horn 9 disk in
the directory \HP as FXRECV. There is more info about this bug there
as well. Note that FXRECV is not required for Rom R, and in fact
will not run properly on Rom R.

Of course "Horn 9" refers to Joe Horn's Goodies Disk #9, available at http://www.hpcalc.org/hp48/compilations/horn/.

With versions A-D of the 48SX/S there can be a problem if the clock is displayed during an ARCHIVE. From the FAQs:

If the clock is displayed during an ARCHIVE via RS-232, there is
a chance (not 100%) that calculator memory will be cleared,
after the transfer. The work-around is to turn the clock
display off before doing the transfer. Should your memory be
cleared, you will have to restore the contents of memory from
the archive.

I think that the manuals recommend that the clock display be turned off during I/O anyway.

In the 49 series, XON/XOFF software flow control doesn't work. This doesn't matter with the small packets used in the calculators' implementations of Kermit and Xmodem, but can be a problem with the "Serial I/O" commands.

Of course, SysRPL or assembly language programs or libraries (as well as, presumably, SYSEVAL, LIBEVAL, and FLASHEVAL, and the 49 series menu 256 commands) can change things in system RAM not accessible to ordinary users, including turning annunciators on or off and changing bits that control I/O. In any case, I'd expect the "3-finged salute" (ON&A&F) followed by NO to set things right, preferably after backing up anything that you don't want to lose.

And of course hardware problems are always a possibility.


Edited: 16 Mar 2006, 3:33 a.m.


I'm not sure what you mean by "the annunciator"; the little symbols at the top of the display are generally known as "annunciators".

I'm guessing that you mean the "alert" annunciator; it looks sort of like a dot with two pair of parentheses around it. This alert annunciator is turned on by (among other things) an unacknowledged alarm. Try an ACKALL command to turn it off, and while you're at it, delete any alarms that you don't want.

There's a possibility that a repeating alarm has a period too short to give you a chance to delete it. In this case, hold down the ON key and press the key with TIME above it (the 4 key on the 48 series or the 9 key on the 49 series) to prevent the next alarm from executing, and then delete any unwanted alarms.



First, thanks for the replies & all the suggestions. I had no Idea there were so many possibilities. Second, sorry for the vagueness on the "annunciator". The one I meant was indeed the I/O Annunciator, the little right arrow way to the right of the display -- not the "alert" annunciator.

To answer some previous questions, I did try the "3-finger solute," to no avail. I didn't perform hardware reset with a paper clip under the foot. I had no alarms programmed and I don't believe an alarm to be a factor. I did have the clock displayed and that might have contributed in some way, but how so is beyond me. There have never been any programs downloaded to my 48GX, either. In fact, it's never been connected to a computer or second calculator.

I spent a good amount of time trying to repeat the problem but have not yet been successful.

The little detail that gets me is the fact that the "data transmit" annunciator was on solid. In normal operation, while waiting to connect to something, it is on only intermittently. If it was actually linked to another device I could see it being solid, but such was not the case here.

Oh well, I guess my problem was magically resolved by divine intervention (eegad!). I'd still like to know if Paul got his fixed as well. Thanks again for everybody's friendly expertise.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP41 Card Reader won't read and write Bruce Larrabee 5 1,660 07-31-2012, 06:33 PM
Last Post: John Robinson
  HP48SX seems fully functional won't run SELF TESTS? Bruce Larrabee 5 1,565 07-16-2012, 11:04 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-67 won't run on batteries David Ramsey 5 1,530 04-18-2012, 12:15 AM
Last Post: David Ramsey
  [WP34S] Mac OS Flashing Tool Won't Flash Les Wright 2 1,129 03-23-2012, 03:59 AM
Last Post: pascal_meheut
  WP34s low battery shut down? Harald 9 2,981 03-02-2012, 05:12 PM
Last Post: Jim Horn
  41CL - Shut Off that Auto-Turn Off Frido Bohn 17 3,298 12-22-2011, 03:39 AM
Last Post: Frido Bohn
  HP won't fix PSE bug on 15CLE? MK-52 14 2,885 12-18-2011, 03:51 PM
Last Post: Eddie W. Shore
  [wp34S] PSTO Won't Write to 6 thru 9 Les Wright 5 1,418 11-26-2011, 09:45 AM
Last Post: Walter B
  12c won't turn on --- options? Gene Wright 8 1,793 10-28-2011, 10:45 PM
Last Post: gene wright
  HP's chief strategy officer to retire next month, won't have a successor designnut 2 868 10-23-2011, 08:46 AM
Last Post: Thomas Radtke

Forum Jump: