HP-41CX - Clock does not appear!



#20

I have a problem with my hp-41cx: the clock will not appear after I clicked 'Shift' and 'On'. the hp-41 however obviously is on, because after the next click 'On', I can turn it on again and/or it would accept the 'DELETE' function per '<-'.
the clock itself works, which means the command 'TIME' gives the current time into the x-register and all other functions of the Time-module work properly, too. What to do to display the clock permanently? Probably one component on the platinum is defective - only which one? Can anyone help?


#21

new batteries! ! ! ! :-)


#22

Just kidding, ehh?? Of course the batteries are new, all functions of the calculator work properly - even the card reader, which has the highest power consumption.

Edited: 2 Jan 2006, 3:26 p.m.


#23

Try reseting it. Warning: This will clear memory.

  1. Turn the unit off
  2. Press and hold the backspace key
  3. Press and release the ON button
  4. Release the backspace key

The unit should now be on and display MEMORY LOST


#24

Hi Randy,

Thank you. I did this already before I posted the problem. MEMORY LOST appears. Unfortunately without further success.

Best wishes,
Tom

#25

Hi, Tom;

if your answer is "No, I do not allow you a silly question!", please, do not read... It may be considered a silly question, anyway! <8^(

although it seems silly, I cannot help asking it: are you sure it is an HP41CX?

Please, prior to blame me for that question, just let me ask a few others: Is it a newly bought unit, that you have never used before? Did [SHIFT][ON] work properly before? Have you tried [CAT] 2 and checked for the headers-only, CX-style catalog output?

I'm asking these all because it is not hard to hardwire the Time and the X-Functions modules inside a regular HP41CV and 'transplant' its guts to a CX case.

Again, please, if this is not the case, forgive me. I have seen some weird 'hacked' models that called my attention to what can and cannot be done...

Will you forgive me?

Cheers.

Luiz (Brazil)


#26

Hi Luiz,

Thank you for your posting. I never would quote it as a silly question, because I did a transplantation from CV to CX and viceversa with other hp-41's, too. But this one is a genuine HP-41CX. [CAT2] shows the CX-ROM Version and the extended CX funktions.

In another post I learned that disconnecting the cardreader without shut off the HP-41 could cause this problem. I bought this one used, so I did not know anything about its 'history'.

Best Regards,
Tom


#27

Hi Tom,

Try the CLOCK function. I think it works like
the SHIFT ON.

Best regards

François


#28

Bonjour François,

I tried this, too. But the command [CLOCK] shows the same effect - same problem.

Thanks,
Tom


#29

When you xeq the clock function what happened? Just nothing happened or the calculator display "nonexistent"?


#30

Hi Chan,

the function [XEQ][CLOCK] causes the same effect as [SHIFT][On]. The display becomes empty: no signs, no characters. Pressing [<-] the display shows the content of the X-Register again.

Thanks,
Tom


#31

I think you will have to open the calculator in order to "celan" the contact between PCB's. In fact, just opening it and moving the two halves of the calculator can fit it! PAY ATTENTION to plastic posts; the yare very fragile so don't screw them in to much...


#32

Hello Michel,

last weekend I opened the calculator again and cleaned the contacts. No success. But another phenomenon became obvious: Once pressed [Shift][On] or [XEQ][CLOCK] the calculator cannot be shut off totally anymore?!? After [Off] any key turns the HP-41CX on and further to that: [<-]+[On] does not lead to 'MEMORY LOST'. To make the calculator working normally, batteries have to be removed for a few seconds. But the above mentioned problems (no clock ...) remain.

Best regards,
Tom


#33

My question: Did the "BAT" indicator appear in the display? - With my 41cx it's exactly then that the clock won't be displayed (for avoiding too much power consumption)! In my opinion you possibly & simply should recharge the batteries or replace them by new ones.

Good luck, Hans-Joerg


#34

Hi Hans-Jörg,

the BAT-Indicator is off. I used new batteries (let's say, they were sold to me as new ones ...). Does it also occur when the BAT-Ind. is off? If so, I'm going to buy new batteries.

Best regards,
Tom

#35

I have seen this when either the clock crystal or the 22 megohm resistors in the clock circuit are bad.


#36

Hello David,

Thanks for this important information. Due to the fact that the clock itself seems to be ok ([TIME], [SW] e.g. work properly) this could be the reason of the problem. I am going to open the HP-41CX again...

Tom

#37

Hi David,

Two more attempts to make the HP 100% working:

1. fresh batteries --> no success
2. I replaced the resistor (the old one did have about 26 MegaOhm), the new one has exactly 22.0 MOhm --> no success.

Very frustrating. Do you really think the clock cristal could be bad however [TIME] and [SW] work properly?

Tom

Edited: 15 Jan 2006, 11:21 a.m.


#38

If TIME and SW are actually working properly, then your problem most likely is the firmware ROM. I know that if the clock crystal has problems, you don't get the clock display.

I had one machine where the clock was very flakey and would not come on from the power switch. It would come on from the keyboard. Apperently it was a bad CPU contact. Pressing the keyboard keys pressed down on the CPU card enough to get contact for a short time, but the clock stopped if you touched the machine.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime - Revision Suggestion - Setting the Clock Bill Triplett 5 508 11-15-2013, 12:36 AM
Last Post: Joe Horn
  Prime incase anybody missed the clock Dougggg 5 451 10-19-2013, 04:05 PM
Last Post: Geoff Quickfall
  Using your HP-65 as a clock! Don Shepherd 24 1,350 10-08-2013, 11:53 AM
Last Post: Don Shepherd
  WP-34s clock program Andrew Nikitin 8 553 06-09-2013, 11:20 PM
Last Post: Andrew Nikitin
  Cool math clock Bruce Bergman 28 1,683 04-10-2013, 03:13 AM
Last Post: Siegfried (Austria)
  hp clock does not talk to hp 71 Hans Holzach 15 782 07-29-2012, 04:13 PM
Last Post: Hans Holzach
  OT: Mechanical CPU clock Ethan Conner 1 237 04-19-2012, 01:23 AM
Last Post: Mike Morrow
  [WP34s] Accurate Clock Katie Wasserman 1 206 04-08-2012, 01:25 AM
Last Post: Walter B
  41CL Usage Notes: Clock Mode and Turbo Interaction Craig Ruff 1 223 12-11-2011, 05:27 AM
Last Post: Ángel Martin
  HP50g - very inaccurate clock? Mark Edmonds 13 715 09-20-2009, 03:47 PM
Last Post: Mike Morrow

Forum Jump: