Problem printing with a HP2225B



#2

Hello,

I have a problem with printing on a HP2225B thinkjet printer.

The HP2225B is hooked up with the HP IL interface via IL as only device in the loop.

I have checked flags 21 and 55: Both are set (and verified that they are set). If I start up without the printer hooked up, both are cleared, after connecting both switch to the "set" status.

IL module works (checked with HP82162A printer.

Executed "Autoio"

Did a findid on HP222B and got "1" as response.

Printer detect paper works (yellow blinking Led switches to full on when paper taken out).

Batteries are fully loaded.

Print advance works.

Changing the settings for flag 15 and 16 does not make any difference.

Selftest for printing testpage does NOT work.

I used a fully new Printhead.

When I execute the "PRX" command I get "transmit error"
I exchanged the PCB board and got exactly the same error.
I checked both the IL as the printer manual but not a single reference to this "transmit err".

Based on this it looks like the IL interface is working. The HP 41 is detecting the printer oké and the transmit error comes somewhere from the communication between the CPU on the PCB board and the printhead.

Any suggestions, I am at this moment having a blank in my mind ?

Thank you

Ronald.


#3

Forget the HP41 for the moment...

At power-on (of the 2225B), do you get the 'carriage shuffle'? Does it move away from the left side, and then return to detect the home position?

What exactly happens when you try to print the test page? Do the carriage and paper move and just no ink appears on the paper or what?

FWIW, I have the Thinkjet service manual...


#4

Hi Tony,

When I swith the printer on the printhead moves all the right and back again.

If I try to pint the testpage nothing happpens.

The flexcable was replaced with a complete new one. I I measure with a DVM om the circuit board with the printhead out it has a vry high resistance between the corner connection and all the other points on the flexcable. When the printhead is mounted, it measures on all pinns between a 130 - 160 ohms. For that reason I think the cable is fine, the printhead makes the right connections.

Does the servicemanual say anything on this IL error ?

Kind regards

Ronald


#5

You need not worry about the flexible cable or the printhead for the moment. There is no way that the printer's CPU can tell if those are working properly, so if the machine doesn't 'go through the motions' of printing the self-test page, the problem is elsewhere.

I think it sounds like you have a problem with the home sensor. This is a slotted optoswtich mounted on the print mechanism which detects a plastic 'flag' on the carriage. It's got 4 wires going to it, wired to a connector that plugs into the logic board.

I would start by making sure there's nothing in the slot -- bit of paper or whatever. It is connected to an 8 pin chip on the logic board which is a standard voltage comparator -- something like a LM393 (but don't replace it with one of those without me checking the manual first, this is from memory and I've not worked on a Thinkjet for some time). I would then start checking voltages round that chip to find whether the optoswitch itself was OK, etc.


#6

Hi Tony,

Thank you for the suggestion, I will check this out. The carriage (if this is the correct word) for the printhead does indeed looks a little bit different to the old one, so .... I have hopes again.

Will report later back on the outcome.

Thanks

Ronald.


#7

Hi Tony,

CI checked out the end of carriage detector. If I take it out, the carriage will run untill it's mechanical end and after 5 seconds the motor trying to drive him stops.
So I assume that is working oké.
I then changed the motherboard completely. No change at all. I changed the end of carriage detector and out of paper also from the other printer I had. No change.

If I give a "PWRUP" command with the printer on, IL connector connected, it returns very quick in the HP41 with no error's. If I however switchg the printer of or disconnect the IL connectort at the printer's connector I get after maybe 5 seconds also the "trasmit error" in the display of the HP41.

Any more idea's maybe ?
You do have by any means a scanned part of the service manual so I do some circuit level tracing with my osciloscope of DVM ?

Gr.

Ronald


#8

When you said 'removed' the sensor, do you mean you disconnected it from the board as well? I have an idea the LED is used as a voltage reference for the comparator circuit.

Apart from the sensor and the mainboard (both of which you say you've swapped out with good parts, not that I aprove of module-swapping...), the only other things involved are the carriage feed stepper motor and mechanical bits. I can assure you (from the schematics and from experience) that a fault in the paper feed mechanism or in the cartridge/flexiprint will not cause any errors. It just won't work.

Alas I have no scanner, so no way to send copies of bits of the service manual. But if you send me an e-mail (my address is unmangled), I'll talk you through it.


#9

Hi Tony,

When you said 'removed' the sensor, do you mean you disconnected it from the board as well? I have an idea the LED is used as a voltage reference for the comparator circuit. --> Yes, I did, I also changed it with one from the other printer, but to no avail, so I replaced the original again.


Apart from the sensor and the mainboard (both of which you say you've swapped out with good parts, not that I aprove of module-swapping...), the only other things involved are the carriage feed stepper motor and mechanical bits. I can assure you (from the schematics and from experience) that a fault in the paper feed mechanism or in the cartridge/flexiprint will not cause any errors. It just won't work.

Alas I have no scanner, so no way to send copies of bits of the service manual. But if you send me an e-mail (my address is unmangled), I'll talk you through it.
-->That is very nice, I just send you a mail with my adress.


#10

I hopefully sent you a long-ish e-mail message last night giving some information I extracted from the service manual.

In particular, the carriage should pass through the home switch _twice_ after power-on. If not, the problem is either the home switch optoswitch, something on the logic PCB, or a mechanical problem (motor, gearing).

Also, what does the yellow LED do? It should blink twice and go out. If it carries on blinking, there is a problem on the logic board (basically, the CPU, ROM or RAM have failed the self-test). If it blinks twice, goes out for a couple of seconds, then starts blinking, the problem is that the carriage did not find the home position (which is what I suspect).

If you are _sure_ the logic board and the home switch sensor are both good, then the problem has to be either the motor (very unlikely as it moves the carriage) or a mechanical problem.

#11

If you want to get it working for fun, then excellent, its a fun
printer to play with, but if you think you can actually use it, I have bad news for you.

This printer is really bad, probably because it was the first inkjet that HP produced, the ink slowly leaks and can cause a real mess in the print head compartment, the inkjet head nozzles clog up etc.

The interface to the (disposable) printhead is also very fussy and you have to be really careful when you clean this up (esp. when cleaning after a leaky printhead) not to damage the little bumps that make contact with the printhead. If this happens, you have to live with the missing dots. I do not think you can repair the flex cable with the contact bumps.

The trick is to use the printer regularly (at least once a week, preferably more frequently), to keep the ink in the printhead and the nozzles clear. Then your ThinkJet will work nicely.

If you plan to store it, make sure the printhead is removed to prevent the inevitable leak from ruining the printer. I usually place the printhead in plastic wrap (used to wrap food) to keep the ink from drying up, some times even this does not work.

Quality is what you'd expect from a 9 pin matrix printer from the 80s, only worse. I get much better printouts from my Epson MX-80 and FX-80 printers (and their HP-IB versions).

I have a stack of ThinkJet printers (mainly HP-IB units) I bought for their HP-IB to HP-IL bridge circuit and they been nothing but a disappointment. The only ThinkJet I try to maintain in some sort of working order is the one that is part of my Integral PC. I wish HP has used a thermal printer for that machine.

Best Regards

**vp


#12

Ho Vassilus,

Reason is pure sentiment journy. We used this printer later for producing the manauals for the Eramco MLDL boxes in the past.

At that time we had the Epson FX80 printer and later this one not making the rattlesnake noise but a nice zoem zoem. It was small, you could take it along easily, battery operated. It was a real gimmick (if that word already existed at time).

I know the ink is awfull, I had it last week by accident on my shirt, it took a chlorine to get it bleached again......

Kind regards.

Ronald


Possibly Related Threads...
Thread Author Replies Views Last Post
  Printing the HP Prime manual BobVA 3 730 10-25-2013, 09:53 PM
Last Post: BobVA
  3D printing custom molds Han 3 643 08-02-2013, 03:26 AM
Last Post: Bruce Larrabee
  Printing HP 9825 data Norman Pillsbury 3 698 06-01-2013, 10:08 PM
Last Post: David Ramsey
  Does IR printing not work on your converted WP34s? Then read on... Harald 3 728 04-04-2013, 05:46 PM
Last Post: Harald
  WP34s IR Printing Update? Thomas Chrapkiewicz 2 514 02-24-2013, 01:53 PM
Last Post: Marcus von Cube, Germany
  is there a printing error in the HP 50G Quick Starrt Guide? Al 12 1,300 11-23-2012, 07:07 PM
Last Post: Al
  WP 34S Printing Harald 15 1,466 04-28-2012, 08:54 PM
Last Post: Les Wright
  WP 34S: IR printing - update Marcus von Cube, Germany 79 4,829 04-25-2012, 11:24 AM
Last Post: Walter B
  [WP-34s] CAT documentation, manual printing DRAFT Alexander Oestert 10 1,152 04-05-2012, 02:48 PM
Last Post: Les Wright
  $1000 for a vintage HP 97 printing calculator aurelio 5 781 02-19-2012, 11:55 AM
Last Post: DavidShenk

Forum Jump: