Help ! HP-42S Invalid Type Error



#4

I have a 42-s that is giving an "invalid type" error whenever I attempt to perform ANY of the statistical functions (E+ or E-)- any of them. Other functions and features work fine.

This is bugging me as this is my workhorse and has been working for me without problem since the 80's.

Doug


#5

Ok, so how often does the same person that posted the question have the first response? Duh, Well I tried to clear the summation register and couldn't - same error. So I cleared everything (CLALL). Oh well, I can punch in the several programs I had later..

Then I got another error - Size error. So then I relocated the first summation register to R11 (default), and poof it works.... Whew !

In the process of this whole problem, I have discovered that there is a world of HP calc nuts out there (I guess I am now an accomplice too.) I am disappointed to dsicover that HP has discontinued the 42s. I can see why so many folks love it. I used to just think it was an old HP (dime a dozen) and I treated it pretty rough (a testament to its ruggedness. Now that I know I will probably pay more to replace it than I paid for it, I will treat it accordingly.


#6

Hi,

I tried to simulate in my 13-old and tired 42S the error you've mentioned on your help request

1- If your stack is empty and you enter a real number and use the E+/E-, the answer is the counting number of your entry.
2- If your x-reg has a complex number (i.e. -1 SQRT)) and you use E+/E-, the answer is the Invalid Type error message.
3- If your x-reg has a matrix (i.e. [7X7 MATRIX]) and you use E+/E-, the answer is Dimension Error message.
4- If your x-reg has a real number and y-reg has a matrix or a complex number and you use E+/E-, the answer is the Invalid Type error message.

It seems old 42S' E+/E- function uses two real arguments in x and y-registers. Try checking the contents of the y-reg in your program before using E+/E- function.

Hope it can help


Possibly Related Threads...
Thread Author Replies Views Last Post
  [HP Prime] "Error while checking exact value with approximate value, returning both!" Chris Pem10 13 1,227 12-06-2013, 05:12 AM
Last Post: parisse
  MS advert shows spreadsheet with obvious error BruceH 3 512 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  HP Prime - local variables retain their initial type BruceH 4 507 11-10-2013, 12:42 PM
Last Post: Michael de Estrada
  HP Prime: Rounding error in determinant Stephan Matthys 3 403 10-25-2013, 09:29 PM
Last Post: Walter B
  HP Prime Error: Summation Upper Bound > 1000 HP Pioneer 2 346 10-25-2013, 11:32 AM
Last Post: steindid
  Prime Error or Mine? toml_12953 12 1,002 10-22-2013, 10:35 AM
Last Post: toml_12953
  Explaination on How to Reset Caculator in Users guie: error Harold A Climer 5 568 10-15-2013, 02:11 AM
Last Post: cyrille de Brébisson
  Repair of HP-34C - Error 0 and Error 9 Jeff Kearns 3 400 10-11-2013, 12:29 PM
Last Post: Randy
  Do You Think a Listing Error Was Made? Jim Johnson 13 941 09-04-2013, 09:23 AM
Last Post: Eddie W. Shore
  [HP-Prime CAS] list[x,y,z], vector[x, y, z ] ... data type operation? CompSystems 1 308 08-22-2013, 03:30 PM
Last Post: Joe Horn

Forum Jump: