Display on early HP 41C



#2

Hello,

I am trying to see if I can repair an early HP 41C,
serial number 1952A01621. When I insert the battery pack,
all of the LCD elements turn on. I have tried the various
reset methods, shorting out the battery terminals, reading
a card, etc. to no avail.

I would welcome any additional suggestions.

Happy New Year,

Ion Abraham
Albuquerque, New Mexico


#3

The first thing is to find if the problem is with the display or the calculator.

1) turn calculator on
2) press USER -- does USER come on
3) press USER again -- does it go off
4) press SHIFT -- does SHIFT come on?
5) press 4 -- does calculator beep?

if it beeps, then the calculator is probably OK, and it's definitely the display.

Steps 2, 3, and 4 may not change the display if the display is broken.

It's probably NOT the display :-(

Does the back of the calculator seem loose at all?

It could quite possibly have broken posts internally that prevent the 2 boards inside from making correct contact. Squeezing the calculator together *may* temporarily fix this. Does the display change?

Do cards actually go through the card reader?

It's most likely you'll have to open the calculator up (4 screws under the rubber feet) to further diagnose and/or fix it.

Is there any corrosion in the battery compartment? corrosion can get into the innards of the calculator and stuff things up.

Sorry this is a little rambling. Hope it's of some assistance


#4

Steve,

Thanks very much for your reply. It seems the problem is
a bit more subtle than I had thought.
When the display is viewed at the "normal" 15-20 degree
angle off normal, ALL the LCD elements appear to be black,
but when viewed directly normal and even a bit back tilted,
the display does show that PRGM and ALPHA, for example, go
off and on. Numbers still do not show up properly, even
when viewed this way.
I tried the BEEP and it does NOT. The back of the unit
seems quite firmly attached.
I guess it's time to open it up and/or wait for my CD ROM
set with the service manual. It seems it's not just the
display.
Any other suggestions would be appreciated.

Ion Abraham
Albuquerque, New Mexico


#5

Hi Ion,

From my experience with these things, open it up, clean all the circuit board contacts with a good circuit board cleaner (I'm assuming it's a "fullnut"), check the screw posts are not cracked/broken, and reassemble, and more often than not the calc will then work fine. Cheers - John


#6

John,

Thanks for your reply. I actually did that after posting
my reply to Steve, and I really had high hopes, because
some of the circuit board contacts looked like they could
use the cleaning. The screw posts are fine, although one
of the other posts for the 1/4" nuts that hold down the
circuit board was stripped (they never should have put a
stainless nut on a plastic threaded post). Nevertheless,
I think the board is probably held down OK.
Alas, after all that, there was no change in behavior at
all. I am going to wait for my Museum CD-ROM set, which
apparently includes the 41C service manual. I would like
to try some board level tests.
I would also welcome any other suggestions, of course.

Best regards,

Ion Abraham
Albquerque, New Mexico


#7

OK, one last thing to try if your willing, unsolder the display and remove it. Then there's a couple of U shaped metal strips at the top and bottom that hold the display glass and circuit board together. In this old model, the material used to connect the glass to the circuit board is similar to the strips used to connect the CPU board to teh keyboard. Remove the metal strips, under the metal strips is a piece of plastic (insulation), and take the circuit board off. Clean all contacts (glass, circuit board, and connecting strips), and reassemble being sure to get the plastic insulating strips around the right way. Just think about this and it will become obvious. Once reassembled, solder it back in and give it a go. If all else fails I may have a part or two to help you fix it. Cheers - John


#8

John,

Thanks for your suggestion. I opened a second, more recent 41C I'm trying to fix, and I see the clips and all, so I am going to try the procedure you describe, especially because this one has some black graphite-like stuff behind the lens in the display, and one of the leads to the display was desoldered already. This more recent unit never did show anything in the display, despite repeated clear-enter-ons, but I have some hope after seeing the loose lead. I still think more is wrong than just the display, because BEEP does not work either, for example.

What it does do is emit a very loud and very high pitched sound when the batteries are first plugged in (after being without them for a long while). The sound then dies down but a very faint buzz is still audible as long as the batteries are plugged in.

Do you or anyone else know what causes this? I have seen this mentioned by others in the forum archive, but without any explanation.

I guess my foray into restoration is not off to a stellar start, but I wouldn't lose much either way. I bought these two 41C's as broken for not much money, and I got a really nice book out of it, "HP-41C/41CV Operating Manual - A Guide for the Experienced User," a short little book that summarizes some of the more interesting programming and operational basics (for the CX as well).

Still, I am waiting for the CD-ROM set, to see if the service manual has some more useful tests.

Best regards,

Ion Abraham
Albuquerque, New Mexico


#9

The high pitched squeal is a good thing. Take the batteries out and let it sit overnight then try again. Repeated pressing of the on/off rocker with the batteries out for about 1 minute is another try.
Sounds like at least one of the display solder tabs are not making the connection. The squeal is just there because you are trying to awake it from its' nap and doesn't want to!
Leave him/her alone for a night and try again. It still wants to sleep!


Possibly Related Threads...
Thread Author Replies Views Last Post
  Layout of arithmetic keys on early calculators Walter B 10 285 11-20-2013, 11:13 AM
Last Post: Jake Schwartz
  HP50G early days vs Prime early days? Mike Powell 7 189 10-09-2013, 11:17 AM
Last Post: Eric Rechlin
  HP-41c display problem Ignacio Sánchez 6 168 09-04-2013, 10:52 AM
Last Post: Ignacio Sánchez Reig
  May be a little early ... Walter B 5 152 12-09-2012, 05:04 PM
Last Post: Paul Dale
  Can the display for a HP32Sii be replaced with the display from another model? Bruce Larrabee 8 261 10-10-2012, 10:05 PM
Last Post: Luiz C. Vieira (Brazil)
  Non HP very early LCD Calc? Ian Phillips 6 216 10-06-2012, 01:57 PM
Last Post: Frank Boehm (Germany)
  Re: more HMS, aTIME, 34s display, 41c bugs? Christopher Johnson 0 57 03-05-2012, 11:20 AM
Last Post: Christopher Johnson
  more HMS, aTIME, 34s display, 41c bugs? Christopher Johnson 2 90 02-25-2012, 10:06 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-41C bad display - where to start from ? Alberto Fenini 8 233 02-12-2012, 02:01 PM
Last Post: aurelio
  A Very Early HP Calculator Connection Les Bell 2 107 01-18-2012, 05:15 PM
Last Post: John Robinson

Forum Jump: