How to Configure X25/ACC in HPUX 9000 with modems



#2

Hello,

I have two motorola 3266 Fast modems attached
to a z7400a mux (one on port 0:0 and the other on port 0:1) they are configured to work in sync mode connected thru a telephone leased line (so they are connected all the time).
I've tried two things:
1. First I tried with lapb_sample.answ that looks as follows:

************************************************************
*@(#)NACC lapb_sample.answ $Rev: /main/12 $"

#include "/opt/acc/cfg/ttgendefine"

ttgen

Configuration
system-name "ACC HDLC/LAP-B (ABM) protocol ttgen input file"
program-zlu 100
terminal-zlu 800
logical-term 800
physical-term 800
buffer-pool 3000000
logical-size 252
queue-Limit 200
transmit-limit 100
unack-limit 5000
port-limit 20000
* E1T1-Port-Limit 100000
node-entry 1

Interface-Definition
z7400a 0 0:8 /opt/acc/z7400a/hdlc.zabs

Port-Definition
Port 0:0 RS232 9600 Int SDLC X1 NRZ
Port 0:1 RS232 9600 Ext SDLC X1 NRZ
Port 0:2 RS232 9600 Int SDLC X1 NRZ
Port 0:3 RS232 9600 Ext SDLC X1 NRZ
Port 0:4 RS232 9600 Int SDLC X1 NRZ
Port 0:5 RS232 9600 Ext SDLC X1 NRZ
Port 0:6 RS232 9600 Int SDLC X1 NRZ
Port 0:7 RS232 9600 Ext SDLC X1 NRZ

Terminal-Definition
Term 10 0:0 HDLC.LAPB HDLC_DTE_400MS 1000 0 0 0 0 "HDLC link 1"
Term 20 0:1 HDLC.LAPB HDLC_DCE_400MS 1000 0 0 0 0 "HDLC link 2"

Node-Definition
Local-Node 123

End$
************************************************************

and zmasterd bring the x25server working. Then I used Zterm utility to verify the configuration and when I try to enable the link:

************************************************************
rc 10 20
cn 10 20 EN
rx
************************************************************

it replies with:
Link not established on enable
Link not established on enable

so nothing done...

2. Then I try to do the loop test: I've used x25_loop.answ that look as follows:

************************************************************
**ttgen input file /opt/acc/cfg/x25_loop.answ Created Wed Aug 30
18:03:06 PST 2000
**@(#)ACC sample_header $Rev: /main/6 $"
#include "/opt/acc/cfg/ttgendefine"

ttgen Configuration
System-name "ACC ttgen input file"
Program-zlu 100
Terminal-zlu 1000
Logical-Term 800
Physical-Term 800
Buffer-Pool 3000000
Logical-Size 252
Logical-Data 10 X25CNT,0,X25CNT_LDSIZE
Queue-Limit 200
Transmit-Limit 100
Unack-Limit 5000
Port-Limit 20000
Node-entry 1

Interface-Definition
z7400a 0 0:8 /opt/acc/z7400a/x25.zabs

Port-Definition
Port 0:0 RS232 9600 Int SDLC X1 NRZ
Port 0:1 RS232 9600 Ext SDLC X1 NRZ
Port 0:2 RS232 9600 Int SDLC X1 NRZ
Port 0:3 RS232 9600 Ext SDLC X1 NRZ
Port 0:4 RS232 9600 Int SDLC X1 NRZ
Port 0:5 RS232 9600 Ext SDLC X1 NRZ
Port 0:6 RS232 9600 Int SDLC X1 NRZ
Port 0:7 RS232 9600 Ext SDLC X1 NRZ

Terminal-Definition
Term 600 0:0 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 601 0:1 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 602 0:2 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 603 0:3 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 604 0:4 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 605 0:5 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 606 0:6 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 607 0:7 PORTTEST 0000h 0000h 99 0 0 0 0 "For Loopback Test"
Term 608 0:0 MONITOR 0000h 0000h 01 0 0 0 0 "Used for Watch
Feature"

Node-Definition
Local-Node 123
End$
************************************************************

and again zmasterd bring the x25server working. Then I used zx25init to
enable the link:

zx25init -c /etc/x25/x25configCPI_0 -a /etc/x25/ip_to_x121_map
(>>result)

and the same for the other

zx25init -c /etc/x25/x25configCPI_1 -a /etc/x25/ip_to_x121_map
(>>result)

and then the read data led from one modem start flushing and on the other modem the read data led stays on but on /var/opt/acc/log/xxx.tlog file it appears the same message: Link not established on enable.

Here file x25configCPI_0 and x25configCPI_1 :

************************************************************
#@(#)NACC x25configCPI_0 $Rev: /main/2 $"
#
x.121 408746500000
x.121_packetaddr 408746500000
device zx25m0p0
name natacc00
#
# Level 2 Parameters
#
t1 1600
t3 60000
framesize 149
n2 10
l2window 7
#
# Level 3 Parameters
#
networktype DTE_84
#
# Circuit Table Definition
#
# LCI TYPE HOW MANY
lci 1 pvc 2
#
# Flow Control, Throughput Class, Fast Select and Reverse Charge
Settings
#
flowcontrol off
thruputclass off
fast_select_accept disabled
reverse_charge disabled
def_inpacketsize 128
def_outpacketsize 128
def_inwindow 7
def_outwindow 7
def_inthruputclass 11
def_outthruputclass 11
#
# IP Parameters
#
ipaddress 130.9.192.0
idletimer 45
holdtimer 30
mtu 2048
************************************************************

************************************************************
#@(#)NACC x25configCPI_1 $Rev: /main/2 $"
#
x.121 408746500100
x.121_packetaddr 408746500100
device zx25m0p1
name natacc01
#
# Level 2 Parameters
#
t1 1600
t3 60000
framesize 149
n2 10
l2window 7
#
# Level 3 Parameters
#
networktype DCE_84
#
# Circuit Table Definition
#
# LCI TYPE HOW MANY
lci 1 pvc 8
#
# Flow Control, Throughput Class, Fast Select and Reverse Charge
Settings
#
flowcontrol off
thruputclass off
fast_select_accept disabled
reverse_charge disabled
def_inpacketsize 128
def_outpacketsize 128
def_inwindow 7
def_outwindow 7
def_inthruputclass 11
def_outthruputclass 11
#
# IP Parameters
#
ipaddress 130.9.192.1
idletimer 45
holdtimer 30
mtu 2048
************************************************************

can anybody help me ???

Goncalo Valadas
Edisoft, S.A.
Lisboa-Portugal


Possibly Related Threads...
Thread Author Replies Views Last Post
  $9000 HP-35 on TAS Mark Henderson 21 1,529 01-06-2011, 02:12 AM
Last Post: Walter B
  OT: CP/M-68K for HP 9000 Series 200 computers Juergen Keller 5 514 09-22-2010, 10:09 AM
Last Post: Olivier De Smet
  Re: O.T.: HP 9000, HP 9133 programs Peter Walker 0 194 08-16-2006, 12:28 AM
Last Post: Peter Walker
  O.T.: HP 9000, HP 9133 programs Ed Look 8 745 06-28-2006, 01:44 AM
Last Post: Vassilis Prevelakis
  HP 9000 Server for $49 :-) gileno 1 256 10-27-2005, 04:23 PM
Last Post: Frank Wales
  Jornada X25 Linux prototype : has anyone seen on sale ? Pascal 4 505 10-08-2003, 02:39 AM
Last Post: Pascal
  configure of HP 12 C Platinum Luc 1 206 06-27-2003, 06:06 AM
Last Post: Bill Wiese
  HP X25 - "Calypso" Y K Wong 0 171 10-29-2002, 12:48 AM
Last Post: Y K Wong (Singapore)
  Jornada x25 on eBay... Raymond Del Tondo 1 275 03-08-2002, 11:05 AM
Last Post: J.Manrique
  PCL5 command to configure raster data augais 0 228 02-22-2002, 10:29 AM
Last Post: augais

Forum Jump: