HP41CX doesn't turn on



#2

Hi

I own a HP41CX I bought three years ago and since then it has always functioned correctly. I haven't used it on the last year so I removed the non-rechargeable batteries to prevent from corrosion and stored the calculator on a safe place. Yesterday I picked it up again and placed the old batteries and turned it on. It showed the MEMORY LOST message for about half a second and then the message faded and the calculator seem to be DEAD! I've replaced the old batteries with new ones, but the same: after placing them I turn it on and it shows the message and then fades and nothing more happens.

Has someone an idea what could be wrong? I hope the calculator is not damaged of being not used!

Thanks for the help
Ralph


#3

I've been reading a bit on the MoHPC article about batteries and says for the 41CX they must be N cells. I've looked at the ones I bought: The model is VARTA 4001 . LR 1 Alkaline (1.5 V). Now I'm not sure if they are the right ones for the calculator...the size of them is correct, however.

Ralph

#4

Hi, Ralph;

I own five working HP41, one of them (HP41C) is with me since it was bought new in the beginning of the 80's. All I can tell you is that I experienced some cases like this, where you insert batteries and they momentarily charge the capacitor built in parallel with them. Because of bad contact (battery holder springs with residual corrosion, batteries main contact set, even contacts between IO/Batt assembly and mainboard...), the batteries do not feed the mainboard circuitry after they are in place, so the remaining charge in the capacitor is enough to power the calculator up time enough for you to see MEMORY LOST message fadding. In all cases, I cleanned each part I mentioned above, same sequence, and tested the calculator. I don't recall any unsuccessful attempt. In two or thee cases I had to reduce the spring pressure by "deforming" them slightly; some springs force the IO/Batt assembly too much when and after the bettries compartment is inserted.

If you need to open the calculator there are some helpfull hints here, but I'd try some "external" cleanning mostly if you have not done this before.

Let us knwo what happens next.

Success!

Luiz (Brazil)


#5

Hi Luiz,

I have repaired it. I've clean all contacts and have observed the springs that hold the batteries make a great force. So I have put the battery holder in place but just pressing it so that all four batteries made contact. I've then turn the calculator on and it worked fine (nice to see the 0.0000 again). The solution has been deforming the springs a bit so that they don't press with too much force. So easy!!

Thanks very much for the help!


#6

#7

Your battery type is ok - I use the same ones. And I have discovered that the battery holder of older HP41 is somewhat tricky to insert. On my two HP41s I have to adjust it smoothly every time I change batteries. Even after cleaning all contacts with a fiber pencil eraser it has to get the correct pressure on all contacts.
It seems to be the same problem with your calculator.

Best regards

Stefan


#8

Before that I had only changed batteries on my HP-41 once, but now I'm getting familiar with the holder, as you say if it doesn't makes the correct pressure the calculator won't turn on.

Thanks for the counsel.

Ralph


Possibly Related Threads...
Thread Author Replies Views Last Post
  emu48 - copy stack doesn't work (as expected) Thomas Radtke 2 468 11-11-2013, 02:19 PM
Last Post: Thomas Radtke
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 840 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  HP Prime: Slow turn off Paul D. Fox 1 243 10-09-2013, 08:39 PM
Last Post: Tim Wessman
  HP41CX: Strange serial #... Stephan Matthys 1 237 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  Anyone got a 39gII and doesn't mind memory loss? bhtooefr 4 378 05-19-2013, 03:57 PM
Last Post: bhtooefr
  Repaired HP-97 card reader doesn't show any signs of life jbssm 6 549 02-17-2013, 03:15 AM
Last Post: Alberto Fenini
  Using PIL-BOX & ILPer to Transfer Programmes from PC to HP41CX? Michael Lopez 5 416 06-25-2012, 09:31 AM
Last Post: Michael Lopez
  Can't turn on HP 15C Laci 4 350 03-23-2012, 03:54 PM
Last Post: uhmgawa
  HP-41CV Doesn't go into PRGM or USER mode Matt Agajanian 4 307 03-15-2012, 11:39 PM
Last Post: Matt Agajanian
  Vintage HP15C Key Clicks but Doesn't Register Bruce Zastera 15 772 01-27-2012, 06:18 PM
Last Post: uhmgawa

Forum Jump: