67 display failure - npn transistor array replacement



#4

I think I tracked down the origin of my faulty 67 to the 1858-0050 npn transistor array on the keyboard pcb. The machine pulls 150mA, but the display is blank. The logic board works in another machine, the cathode driver 1820-1749 has a 5ms period signal on the RCD line and a 1ms period signal on the strobe, so I figure it's ok. I know the 1858-0050 is a standard array, but I was unable so far to come up with the pinout. What bothers me is that the low battery output doesnt work, even if i lower the voltage down to 1.5V - it's not driven by the transistor array, so if my diagnosis is correct at least the led should come up. What's wrong with my diagnosis? Any help appreciated.

Andraes

Andreas

Edited: 12 Dec 2004, 1:14 p.m.


#5

Hi Andreas,

The normal 1858-0050-1D spare part is a RCA IC: CA 3082 NPN Transistor (Tr) array Common Collector (obsolete product). You can find the pin out serching via Google (a *.pdf file); anyway, following the "raw" pin out version:

1 Em Tr1
2 Em Tr2
3 Ba Tr2
4 Em Tr5
5 Substrate
6 Ba Tr5
7 Em Tr6
8 Ba Tr6
9 Em Tr7
10 Ba Tr7
11 Ba Tr4
12 Em Tr4
13 Ba Tr3
14 Em Tr3
15 Common Collector
16 Ba Tr1

Good Luck!


#6

Thank you, got that. It is the strangest thing: All emitters show pulses on the scope, but the display is blank. I'll keep searching...


#7

...if I interpret what I read on the forum correctly, this is it for my 67: AFter replacing the 1858-0050 with a CA3082 array, the display comes up with 0.00, but the keyboard does not respond. If I'm not wrong, this means the 1820-1749 cathode driver, which also generates a clock, is dead...STB and RCD work though. IS this the end? Using a 2nd logic board shows the same behaviour.

Sadly
Andreas


#8

If the clock was bad, then the display would not show 0.00

#9

Hi Andreas,

I'm very sorry but my "wisdom" regarding Timing Diagrams is limited. Perhaps someone could help you on the right way.
Good luck!

#10

The cathode driver doesn't generate the clock. In Classics, the clock is generated by the anode driver, but the 67 is not a classic inside, it's a Woodstock. And on Woodstocks (and for that matter Topcats and the 19C), the clock generator is in the ACT CPU chip.

If you're getting a sane display (0.00, for example), then the clock is running. In fact the ACT, ROM0, anode driver transistor array and cathode driver are all at least partially working.

Now, in the 67 the keyboard is scanned by the cathode driver outputs, and feeds into 5 inputs on the ACT chip. Since you've swapped out the logic board (including the ACT), I would assume the ACT is good (at least for the moment), and the cathode driver is doing something.

Have you checked for a short in the keyboard matrix (for example, a key that's electrically pressed all the time). I'm pretty sure that will disable the keyboard on these machines. If you have the pinouts and a 'scope or logic analyser, look at the 5 KA...KE pins on the ACT or on the keyboard-logic board connector. They should all be 'dead'. If you get a signal on one of them, you've got a key shorted.


#11

Tony,
you brought me back on track. I measure 6V on KC1 to KC4 and
0V on KC5. I suppose that means KC5 is permanently pressed...I have to find where this comes from. The keys look ok. As long as there's hope! Thank you so far

Andreas


#12

I think the next thing to do is to find out what KC5 is shorted to. I would guess it's either ground (which you can find at the -ve side of the battery pack) or one of the outputs of the cathode driver.

Do this test first with the keyboard/chassis plate screwed in place in the top case. I remember a nasty fault (that took me a long time to track down) where one of the battery contacts shorted to a trace on the keyboard PCB when the machine was assembled.

Anyway, it sounds like it should be repairable.


#13

I have seen several shorts in classics caused by incredibly small slivers of fractured key strips. You can't see them with the naked eye. They seem to get stuck in the upper area of the board, above the top row of strips. Perhaps the old sticky switch grease is a contributing factor. A good wash with isopropyl usually flushes them away.


#14

Gentlemen and fellow collectors, I am pleased to announce that through your expert advice I was able to repair my 67. The problem was indeed due to a battery contact shorting a trace on the keyboard/display pcb. Once I realized that, I felt stupid for not having been able to identify the cause myself. Thank you again for your most useful help! Now more daunting tasks lie ahead - with a working 67, I should be able to restore my second 67 with a defective anode driver (so I do think), and if I am courageous enough, the dead 9010 waiting to be repaired for several months now, for which Tony was so kind to send me schematics. GEntlemen, it's been a pleasure! Long live this forum.

Andreas


Possibly Related Threads...
Thread Author Replies Views Last Post
  A prime failure Jan 17 1,356 12-06-2013, 08:02 PM
Last Post: Michael de Estrada
  IR printer failure Andrew Nikitin 7 699 11-05-2013, 11:25 AM
Last Post: Andrew Nikitin
  HP Prime: How to use a large array in a program? HP Pioneer 2 293 10-27-2013, 03:15 AM
Last Post: steindid
  HP Prime Program: Sampling Without Replacement Eddie W. Shore 13 968 10-04-2013, 12:22 AM
Last Post: Joe Horn
  HP48GX screen replacement Francisco Quiles 9 829 10-03-2013, 09:17 PM
Last Post: Francisco Quiles
  HP 2225D+ RAM failure/replacement Luca 4 541 09-10-2013, 01:46 PM
Last Post: Luca
  HP 15C-LE replacement still available? Borja 16 1,277 08-22-2013, 11:16 AM
Last Post: Michael de Estrada
  Battery replacement HP75C Chris H (UK) 1 301 08-05-2013, 11:02 AM
Last Post: Sylvain Cote
  [HP -Prime CAS] List, Matrix, Vector as one Array? CompSystems 0 214 07-26-2013, 05:22 PM
Last Post: CompSystems
  17bii failure db (martinez, ca.) 5 480 01-16-2013, 03:12 PM
Last Post: Jeff O.

Forum Jump: