15C all functions work, but can't self test


I have an old HP 15c that I "inherited" from my uncle.
I'm trying to learn to use it and though it seems to execute all the functions properly, I cannot get it to do the self test or the keyboard test.
Instead of it going into test mode, it just turns on.

I know to hold down the x key, then press the "on" key, then let go of the x key, but no joy.

If anyone could help, I'd appreciate it.

Thank you.



maybe you mixed up the order of keys you have to press/release.

Before initiating the key sequence,

the calc has to be turned off.


1. Press and hold the 'x' key.

2. Press and *release* the 'ON' key.

3. Release the 'x' key.

Now the self test starts. After finishing, all segments are lit.

To return to normal mode, just press any key.



Edited: 27 Aug 2004, 1:51 a.m.


Yes, I'm sure I've done the sequence correctly,
In fact, I just put in a new set of Duracell batteries and tried the test again and it worked like a charm.
However, after getting it to work once, I now cannot get it to do it again!

Very frustrating :/

Thanks for your help though.


Strange as it may sound, chances are you have a bad memory backup capacitor. Take the batteries out for 30 seconds, then put them back in. If you see PR ERROR, you have a bad capacitor. The capacitor should hold memory for at least five minutes so the thirty second test is usually enough to determine if it's a problem.

The value of the part is 22uf but it can be a standard radial leaded electrolytic or a surface mount tantalum - it depends on the age of the unit. I've never seen a tantalum fail, only the standard electrolytics.


Found the problem. I was trying to make it do the test again immediately after a test. If I just let it sit for a minute, it can do the test again perfectly.

Possibly Related Threads…
Thread Author Replies Views Last Post
  emu48 - copy stack doesn't work (as expected) Thomas Radtke 2 1,963 11-11-2013, 02:19 PM
Last Post: Thomas Radtke
  [41CL] New Extra Functions version Monte Dalrymple 0 1,107 11-08-2013, 04:32 PM
Last Post: Monte Dalrymple
  Another Prime mystery - templates don't work anymore Michael de Estrada 2 1,337 11-02-2013, 11:34 AM
Last Post: Michael de Estrada
  HP Prime: in need of help with defining functions Alberto Candel 14 4,326 10-27-2013, 10:48 AM
Last Post: Alberto Candel
  HP-42S ESD self-test Yriarte 2 1,559 10-24-2013, 09:08 AM
Last Post: Yriarte
  Does the HP Prime software only work with Win 7/ 8 ? Michael de Estrada 3 1,669 10-12-2013, 02:52 PM
Last Post: John Ioannidis
  HP Prime spreadsheet functions SanS 0 1,903 10-04-2013, 04:23 AM
Last Post: SanS
  So I took a test with my Prime today ... kris223 12 3,490 09-25-2013, 07:19 PM
Last Post: kris223
  Stats functions on the HP34S Nicholas van Stigt 5 2,017 09-24-2013, 02:45 AM
Last Post: Nick_S
  Trig Functions Howard Owen 11 3,503 09-16-2013, 02:53 PM
Last Post: Fred Lusk

Forum Jump: