97 Card Reader Problem (NOT gummy problem)



#7

I got around replace the gummed-up roller on my HP97 back in ~93' with silicon fuel tubing, read/write worked great! I used the HP97 on and off for the next couple of years, and then it sat as a display piece from 96 till beginning of this year. Now, I keep getting an ERROR msg when loading a card. I can write to a card a short program, and I don't get any problems at all (ie, display goes back to normal), but the same card that had been written on can't be read! I've tried a dozen or so new cards to no avail. Battery pack is new rebuilt, and I have adapter on when write/read.

The only clue I've had is: on writing, I can hear the motor go Wrr-Wrr-Wrr-Wrr, about 4 oscillating cycles. When I read ANY card, I notice that the motor goes Wrr-Wrr-Wrr-Wrrrrrrr, spits the card out then gives me the ERROR message.

Any clue what's going on? HELP!!


#8

Uneven sound means uneven transport speed, which can be the cause behind the symptoms you see.

The uneven sound from the card reader can be a result of two factors (or a combination of them): a deformed transport wheel, or a defective "clutch" mechanism.

Since you used silicon fuel tubing (my favorite) I suspect that your transport wheel is okay, but the clutch mechanism is shot. In my experience, it is okay to permanently attach the worm gear to the motor shaft, which will probably solve the problem.


Viktor


#9

Some silicon tubing can leach silicones which could affect transport of the card through the machine. Might want to try surgical tubing which grips well and has a good surface texture. A tiny dab of epoxy to permanently attach the worm gear shaft to the motor shaft has worked for my repairs on a 67. just dip the shapt into the epoxy, a very small amount goes a long way! I feel in your case the tubing you used may need replacing.

Good Luck!

#10

It sounds like your home made roller is out of round. You should get a smooth whirring sound and not a whir-whir-whir sound.

#11

Many thanks for the numerous suggestions! I will try and find sometime this weekend to open up the 97 and probably do the following:

* Check integrity of roller, approximate roundness (micrometered).
* CA or epoxy worm gear onto motor shaft.

I have been thinking that it might be related to off-round roller, since the 4 cycle wrrr's would seem to coincide with the circumference of the roller (will have to measure out when it's opened).

I did suddenly realise that replacing the roller back in 93 looks more complicating that I'd imagine/worked it to be! Esp after reading the 41 card reader restoration article - I have 2 41 card reader that require new rollers also.

Anyways, will get back to this forum as to my results.

#12

I would also make sure that there is no residue on the small nylon idler roller. This can cause the irregular motor motion.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Prime Emulator Connection Problem John Colvin 3 363 12-14-2013, 11:00 PM
Last Post: Han
  Reasonable price for a 41C, Quad Mem, Time, Navigation and Card reader module? Eelco Rouw 10 710 12-12-2013, 01:52 AM
Last Post: Eelco Rouw
  hp-67 card reader problem. Marcel Samek 5 433 12-09-2013, 09:09 PM
Last Post: Paul Berger (Canada)
  Strange HP 25 Problem (Repair) Onur Ilkorur 5 394 12-06-2013, 05:13 PM
Last Post: Onur Ilkorur
  HP Prime: problem with the memory of calculator during the debug process? Carlos CM (Mexico) 7 507 12-06-2013, 12:34 PM
Last Post: Carlos CM (Mexico)
  Problem with debug HP prime program, somebody help me? Carlos CM (Mexico) 6 499 12-05-2013, 03:07 PM
Last Post: Carlos CM (Mexico)
  [HP Prime] Using n-root symbol and exponent problem uklo 7 413 11-11-2013, 01:39 AM
Last Post: Alberto Candel
  [HP Prime] CAS font problem Thomas Ritschel 1 204 11-08-2013, 09:43 AM
Last Post: Javier Goizueta
  HP Prime - Variable problem bluesun08 12 627 11-07-2013, 11:34 AM
Last Post: bluesun08
  WP 34s : An old problem coming back Miguel Toro 2 250 11-05-2013, 03:00 AM
Last Post: Marcus von Cube, Germany

Forum Jump: