HP 41 emulator problem



#2

After not using my 41 emulator for a while, upon accessing it to write a program I get the message: "Unable to load the font file: LCD.fon." Upon clicking OK, I get another message: "Unable to load font file LCD4.ttf." Upon clicking OK, the calculator comes on but the display is garbled. Anyone ever have this problem? Although I've tried several fixes recommended by the developer, none of the fixes so far have worked. Need some help here, folks. Thanks.


#3

Hi;

the LCD4.ttf is a True-Type® font necessary to show information in the display. There's a way to get it back, but you need to find the original zipped file with the emulator files, unzip them and use Windows Control Panel, Fonts application and manually install the LCD4.ttf font back. It's more likely that somehow this font has been erased or uninstalled from your current system (have you upgraded it lately?). The process of restoring it is easy, you just need to have the TTF file.

Have you found it but succeed, post a message again and we'll try to step you through the solution.

Best regards.

Luiz (Brazil)

Edited: 31 May 2004, 12:01 p.m.


#4

OK, I did that. I took the font sent to me by the developer and copied it into the font bank (control panel, etc) and rebooted. Also, LCD4 shows as being present in the V41 emulator file (Program Files, etc). Still same error message.

#5

Jim, this has happened to me, too. It's apparently connected to updating (which I do fairly frequently). Rather than repair the font file, I simply uninstall and re-install the emulator. Although this may not be necessary, my experience is that you never know what other mischief may have occurred. A clean install resolves all issues...


#6

I did this. The V41 program does not have an "uninstall" feature but I deleted the file and then reinstalled it to no avail. Apparently the LCD4 font is present, the message is just saying that it can't load it. What I suspect is that that something in regards to trouble I had recently with a new HP printer driver. I bought a new printer and had to download a new driver. It didn't want to work. A repair shop was unable to help. So I sat down one day and tried everything possible. I finally got the driver to load and the printer now works. ?????? I don't know what I did right or wrong. You know how those things go. Supposedly other apps are not supposed to interfere with this emulator program but when it works one day and the next day it doesn't, something strange is wrong.

#7

This problem arises when the SP4 update to Windows 2000 is installed. The emulator developer has a corrected font on his web page that will do the trick. You will have to delete the old font from Windows 2000 and install the new one. You may still get the error message but the emulator should work fine after the new font is loaded.


#8

The developer is aware of the problem and what you're suggesting is one of the first things we tried. I'm using Windows ME but supposedly that's not an issue. I will continue to work on it and report if I make any progress. I appreciate everyone's help.

#9

Jim:

Actually v41 does have an "uninstall". Unless something really trashed your files you should be able to go to START->SETTINGS->CONTROL PANEL->ADD/REMOVE PROGRAMS scroll the window down to find "v41" and click on the "CHANGE/REMOVE" button.

I've run v41 on all Windows O.S's from Win98 to XP professional. It is true that Win2000 needs one different file but Warren does provide instructions. Windows ME--for me--installed both the current vs.7 and the vs. 8 beta without problem with the current installers available on "the other site".

Also, if you just uninstalled the font file and the executable you probably haven't cleared all the used files.
Even clearing the program's folder--usually in "Program Files" may not clear all the ".dll" files as some could be left in the Windows or Windows/system(32) folders.

The best way to clear out everything is to download the latest files then install them. Because font files and dll's are considered system files be sure that in a ME system the "System Backup and Restore" is turned off before you start. This is Microsoft's way of protecting us from ourselves and will save and restore system files it things you shouldn't be deleting. If you delete a "system" file--outside of an "unstall script" -- the OS will often save it and restore it. It can even "restore" over a newer, just installed version.

When the installer asks where to install to: be sure that the new install is directed to the existing program directory. After this do a re-boot (it's Windows after all!) and then go to the control panel and uninstall the program. Re-boot again, and check that all references to v41 are removed from the system: any lingering folders, etc. Oh, also be sure you purged the "Trash Bin" so files are really gone.

Finally, reboot again (you know, Windows!) and then run the Window's "Error Check"(i.e.scandisk) tool and the defragmenter tool.

After all this you should be able to re-install the latest version without problem.

By the way, don't blame Warren's software. Things like this are generally Window's problems and as with most Windows problems are a b.tch to fix.

#10

I have a similar problem with V41 after changing over to Win2000. I never got the font to work properly, but I found that by going into the "Settings" menu (found under "Options" in the menu bar), and unchecking the "Use TrueType LCD Font" option, I got the emulator to work again. The display isn't as realistic as before, but it's no longer garbled and it appears to run ok.


#11

I tried this early on at Warren's behest and while the display did change, it still wasn't right. I am currently investigating what David Y. recommended to see what that yields.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Prime Emulator Connection Problem John Colvin 3 269 12-14-2013, 11:00 PM
Last Post: Han
  HP-41(CL): The easiest way to transfer FOCAL programs from a Linux PC to the HP-41 Geir Isene 13 676 12-05-2013, 02:40 AM
Last Post: Hans Brueggemann
  Problem loading library into emulator Tom Grydeland 2 158 09-08-2013, 08:42 AM
Last Post: Marcus von Cube, Germany
  HP-17bII+ emulator problem (TW?) fhub 7 292 06-23-2013, 09:57 AM
Last Post: Olivier De Smet
  HP 12c Platinum Emulator Activation Server Problem Danny Farley 5 242 04-09-2013, 09:13 PM
Last Post: Danny Farley
  I am back ;) with a problem on HP 41 ;( wildpig 7 315 07-09-2012, 11:30 AM
Last Post: Mike Morrow
  HP-15C LE Emulator Problem Namir 26 792 09-12-2011, 05:12 PM
Last Post: Marcus von Cube, Germany
  HP-41 / EMU41P emulator query John AS (UK) 4 180 03-04-2010, 06:19 AM
Last Post: Ángel Martin
  HP-41 Card Reader NOT gummy wheel problem Rich Forest 19 601 01-12-2009, 10:59 AM
Last Post: Ignazio Cara (Italy)
  How common is the HP 41 emulator card for 48SX? Keith Beyer 4 180 11-19-2008, 04:15 PM
Last Post: Geir Isene

Forum Jump: