HP-41CX Needs help


Hi, I recently got a barcode reader for my HP-41CX, and I tried using it with my setup. I had a card reader, and a Clonix module installed. I used a simple "configuration builder" posted on some website to make My Clonix config, because I'm just learning the ropes and not so good at all the fancy configuration options.

Anyway, I plugged in the barcode reader into port 3, and it locked up the calculator. I think there was a address conflict or something? At any rate, Port 3 on the 41CX no longer works, it just emits a high-pitch buzzing sound anytime I plug something into it. I tried a continous memory reset, and even removed the battaries to totally kill the main memmory, yet nothing worked. I've put the calculator away for now and decided to seek profesional help, before I make a bad problem worse.

Can anyone explain to me whats going on? I need a solution pretty quickly here, because I need to use this on a test in a few days.


Edited: 23 Apr 2004, 9:33 p.m. after one or more responses were posted



not sure if it's the solution, but you could try to clean the contacts with a dry Q-tip. Take the batts out for safety first.

And you could take a look at the contacts of the wand plug.
Is one of the contacts sharp edged, or otherwise damaged?



Everything is in like new condition... It's... Well, weird. The buzzing sound is coming from the lower side of the calculator, right under the label that displays the alpha abilities of the keyboard.

I'll try cleaning it anyway... Hope it works. :/


Hi, Raymond;

I usualy hear this mid-to-high pitch (audible) "buzz" when putting batteries in some halfnut 41CV after leaving them resting for some days (your location is correct: for full- and halfnuts, this is the region where a coil is located). In this case, they don't switch to ON and it's necessary to remove and reinsert the batteries once or twice. And this happens when there is nothing connected to the calculator.

I also heard this same buzz other times when inserting some modules in some particular ports, like it happenen a few times with a card reader. Everytime I plugged the reader in one particular 41CV it started the "buzz" and crashed: [MEMORY LOST]. The same reader in other calculators worked fine.

The "remedy" was opening the calculator and cleaning the contacts between the IO/BATT assembly (one single piece) and the keyboard PCB. At least two contacts have different arrangement on each port, sort of a "two-bit" addressing; if one line for these contacts has a bad contact, two ports may share the same addressing and the system may result in "bus lines short circuitted". Think of two different devices that share the same data bus being "read" at the same time (same address for both, in this case) and one of them sends a "zero" while the other one sends a "one" in the same data line... I guess you know what is this about.

What I have no idea is how the Clonix ROM "shares" port addresses with ordinary, standard devices. At this point. I stuck.

My 2ยข.

Luiz (Brazil)

Edited: 24 Apr 2004, 3:43 a.m.


I have also heard this sound when inserting batteries;
I have associated it with partly drained batteries,
although that is just a feeling, nothing solid to
support it.



Back then in the fullnut days, it helped to perform a BEEP.

AFAIR, the sound sourced from the CPU T register, when it wasn't reset correctly.


Possibly Related Threads…
Thread Author Replies Views Last Post
  41cx to 41cx over HP/IL? steve 8 2,235 02-17-2003, 08:55 AM
Last Post: Christoph Klug

Forum Jump: