Cardreader behavior



#10

Good morning to all.
Yesterday my cardreader showed a strange behavior. It accepts card wrighten long ago and I am able to work with those programs.
Yet, when I wright a card it does it all right, this shows me the "xeq ver" operation. The display shows the correct letter "P" for program and the correct track which is only 1 in this case. But then it refuses to read the card wrighten before to its memory. The wording "working" flashes but in the end the calculator left me with the same amount of memory and the program was not in the CAT 1. The programm its self is functional as I have the program in Barcode and tryed to transfer it via the calculator to a magnetic card.
Has anybody a solusion/conclusion to this? Thank you very much in advance for your help. Stephan


#11

You have probably written an empty card. To write a program to magnetic cards, position the calculator at the program you want to write (by pressing GTO.prgm_name or by using CAT 1, then stopping at the program in question), switch to PRGM mode and insert the card. Make sure the write protect tab has not been cut away, else you will have to set flag 14 (SF 14) to overwrite the card.

Does this help?
Cheers, Victor


#12

Do you have enough free memory in you HP41 to accommodate loading the program stored on the card?

**vp


#13

Hi Vassilis. Thank you very much for your thoughts to my problem. It looks to me the calculator has enough memory indeed. There are only two other programs (Distance conversion and Great Circle Navigation) in memory of my CX at this point in time. The temperature program of concern is not very big, or let's say long. As a matter of fact the program is stored already. Brought into the calc via the barcode reader. Yet I' ve tried to write it to the card and deleted the program after I've writhen it. Trying to get it back into memory via the cardreader, this procedure failed. The card its self is recognized by the calc all right as it prompts for the correct card kind and tracks. But the program won't be loaded to memory. I am a little bit clueless here. It seems to write on one hand (XEQ VER) but seems to fail on the other (no program). Greetings Stephan

#14

Hi Victor, thank you very much for your advises. Just to make sure I didn't miss a step I've tryed again to wright a card. Same result. The calculator shows me - by verifing the card - there must be "something" on it. Showing "P" for program and the correct amount of tracks. But you are right, it looks like a blank card when I try to reload the program. Is there a possibility that I own old, say unmagnetable cards? Greetings Stephan


#15

No, if your card would not keep magnetization, you'd be receiving checksum errors.

Some things to try:

- Make sure the calculator is positioned in a program that actually contains something. For example, make a short program containing only a few lines, save it to an empty card, delete it and try to reload it from the card. Does this work?

- Check the available memory, as Vassilis suggested. Press GTO.., then switch to program mode. You will see '00 REG xxx', xxx being the number of free registers. One card track can hold up to 16 registers, so if your program has 4 tracks, you will need at least 49 and up to 64 registers for it. To increase the number of free registers, either delete a different program or decrease the SIZE (using the SIZE instruction). BTW, do you see 'TRY AGAIN' after reading in a program card?

- Test the card reader with a card that has never been written to (will show 'CARD ERR' or probably 'CHKSUM ERR' when checked with VER). Write a program to it and see if VER displays the correct type afterwards. Alternatively, you can take a card of known type (let's say, 'P') and write something else onto it, like data (using .015 WDTAX) or Status information (using WSTS), and then check if the new type gets displayed by VER. If not, your card reader is most likely not writing anything. If you see the correct type and still can't read back your programs, then we'll have to think of something else...

Hope this helps. Keep us posted.
Cheers
Victor


#16

Hi Victor. Wow, quite a lot of things to do. Give me 2 days and I'll be back with the results. Thank you so much for your help. I let you know by Friday about the outcome. read you later:-) Stephan

#17

Good morning Victor. I have done the procedures you suggested. Here the results: The card reader seems to write. It showed "card err" with a blank card. Taken the blank card, it showed "type S track 1" and "type S track 2" for the WSTS procedure. Overwriting the card now with my program, it showed "type P track 1", but didn't reload it to the calculator.
I do not know, if there must be a special procedure or some flags has to be set for a program to write? But as I gathered from the manual (yes, I do read them not only for calculators) the only thing I have to do is to set the calc to the program in question and switch to program mode. Now sliding the card through should do the trick. It looks to my that my program causes the problem. But then why does the correct type and tracks show up on the display? If you have a clue or maybe another "thinking approach" to this let me know. Thanks again very much in advance. Stephan


#18

Hmmm... this is getting stranger and stranger. Is it the same with any program you want to write to card, or just a particular one?

And, of course, to read the program back in, you switch to RUN mode (*NOT* PRGM)....

If this all fails, write a short program to card and send the card to me, I'll check it with my own card reader. Then we'll know if there's something on it or not. I live in Switzeland too, so that would be easy... I'll send you my address via email.

Maybe someone else in this forum has an idea what the problem could be?

Cheers, Victor


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP PRIME : strange behavior when trying user key capability Damien 12 1,713 11-03-2013, 11:02 AM
Last Post: Joe Horn
  Prime formatting behavior Camille 0 390 09-28-2013, 05:37 PM
Last Post: Camille
  wp-34s (Inconsistent Behavior) Barry Mead 2 580 07-23-2013, 02:54 AM
Last Post: Marcus von Cube, Germany
  HP-41C Tall Keys Strange ON Behavior aj04062 3 756 12-02-2012, 06:49 AM
Last Post: aj04062
  Weird behavior from lithium AAs Dave Britten 4 679 11-14-2012, 06:22 PM
Last Post: Lars Bergström
  HP15C strange complex number behavior Mike W 5 868 09-11-2012, 04:36 PM
Last Post: Mike W
  Curious SINPLOT behavior on HP71B Christoph Giesselink 4 764 07-12-2012, 03:12 PM
Last Post: J-F Garnier
  HP 67 and 97 odd behavior- HELP Fouad M. Kaadou 4 690 11-23-2011, 12:30 PM
Last Post: Fouad M. Kaadou
  OT weird cursor behavior Martin Pinckney 10 1,251 10-17-2011, 10:54 AM
Last Post: Paul Berger (Canada)
  15C LE - weird self-test behavior Katie Wasserman 0 332 09-19-2011, 11:52 PM
Last Post: Katie Wasserman

Forum Jump: