New bug?


Decided to take 5 mins off and read the manual and follow some of the examples to refresh my brain.

Tried typing "1234567890123456" to see what it did, i.e. whether it was an integer or a float.

I got to about '6' and the calc powered off as if it had lost battery power or I had OFFed it. (Batteries are fresh as of last night).

Turned on again and repeated test numerous times...but didnt reproduce the 'glitch'. Havent seen anyone else report this, but just in case.

I havent had any issue with the keys being too hard or different...strange. I put it down to Solar Flares for now.


Was playing around with APPS and looking at the ALG menu and went to CANCL the popup and the calc hung hard. ON-C didnt do anything. Had to hard reset it.

Either this calc suffers from static (got a static spark when touching the hifi a minute or two after this activity) or them bugs are really opening up on this baby.


To help others see how to find this bug, you didn't provide enough info to replicate it.

"playing around with APPS"

Were you in the APPS choose box? If so, how did you access the ALG menu? Press the RS ALG key? Go through the APPS choosebox to the calculus menu then the algebra menu?


I'm using ROM 1.22 and just did:



ENTER (Enters the CAS menu)


ENTER (Enters the ALG menu)

and I can press CANCEL very easily without a crash.

If you did something else, help us replicate the "bug" report.


Sorry - I am not being specific enough. It very much surprised me and it was difficult to know exactly what I did. I was defintely playing with CHOOSE boxes which I have done plenty of times before.

I am not necessarily looking for help here..I am trying to be deliberately thick (not hard for me!) and just bash about and learn whats on all the menus.

I raise these here in case others see similar issues and dont want to feel alone.

It upsets me that the HP48SX was brilliant, the HP49 I found unusable because the screen was so difficult to see, and the HP49G+ is looking 'buggy' (hardware and/or software). But I am still happy with it. Its a learning tool and I am not sure I trust it.


And I'm just trying to duplicate the bug.

If it can't be duplicated then no one can be sure if there IS a problem.



Them bugs coming thick and fast...this one is definitely sw.

Set the stack display to small.

Did a RCLF -- this is me typing them in from the calc:

{#800028205410ff0h #0h #12000000098h #0}

Now keep DUPing them on the stack. Eventually you see levels 1..5 showing the same flags.

But frame 5 redraws wrong. It needs two lines for display and each of levels 1..4 are correct. But level 5 shows just the top 2 pixels of the second line. Maybe this is correct behaviour but it looks flipping ugly. It should use the
"..." notation if it cannot fit.


Set my 49G+ to small stack display.

I did a RCLF but my list is: {#CF1h #1100h #80h #0h}

When I DUP this, I can fill all 9 levels of the stack with it and it displays fine.

Why did you indicate "5" levels of the stack? If the stack display is set to small, it should show 9 levels not 5.

My flags are set to show "many lines" (flag 52 is clear), but when I have it set to "show one line", I still dont' get this behavior.




I assume that if you use my flags ie what RCLF returns you get all my settings, namely font size. I have 5 levels showing because those flags spill over to two lines for the font setting.

If you use your flags (which are shorter than mine) you likely wont see it.

Its debatably a bug -- if you have a big array on the stack, it likely wont be able to display all of it. In which case it depends on the code for showing either the top bit or the bottom bit. But it would be nice if partial lines didnt show. At a small font, the pixels run into each other making it look very bizarre.

Not a biggie. I'm still happy that the HP49G+ is cleverer than me... :-(


Duplicated on 49g+.

Note on 49G, only 4 levels display, level 4 shows .. at end rather than trying to display between level 4 and 5.


Power off doesnt seem to work. I havent come across where
its possible to enable/disable this or change the timeout
(not sure its possible without programming the STARTUP/STARTOFF functions. I may have the OFF function wrong).

Walked away from my calc and it was on about half hour
later. It could be that it is powering itself on - I'm
pretty sure I power it off when I finish with it.

Will keep an eye on it....


Oh there coming thick and fast....

I tried one of the silly examples:

<integral> 0 to X exp(X) dX

(sorry not sure of the ascii convention to get this right).
Anyway, note I am evaluating exp(X) and not exp(-X).

I would expect this to be infinite?

Anyway after 30 secs, maybe 1 minute it was still calculating away. Maybe it is fine to do this in one or other of the numeric modes .. not sure.

So I aborted the operation with ON/CANCEL.

It popped up a note saying the operation was interrupted.

The bug is it left this on the stack:

2: External
1: 0.728780437708

I think any command leaving an External on the stack can be considered a bug? Not sure what the 0.728780437708 corresponds to (the right answer?)

more later when the next baby appears.


Hi Paul,

I have no book to reference here, but if I remember, Dx(exp(x)) = exp(x), in which case, Int( exp(x))dx, would be exp(x) + constant.

then if you eval at 0, and x, (I'd think to use t or something for clarity) you'd get [ exp(t) - 1 ] ...but that's if you are doing symbolic mode I might be way beyond my background. Then if you meant for x->infinity, then I'd be sure to agree that the integral will diverge. Maybe that object it leaves is an intermediate calculation while its trying to do the impossible. ?

best regards,


On my HP49+ this integral returns exp(x)-1, within a fraction of a second.

Forum Jump: