HP 37E repair.



#8

Help, I need help!!
Ok, I don't really deserve help, as what I have done is just too stupid, but anyway...
I am still trying to fix this HP37E. And now I got that 32E for parts (Thanks Stephan!!). So I started working on it again. And.....I droped the chips out of the frame. I had numbered them before, but it came of when I used alcohol to clean the contacts. :(
Now I am not really sure wich chip goes where and wich way round.

Does anyone have a picture handy? What I *think* is correct is this:
The big chip is inserted so I can see the "AMI" at the bottom-end (opposit of the LEDs) of the calculator. Then one silver chip to the top (towards LEDs). This one is missing one pin, the pin that is on the top left (towards LEDs and towards calculator middle). The other silver Chip is the one at the bottom-end, looks the same, has also one missing Pin pointing in the same direction.
I am pretty sure about the silver ones, as I can see where there is no mark on the flexible circuit-board from the missing pin. Are those chips both the same?
In the middle of the two silver ones, there is a little black one. I placed it, so that the hp logo points to the top (LED side) of the calculator. Just like the logos on the silver chips do.

Sorry for beeing that stupid...
And thanks for your help.

Regards,
Harry


#9

I figured I can make a working 32E out of the parts too. And that is what I did. It is working now. All I have left to do is make a nice faceplate for it now. Any suggestions on how to do that? The one I have is worn out. I would like to paint i black (its kinda grey now), but how do I get the legends on then?

Regars,
Harry

PS: Stephan, you get more then one beer now, most of the parts in the calculator were good.


#10

Please make me know the id number of each chip and I will try to say its position.

Cheers

Jon


#11

All I can read is the little black one. It says: IMA?0008 SGP791028. The others are not readable anymore. (This was the same before I used alcohol to clean the contacts)

Regards, Harry


#12

Ok:
According to one HP-37E I repaired long time ago. The position of the chips was. The closest to the display was 00031, the second hadn´t any readable id, and the third was 1MA10008. So that chip should be the last one. With the other two, just test.

I think this can help you.

Best Regards

Jon


#13

Thanks Jon

#14

Hi, Harry;

if you look at Spice's mainboard layout you'll see that all 8-pin chips are in paralell with each other, say, pins with the same "number" (position) in all of them are connected together with each other. The only exception goes for the C-type models (33C, 34C and 38C), where the upper IC has a separate connection for pin # 8. This is the position where the RAM chip must go. As you have an HP37E, pin # 8 of the first IC is connected with the others as well.

All you need to do is align the IC's in a way that pin # 1 of each chip points to the upper part of the calculator, the LED assembly part, and everything should goes fine. You may check for yourself and you'll see all of the pins are connected to the same cooper trails.

Success.

Luiz (Brazil)

Edited: 3 Aug 2003, 10:48 a.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP 32E & 37E Peter K Mueller 1 418 04-06-2007, 09:23 PM
Last Post: Les Wright
  batteries for HP32E & 37E Peter K Mueller 6 863 04-16-2006, 11:55 AM
Last Post: David Smith
  HP-37E "low" battery Michel Beaulieu 1 415 02-26-2004, 05:55 PM
Last Post: David Smith
  HP-37E chip placement Erik Wahlin 4 622 07-29-2000, 12:27 AM
Last Post: Erik Wahlin

Forum Jump: