HP-71B Strange Behavior



#8

I have tried to turn on my HP-71B and the display shows only > . When the batteries are inserted or the power cord is installed, this is the only thing that happens, nothing works! Is there a master Reset that is different from the ON / sequence? Any ideas?
Jeff


#9

The manual says if the 71B locks up, do the following:

- Remove power supply, batteries and modules
- Hold 'ON' for approximately 30 seconds
- Insert batteries and press 'ON'

You should be greeted with MEMORY LOST


#10

Unfortunately this did not work. I even tried holding the ON button down for 4 min. Still when the batteries were put in, the same result >. Is there any other ideas to try?
Please let me know.
Jeff


#11

Hi;

is there a chance taht one (or even some) of the keys is stuck? I mean, do all keys "sound" and act the same when pressed? This is just a guess.

I also have observed that some calculators "freeze" for a while and in particualr the HP41 fullnut. In most situations, opening the calculator and shortening the terminals of both big electrolytic capacitors is enough to completely reset the calculator.

I have already opened my HP71, but I did not inspect it for components, I was just "having a look". It is, as all HP calculators, very interesting inside...

Should you try this procedure, please be carefull and make sure you'll shorten only the capacitors in the power supply. Please, take all ESD precautions and use a low-value resistor (about 10 ohms) instead of a straight wire. It's safer.

Best regards, success and let us know what happens.

Luiz (Brazil)

#12

Someone by the name of Doug sent me an e-mail describing a way to correct this problem. Here is the e-mail he sent:
"Two things to try. I had the same thing happen with a unit that I purchased brand new and used for a couple years then one day it did about the same.
Plug in the adapter, then turn the unit on. Hold the on key for about 30 seconds. Then turn it off and on, then try it. If no result then remove a/c power plug and all batteries, and let it set for 24 hours, not any less. Do not push any buttons once power is removed. After 24+ hours, press the on button and hold down for 2 minutes. Do not press and release even once. It cleared the unit I had and never had it happen again."
Voila! This worked.
Thanks to all who helped.
Jeff

#13

Does the calculator respond to pressing ON and / simultaneously? If so, you could try an INIT: 1 (by simply pressing <ENDLINE>) which is the approximate equivalent of a machine reset (ON + C) on the Pioneers, i.e. it just gets you out of any infinite loops and into a defined state (with USER mode off so all standard functions are available again. It will not destroy any data except maybe, if I remember correctly, the command stack.

Next thing you could try is INIT:2 (ON /, then 2, then <ENDLINE>) which does a ROM check. By the speed of it, I'd think it is merely a checksum test, but it'll still tell if any of the ROMs are faulty.

If the test passes and your machine still won't run, you could have a problem with the RAM or the main PCB. I have no knowledge about the 71s internals but from the amount of RAM initially installed (17.5K) I'd guess that 16K are in one chip and the lower 1.5K are in another. The OS uses the lower addresses first, especialy for its internal purposes, so that's where I'd look for a problem. You could have a hairy crack in a trace on the PCB, for example, which, if you find it, would be repairable.

Keep us posted about any results.

Cheers, Victor


#14

I have had this problem a few weeks ago. The calculator was "frozen" and with the known methods nothing was to help.
So I removed the batteries and forgot the thing for about two weeks. After that period I gave it a new chance and put some batteries in. The unit responded in a normal way and all was fine.
I think there was some capacitor or a high resistance CMOS circuit that held some voltage for a few days.
But maybe it was a mechanical problem or wrong temperature...
Noone knows :)

Best regards

Stefan


Possibly Related Threads...
Thread Author Replies Views Last Post
  Strange HP 25 Problem (Repair) Onur Ilkorur 5 633 12-06-2013, 05:13 PM
Last Post: Onur Ilkorur
  Strange Battery Icon during updaate of Prime Firmware. Harold A Climer 7 864 12-05-2013, 04:40 PM
Last Post: Michael de Estrada
  HP PRIME : strange behavior when trying user key capability Damien 12 1,021 11-03-2013, 11:02 AM
Last Post: Joe Horn
  HP Prime function APP - Strange limitation ! :o( dg1969 2 405 10-04-2013, 12:10 PM
Last Post: dg1969
  Prime formatting behavior Camille 0 193 09-28-2013, 05:37 PM
Last Post: Camille
  HP41CX: Strange serial #... Stephan Matthys 1 276 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  wp-34s (Inconsistent Behavior) Barry Mead 2 309 07-23-2013, 02:54 AM
Last Post: Marcus von Cube, Germany
  [WP34s] strange behaviour at number entry Dieter 12 995 06-06-2013, 05:36 PM
Last Post: Harald
  Strange battery leak Cristian Arezzini 0 258 06-03-2013, 09:49 AM
Last Post: Cristian Arezzini
  Strange video Peter Niessen 9 780 04-07-2013, 08:33 AM
Last Post: Csaba Tizedes (Hungary)

Forum Jump: