Have memory, and getting "insuf memory" err mssg.


1) on 48G, I have written code worth 16K bytes; 20K free Bytes.

I typed "triangle solver" program from a known commercial program house (which should use < 8000 Bytes, when arriving at a line where local-var's are assigned:

-> dep <-p2 <-p3 .... for a total of 24 variables

and I save (enter), I got "insuf memory" messg.
I skipped that line and continued keying till the end of the program, and saved without problem. (I skipped a second assignment instance). Returning to key-in the "assignment"
above , the error-messg persisted. I am blcoked there.

Since, there IS memory free 20KB, could anyone tell me what the pb maybe?

2) How does one skips to a particular program line; to avoid
jumping 1 line at-a-time?


I'm not completely clear on what you're saying. I take it that the
problem occurs when attempting to save the program (with the ENTER key);
not when trying to run the program.

I also take it that you have a copy of the program, with some parts left
out, already stored in a global variable.

I'm not sure, but you might get by with less memory if you put the
quoted (surrounded by ' ' delimiters) name and the stack and then press
EDIT (which has an effect similar to the 48S series VISIT) rather than
placing the program itself on the stack before editing it.

I'd check for unneeded variables, and purge any found to free up some
memory. Consider temporarily copying some variables to another device
(your PC if you have the cable, otherwise by IR to another 48, or to a
49G that has the 49G to 49G cable plus the 48 series adapter).

If that doesn't do it, then note that by default, ENTER saves a copy of
the stack, and for commands that take arguments from the stack, a copy
of the arguments (or the argument count for commands like \->LIST or
DROPN that take an indefinite number of arguments). This can use up some memory.

So press LeftShift MODES, then MISC, and then press STK and ARG, to free
up some memory by disabling saving the last stack and arguments (enable
them again when you're all done).

If that still doesn't do it, then note that ENTER also, by default,
saves a copy of each of the last 4 the command line strings.

So from the same menu, press CMD twice to discard the last command lines
that are currently saved, and try again.

If that still doesn't do it, then press CMD once to temporarily disable
last command lines saving, but note that I'm not sure what would happen
if there's still not enough memory to put the program on the stack; I
believe the result would be that the command line would be lost, so save
this for the last resort.

Well, now you see why some of us consider 32K to be "not enough" for
some things.

By "skip to a particular program line", do you mean when
single-stepping? If so, then edit the program to place a HALT command
before that line, and when single-stepping, press CONT (LeftShift ON) to
get to the HALT command.


Possibly Related Threads…
Thread Author Replies Views Last Post
  HP Prime: problem with the memory of calculator during the debug process? Carlos CM (Mexico) 7 3,452 12-06-2013, 12:34 PM
Last Post: Carlos CM (Mexico)
  hp41cv memory modules tim peterson 10 3,615 11-07-2013, 11:09 PM
Last Post: Garth Wilson
  PRIME: Memory Map Harold A Climer 3 1,928 11-06-2013, 11:27 AM
Last Post: Han
  Prime cant find Memory available Dougggg 5 2,003 10-07-2013, 07:24 PM
Last Post: Han
  3D Grapher and Insufficient Memory Han 10 2,864 09-27-2013, 06:39 AM
Last Post: Pier Aiello
  memory evolution in graphing calculators Pier Aiello 0 949 09-11-2013, 07:33 PM
Last Post: Pier Aiello
  Anyone got a 39gII and doesn't mind memory loss? bhtooefr 4 1,735 05-19-2013, 03:57 PM
Last Post: bhtooefr
  [41CL] Memory Reference posted Monte Dalrymple 12 3,646 05-01-2013, 03:39 PM
Last Post: Etienne Victoria
  HP-41CV - A Walk Down Memory Lane Tom Lewis 9 2,712 03-18-2013, 11:14 PM
Last Post: BShoring
  WP-34s memory questions Marcel Samek 7 2,198 02-21-2013, 04:28 PM
Last Post: Walter B

Forum Jump: