hp-71b installing/removing memory


Hello all,

Can someone provide instructions (if any) for preparing the hp-71b to accept 4k or 32k ram memory modules.

I recently inserted a 4k memory module which resulted in a memory reset. I have removed the 4k memory module, and now the 71b seems to be locked. I am unable to turn off the machine.

I am assuming the memory modules were originally supplied with paper instructions for proper use, which I do not have.

Terry Ingram



maybe you could try the INIT key combinations (see HP-71B manual),
or simply remove the batteries for an hour or so.
My experience is that the 71B configures additional RAM w/o any problems, initially as part of main RAM.
If the RAM is freed (as PORT memory) it should even work to remove it w/o 'Memory Lost'.
Only if the RAM module is configured as part of main memory a removal will result in a memory loss.



After removing the batteries, I shorted the battery contacts and the 71b powered up fine.

As your suggestion, I issued FREE PORT(1), before pulling the memory module, and everything worked okay. No memory reset. Upon re-inserting the memory module, the 71b automatically configured the memory as main ram.

Another problem I've noticed during this episode, is now the hp-il module doesn't work. The hp-il module doesn't respond to "CONTROL OFF" or "RESET HPIL" commands.

Any suggestions for the hp-il problem? Are there any way to physically reset the hp-il module?

Thanks for the help,
Terry Ingram



I'm not a hardware expert,
but does your HP-IL module work with other commands, like COPY to/from tape, and does the module show up in the VER$ list?

Maybe pulling it off the machine then reinserting could help,
of course while the HP-71 is off:-)

Another idea: Is the loop closed?



No, the hp-il doesn't work with any commands at all. Not even the "reset hpil". I've pulled and re-inserted the module, but the operation is still the same.

I've tried the closed loop test as described on page 211 of the hp-il owner's manual, and do not receive either the screen cursor indicated a good module, or the "self test failed" message indicating service is required. The 71b just remains in a frozen state until I press the ON key several times.

The hp-il module is recognized with the VER$ command, "HPIL:1A".

Unless there is a physical way to reset (short contacts?), I think it may be time for a new hp-il module.

Thanks for your help,
Terry Ingram

Possibly Related Threads…
Thread Author Replies Views Last Post
  Installing Conn4x on Windows 8 Jerry Raia 2 1,157 01-04-2013, 10:28 AM
Last Post: Jerry Raia
  41 User Memory vs System Memory Gerry Schultz 6 2,438 07-01-2012, 12:02 AM
Last Post: Monte Dalrymple
  Removing WP 34S overlay Jim Horn 6 2,159 06-29-2012, 07:26 PM
Last Post: JimHorn
  hp50g: installing hpgcc3 Gjermund Skailand 0 943 06-02-2012, 07:19 AM
Last Post: gjermund skailand
  HP-71B: fastest memory copy? Hans Brueggemann 5 1,781 02-07-2012, 03:32 AM
Last Post: Hans Brueggemann
  Removing 9810 printer snap rings (circlips) David Ramsey 5 1,788 09-06-2011, 01:32 PM
Last Post: David Ramsey
  HP-IL 71B to 71B via HPIL Geoff Quickfall 11 3,167 12-01-2010, 06:55 PM
Last Post: Michael Meyer
  removing alluminium bezel (was restoring an HP11C) Alberto Fenini 2 1,197 05-24-2010, 04:21 PM
Last Post: Alberto Fenini
  Notes on installing EMU41P on Portable Plus John AS (UK) 0 821 03-04-2010, 03:19 AM
Last Post: John AS (UK)
  Removing the private status of a file (HP-71b) Klaus 4 1,471 08-28-2009, 03:38 AM
Last Post: Marcus von Cube, Germany

Forum Jump: