HP 71B with MEMORY LOST problem



#2

I have a HP 71B which works well, but has an intermittent MEMORY LOST problem. I can't associate any particular event with the MEMORY LOST condition. The unit has 4 4K memory modules in it. It has brand new batteries. Any ideas?


#3

Have you tried without any modules in it?

Is there any problem with the battery terminals? (the "springs" on mine are foam rubber - could they be deteriorated?)

Any sign of physical damage?


#4

No, there is no sign of physical damage anywhere. In fact, the battery compartment is pristine. Additionally, the springs which hold the batteries in place are just what they should be--springy. My does not have foam rubber, it's just springs. Any other ideas?


#5

Brian, I had the same problem with one I got used recently. Mine had no memory modules, but did have the HP-IL module. After several weeks of regular use at work mine no longer has the problem, but I haven't pinned the problem to anything specific. One thing that I did notice was that the unit did not sit on all four rubber pads evenly causing the case to rock and flex slightly. The HP-IL module and pad protruded slightly more than the other three pads, so I sanded it down even. Maybe that helped. My other theory was that it had been without batteries long enough that some components needed to re-polarize. Maybe I'm reaching... Anyway, after around 40 hours of use mine works all the time now.

#6

You should clean the battery contacts anyway. I didn't have the problem, but I heard, that some other guy had a completely non-working 71, which worked after a battery contact cleaning. Good contacts seem to be rather important, especially, when the 71 hasn't been in use for some time.

There might be a contact problem, even, if you don't see any dirt or corrosion on the contacts. The 71s battery contacts have been changed some times in the life cycle of the 71, so I'm sure HP was aware of this. I own a first series 71, which doesn't have the problem, maybe just because I'm using it since I bought it from HP.

You should try using the 71 some hours with the mains transformer. If this works without problems, you have isolated the cause.

I don't believe, that some electrolyte capacitors are bad, because the batteries provide a really large capacitance to the machine. Normally capacitors could be bad, if the machine works with the batteries, bot not with the mains supply. That case could be dangerous to other calculators, but not to the 71. The 71 can be driven without batteries inside. It has a rectifier and some capacitors inside.

When you have further problems with the mains supply attached, you possibly have a broken flex PCB (printed circuit board) between the main (lower) PCB and the keyboard (upper) PCB. That would be bad. I could fix it for you just for shipping costs (take this offer as a Christmas gift) :-) . You could also find an electronics engineer, who opens the 71 and repairs (replaces) the flex PCB with some wires. I can supply further information with email, when neccessary.


#7

Replacing the flex wire between the two boards: been there, done that; it worked. Winter in Madison, Wisconsin was at fault: the HP71B would cool enough inside my backpack while I walked to the university that when I got inside the EE building a lot of moisture would condense inside the HP71. Eventually the place where the flex wire was connected at one of the ends corroded. Had to replace it with a ribbon cable, using a really small soldering tip :-) . That was in 1990, and the HP71B keeps on ticking. But since then, I became confident enough to do some more serious stuff inside the 71, such as soldering more RAM.


#8

Would appreciate details on adding in your own ram!

#9

I would ask what part of the country you are in. I did some HP71B product development for land surveying when the 71B was a current HP product. Whenever I introduced the application in dry parts of the country, I would have constant memory loss that HP attributed to static electicity. I could not duplicate this for HP engineers in my clean lab back east, but I could see it in every time out west.


#10

I have had a memory loss problem with my HP71B as well. In my case I think that the batteries case cover is slightly loose and battery contact is lost. As soon as a key is pressed the memory is gone.

I have stopped using my calculator programs because of this. There is nothing worse that re-entering all the software manually.

If I can get my disk drive working then all will be well. The batteries need to be replaced.

Regards,

Stan


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime: problem with the memory of calculator during the debug process? Carlos CM (Mexico) 7 1,672 12-06-2013, 12:34 PM
Last Post: Carlos CM (Mexico)
  More Prime problems - lost Apps key again Michael de Estrada 10 1,552 11-16-2013, 12:46 PM
Last Post: Michael de Estrada
  Lost formulas David Goldstein 5 986 05-08-2013, 03:39 AM
Last Post: Katie Wasserman
  [41CL] Rescue from 'Lost Y Functions' Dan Grelinger 18 2,073 02-16-2013, 02:08 PM
Last Post: Diego Diaz
  41 User Memory vs System Memory Gerry Schultz 6 1,149 07-01-2012, 12:02 AM
Last Post: Monte Dalrymple
  Package lost-stolen Artur-Brazil 12 1,483 03-22-2012, 12:29 PM
Last Post: Antonio Petri (UK)
  Lost parcel? Matthias Wehrli 12 1,493 02-29-2012, 02:18 AM
Last Post: Nick_S
  HP-71B: fastest memory copy? Hans Brueggemann 5 895 02-07-2012, 03:32 AM
Last Post: Hans Brueggemann
  Help with 41CV - memory problem ? timw 7 1,005 09-08-2011, 02:15 AM
Last Post: Marcus von Cube, Germany
  41CV Fullnut shows "Memory Lost" consantly John Robinson 7 1,108 05-27-2011, 05:51 PM
Last Post: John Robinson

Forum Jump: