HP-41CV bad I/O ports



#3

Hello all:

I bought a bare-calc. 41CV (full-nut) off eBay a while ago, and it has worked fine ... until I went to plug in my new Time module! >:-P The Time module locked the machine up, and a memory-clear reset with the module in did not help. I think the Time module is good. Unfortunately, I can't test the Time module, because my only other 41 is a CX.

I then tried a known-good "Stat1" module, and it was at least recognized by the 41CV (Catalog 2), but only in ports 2 or 4. In ports 1 and 3, the 41CV did not "see" the module at all.

Lastly, I tried plugging in my 82143 printer---which works fine from my CX---and the printer would *only* print lines of diamonds, regardless of the port!

So, I appear to have a 41CV with very flakey I/O. Looking in the four ports, the connectors look perfect: all nice and shiny. Also, I tried repeated insertions/removals with no change in behavior for any of the tests. This makes me very much doubt that it is a connector issue.

Unfortunately, I have no repair experiance with any HP, much less a 41-CV (full-nut). I am an electrical engineer ... but ... let's just say that it has been a while since I've played with hardware! ;-) Can any of you hardware gurus (Tony?) tell me if there is any chance that this is repairable without SMD-soldering skills? I do have a cheapo soldering iron, power supply, DVM, and a small scope (GREAT, inexpensive, single-channel, 5 MHz, Velleman HPS5 handheld; note the ironic model number!).

Thanks in advance!

Bruce.


#4

Firstly the good news. There are _no_ SMD parts in a fullnut 41. Well, OK, the display contacts are soldered on the surface, but they're at the normal 0.1" pitch. And all the chips are DIL pin-through-hole devices.
Now the even better news. There's a good chance you can fix this without any soldering. It sounds like you have bad connections to the I/O assembly -- the flexible PCB that forms the I/O port connectors and the battery contacts. One thing you may not know is that there are separate connections for ports 1/3 and 2/4 which are connected together on the keyboard PCB. So bad contacts can cause half the ports to stop working.
Take the machine apart(screws under the feet), lift off the CPU board and its connector (take anti-static precautions -- this is delicate CMOS logic). Clean the contacts on the CPU board, the CPU board connector assembly, the contacts on the keyboard PCB (for the CPU board and the I/O assembly) and the contacts on the I/O assembly with propan-2-ol (isopropyl alcohol).
Then squeeze the foam strip under the flexible PCB at the top of the I/O assembly to increase the contact pressure here. Put the machine back together (don't overtighten the screws or you will have many more contact problems!) and try it again.
Incidentally, I also have one of those Velleman 'scopes, but being a cheapskate and handy with a soldering iron, I build the kit version. Took me an evening... It's a useful instrument for checking PSU ripple, etc, but for logic troubleshooting I much prefer the logicdart...


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP 41CV Repairs William Mabotja 3 985 11-20-2013, 04:45 PM
Last Post: Mike Powell
  "Packing" syndrome of my HP-41CV PGILLET 12 2,194 11-03-2013, 02:46 PM
Last Post: Hans Holzach
  Bad Flash in HP Prime Han 11 2,012 09-27-2013, 12:38 PM
Last Post: Han
  HP-41CV - A Walk Down Memory Lane Tom Lewis 9 1,723 03-18-2013, 11:14 PM
Last Post: BShoring
  Cheap hp32sii in bad condition on sale on Taobao Waon Shinyoe (China) 1 788 03-01-2013, 08:35 PM
Last Post: Raymond Del Tondo
  HP-41CV power problem Don Davis 2 803 10-11-2012, 09:13 PM
Last Post: Don Davis
  HP-41CV layout vs Voyager's, 35s Ben Huntsman 17 2,845 09-17-2012, 05:30 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-41CV System II aj04062 1 706 06-22-2012, 08:49 PM
Last Post: Allen
  HP-41CV "tall keys" version Ignacio Sánchez 16 2,767 06-11-2012, 04:59 AM
Last Post: Diego Díaz
  HP 41CV defective aurelio 7 1,558 05-16-2012, 03:54 AM
Last Post: Frank Boehm (Germany)

Forum Jump: