Strange HP 25 Problem (Repair)



#7

Hi,

I have received this very clean HP 25, knowing that there is a fault in programming mode. I thought to myself, if the calculator works that far, the rest can be easy to solve. Maybe it is not even a problem but a newbie operator mistake.

However, to my surprise the problem occurred exactly the as the seller described. So, I am here ...

The calculator functions perfectly. When you switch to programming mode, you can not type your code properly and the calculator does not run the program. It gets stuck at the first instruction. Every key you press in the programming mode is displayed as “13 00” except some keys like “f” or “g”. Even if you type “f SIN” it is displayed first “14” for pressing "f" then when you press "4" for "SIN" the display shows “13 00”. This happens for all other keys, like when you press "9" the "13 00" is displayed.

Any ideas where this problem is originating from?

Thanks in advance,
Onur


#8

For starters, 13 00 is just the default code for GTO 00 that is stored in all the program steps until you enter something else. So, it sounds like most of your key presses are simply not registering in program memory. As to specifically why this is happening, I can't say. If the calculator was attached to the AC adapter without a good battery inside or good contact with the battery, something may have been damaged. Since you say that it works properly in normal RUN mode, it doesn't sound like a keyboard problem.

Edited: 6 Dec 2013, 3:46 p.m.


#9

I know that these calculators are sensitive when it comes to connecting AC adapter when the battery contacts are no good, but I have no way of knowing the history of the calculator since I have it for a day now.

I have plenty other Woodstock series though and one thing I know for sure, when they get fried, they get fried all the way. I haven't seen a "partly fried" Woodstock till now, or is this the first one that I will have, that is my question.


#10

I can't say. I did have a 25C with continuous memory that appeared to go bad, but turned out to be a bad solder connection between the battery contacts and circuit board. Maybe one of the real experts here will chime in.


#11

Sounds like fried memory to me. Do the storage registers still work? If you press Sigma+ repeatedly, does 'n' increment correctly? Do operations store a value in LastX?

Are you sure this is an HP-25 and not an HP-25C? The CMOS memory is notorious for getting zapped on the continuous memory models. I have several HP-25Cs that exhibit the exact behavior that you describe.


#12

Spot on! Sigma+ does not cause any increment and operations do not store a value in LastX.

I have another HP25, can I just replace the 1810-0154 hoping the other one is alive?


Possibly Related Threads...
Thread Author Replies Views Last Post
  Strange Battery Icon during updaate of Prime Firmware. Harold A Climer 7 432 12-05-2013, 04:40 PM
Last Post: Michael de Estrada
  HP-25 Wayne Selway 1 161 11-22-2013, 12:58 PM
Last Post: Michael de Estrada
  HP PRIME : strange behavior when trying user key capability Damien 12 572 11-03-2013, 11:02 AM
Last Post: Joe Horn
  Interesting Base Conversions - Porting a 1975 HP 25 Program to the HP 35S Eddie W. Shore 1 167 10-13-2013, 07:49 PM
Last Post: BruceH
  HP Prime function APP - Strange limitation ! :o( dg1969 2 223 10-04-2013, 12:10 PM
Last Post: dg1969
  HP41CX: Strange serial #... Stephan Matthys 1 150 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  HP-25/25C Potential Matt Agajanian 14 625 07-17-2013, 02:57 AM
Last Post: Matt Agajanian
  [WP34s] strange behaviour at number entry Dieter 12 567 06-06-2013, 05:36 PM
Last Post: Harald
  Strange battery leak Cristian Arezzini 0 123 06-03-2013, 09:49 AM
Last Post: Cristian Arezzini
  Strange video Peter Niessen 9 422 04-07-2013, 08:33 AM
Last Post: Csaba Tizedes (Hungary)

Forum Jump: