EMU41; Dosbox on Linux; Excruciatingly sloooow


EMU41 v 2.5, Dosbox v 0.74, Latest Ubuntu (13.10).

It runs like molasses, it's like watching paint dry.

Any ideas?


And this is my EMU41.INI:

; emu41.ini        emu41 init file

; page size filename
0 12 rom41cx.bin
3 4 cxfcn2d.bin
5 8 cxtime2c.bin
6 4 prter1e.bin
7 4 hpil1h.bin
; ------------



Very likely, it's due to the XIL COM1.

Support of the PIL-Box (through XIL COM1) is experimental and may slow down or disturb emu41 operation depending on the OS. My experience is that it worked well for me on an old W2K system, but much less on XP. I don't know for DOSbox/Linux.

I strongly advise not to use directly the PIL-Box in Emu41 with XIL COM1, but to use ILPer to tranfer data using the virtual disk hdrive1.dat.

Try to remove XIL COM1 and let me know.



The problem was that EM41fired up without running "bnu" first and thus it hang on the connection it seams. When I fixed that, all was smooth sailing. The problem was that when I upgraded from dosbox 0.73 to 0.74, the part with autorunning the bnu got left out.


Yup - running the ilper program under Linux to use it as a mass storage device and also a printer. Neat.

Another question, then; What is the best way to transfer a single FOCAL program from my PC to my 41 using ilper or emu41?


Have you tried Ctrl F12?





Excellent resource, Gerson. Thanks.

After trying to speed up everything, I see that the issue is not with dosbox (I ran the game Gauntlet, and it runs very fast and smooth). The issue seems to be with EMU41, making my question even more pertinent to this forum ;-)


Fixed it - hmm... by following my own, long forgotten instructions...:



EMU41 is now open source, when is one of us going to port to UNIX/Linux/curses?


Oh, wow. Neat news.

If I get the time and inspiration, I will attack it. But I promise nothing ;-)

Possibly Related Threads…
Thread Author Replies Views Last Post
  Is Linux common among us RPN types? db (martinez, ca.) 46 16,358 12-11-2013, 08:25 PM
Last Post: Paul Guertin
  Building WP 34s emulator on Linux Eric Smith 3 1,528 07-25-2013, 03:03 PM
Last Post: Marcus von Cube, Germany
  trouble flashing wp34s under Linux Glenn Becker 8 2,791 07-23-2013, 02:21 AM
Last Post: Marcus von Cube, Germany
  Is there a HP50g emulator for Linux? Matti Övermark 2 1,524 07-03-2013, 07:40 AM
Last Post: Matti Övermark
  wp34s flashing with linux. Thomas Windisch 6 2,289 05-14-2013, 07:40 PM
Last Post: Harald
  wp34sflashcmd Linux problem Ole Streicher 1 1,101 05-09-2013, 07:25 AM
Last Post: pascal_meheut
  OT. Linux on a Ti Nspire. Matt Kernal 0 1,023 11-17-2012, 03:52 PM
Last Post: Matt Kernal
  off-topic question about linux photo software db (martinez, ca.) 7 2,566 07-01-2012, 06:35 PM
Last Post: Jeroen Van Nieuwenhove
  Emu41 Richard L. Taylor 6 2,102 06-30-2012, 01:04 PM
Last Post: Richard L. Taylor
  USB41 + 41CL connection to PC (for Linux/Mac). Here goes: Geir Isene 1 1,205 06-13-2012, 04:05 PM
Last Post: Geir Isene

Forum Jump: