Bricked my Prime


I connected my Prime to the Connectivity Kit and it said there was a firmware update. I downloaded the update, unzipped it and attempted the update according to the readme file. During the 3rd file download to the calculator, there was an error and the update failed.
After a paper clip reset, the calculator would not turn on again.
I tried many times with the paper clip/Symb button, the paper clip/CFO, removing the battery for a while, charging the battery for a long time but nothing works - it doesn't ever respond. Anyone have any ideas?


I have no idea if this will work, but at least it can't hurt and is worth a try. Simultaneously hold down the C F O keys, then push and release the On key and see if the calculator boots into it's bios screen. If it does, then use the arrow keys to select the FLS utility, hit Enter, select the Format flash drive utility and hit Enter. This should recover the operating system unless it has been completely clobbered. Do a hard reset to get out of the bios utility and reboot the calculator normally.

As far as the firmware update, I did mine w/o any unzipping or whatever. I just highlighted the Prime name at the top of the tree in the Connectivity Kit with the Calculators tab clicked, right clicked on it, selected Update firmware at the bottom of the menu and hit enter. At first it failed because it was trying to update before the driver software was installed to treat the Prime as a disk drive connected to the pc, but it succeeded on the second attempt. At no time during any of this did I disconnect the Prime from the pc or turn it off.

After completing firmware update I noticed that it was the same version 2013 8 13 (5106) that was already on the calculator, so if you do get that far check your version first before attempting to do an update. According to Tim W, that is the latest available update, and it's just being sent to users, because it's now on the ftp site.

Edited: 9 Nov 2013, 8:27 p.m.


Thanks for the tip. I still get no response from it with that technique. I had tried the C F O and reset button before also but it didn't work either. Looks like it needs to go back to HP.


Try the instructions from here:

Not sure if it will work if your calculator is not picked up by your PC, but worth a shot before sending it off.


Contact support. They should be able to help out.



Thanks, I called customer service and they are sending me a new one!
It is great to see good service like this - it is not always easy to find any more.


I have similar problem, while I solved a 4 equation problem the calculator freeze.
After an hardware reset the calculator turn on. I restarted with 4 equation problem and the HP prime freeze for 3 minutes and after turned off by itself.
Nothing was able to turn on again. No reset, no removing battery.

Any other suggestion?

Possibly Related Threads…
Thread Author Replies Views Last Post
  HP 30b bricked when repurposing scalpa49 13 3,465 08-26-2011, 07:51 AM
Last Post: Alexander Oestert

Forum Jump: