Unable to reassign K_Abc (a b/c) key


To make the Prime keyboard a little more programmer-friendly, I've been trying to assign a function to a key like so:

KEY K_Abc()

Base:=(Base+1) MOD 4;
RETURN v[Base+1];

Based on research in the message archives, I know I can't actually execute a function when the key is pressed. (I've tried putting in a "\n" into the string on a hunch, but no luck.) So I'll have to settle just for inserting the function call into the command line.

But what I think is unusual is that the key I am least likely to use (a b/c) would be perfect for me to reassign, but it seems to be a key that doesn't want to be reassigned. That is, the above code doesn't do anything if in user key mode and ABC key is pressed. If I replace it with K_SIN or K_Templ, it works okay.

Is this a known issue? Is the key name (despite being returned by the "Create user key" menu option) wrong and hence unrecognized? I ask this because it seems that any arbitrary string can follow the KEY keyword without causing a syntax error. (I've tried K_ABC as well, but no luck.)


It's a known issue. In fact, a lot of keys cannot be redefined (including keys in combination with alpha or shift or both)

Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to start and run EMU41 on new 64-bit Processor Laptop running with Windows 7 Antoine M. Couëtte 6 2,129 12-18-2011, 10:23 AM
Last Post: Massimo Gnerucci (Italy)
  Unable to register the 15c LE Neil Carlson 3 1,370 09-29-2011, 08:27 PM
Last Post: CAD_Jockey
  unable to plot UTPN stroran 3 1,390 04-21-2010, 12:10 PM
Last Post: Kiyoshi Akima
  Unable to transfer data through cables between IBM laptop USB port and HP48 GX Serial Link Antoine M. Couëtte 1 900 10-31-2005, 09:27 AM
Last Post: Antoine M. Couëtte
  To reassign keys on the 33s Eric Lundgren 5 1,694 02-19-2005, 06:33 AM
Last Post: Mvdn
  Unable to clear HP-41cv MEMORY LOST error Todd Koumrian 3 1,396 06-18-2002, 06:48 PM
Last Post: David Smith

Forum Jump: