Re: [WP34S] Flashing Issues


Greetings all,

Haven't been here for a bit. Moreover, I haven't updated my WP34s's in ages, so I thought I would do so tonight.

I am using MySamba under Windows XP using the original cable from Gene and the FTDI USB/Serial adapter acquired from

The first two units flashed fine, so I know my software, cables and set-up are fine.

The third gave me troubles. The initial flashing failed about half-way through. I assumed week batteries. I put fresh ones in, went through the protocol, many times, on p. 149 of the owner's manual, and kept on getting an "unable to connect" error after the blue light on the FTDI adapter flashes only weakly.

I did the trouble-shooting on page 182 of the manual. I did NOT see any display activity when pressing ON for two seconds, but MODE COM5 at the Windows command line finds my FTDI adapter just fine.

Did I "brick" my WP34S with the failed flashing? Can someone walk me through the protocol of saving this?

Right now the bum unit is on my desk, batteries out. Any suggestions how I can recover from this?

Thanks in advance,


Edited: 29 Oct 2013, 12:56 a.m. after one or more responses were posted


Let me see. Obviously you're using v3.1 of the manual. If you're trying to update your devices you shall go to p. 152 (instead of p. 149). Just the first point I come across.



I am actually doing complete re-flashings, not just updating so as to preserve memory and libraries. I move that stuff over later. I have proceeded this way many times before without problems. I have never used the ON+D and ON+S combinations--I have simply reset and erased everything using the buttons on the cable and completely reflashed the erased calculator. But that is where I have been stuck tonight.

My question is basically how to recover from an incomplete or aborted flashing.


Edited: 29 Oct 2013, 12:48 a.m.


OK, so let's proceed to p. 182. In my experience, the first crucial point is you have to be sure about the state of your calc - i.e. make sure it is really turned off. A hard RESET will do.


OK, so let's proceed to p. 182. In my experience, the first crucial point is you have to be sure about the state of your calc - i.e. make sure it is really turned off. A hard RESET will do.

Can you walk me through that? Kind of hard to tell if the calc is on or off when the display won't come on because the firmware is corrupted...



No dice.

Did the hard reset (poked a paper clip in the hole in the back after I had inserted fresh cells), and went through the steps again.

Still get the error.

I am concluding that there is something physically wrong with this calculator and that is the reason, not batteries, why the flashing aborted part way through in the first place.

This is too bad. Of my three units this was my favourite--the overlay was aligned most accurately, and the keys were best behaved…


Edited: 29 Oct 2013, 1:38 a.m.


Sorry, I had to do some other work in between. Don't give up so early. Since November 2012, I inserted another point on p. 182 (as was, now p. 206) between 2a and 2b:

Carefully bend the three legs of both center battery contacts approx. 1mm upwards.

And point 4 reads now:
Now all the hardware is well prepared. Start MySamBa on your computer and enter the port (as determined in 3.c or 3.d, without a colon!) and the file information (see p. 165). Do not start sending yet, just leave the window open!




Done. Indeed, the cells seem to fit more snuggly.

Still no luck. All I get is a faint flash of the blue light, three times, on the FTDI adapter, the the "Unable to Connect" dialogue. The behaviour is exactly the same as if I hit "Send File" and there is no calc connected at all. It's as though the calc is just dead on the end of that cable.

Still able to flash a working unit with the same cable and set up, so those bits are fine.

Obviously something intrinsic to the unit. Indeed, I assumed the aborted flashing last night was due to dead batteries. But when I try the suspect cells in a working unit, BATT gives me 2.9 or 3. I have done successful flashes in the past with BATT returning as low as 2.8, if I work fast.

Assuming mechanical problems in the calc at the moment--perhaps a short or something involving the power supply. It isn't that terribly critical--my other two units work beautifully--but it does bug me when something doesn't work. I only paid $40 for the original 30b and a few bucks for Eric's overlay so the loss isn't huge. Still, I may consider sending the unit to one of the WP34S's Canadian friends (Neil in Ottawa, perhaps) to see if anyone can help.

If there are any other diagnostic ideas, I am open.

Where does one get the 3.2 manual? I am seeing only the 3.1 manual in the Sourceforge main download AND in the doc subdirectory of the most up-to-date Code.



PS. I just remembered that when the aborted flash failed it ended with a dialogue that said something about "time out" and "ack".

Edited: 29 Oct 2013, 11:02 a.m.


In retrospect, I think the calc was a bit wonky early on. I had trouble resetting and erasing before the incomplete flashing--pushing the reset and erase buttons didn't seem to "take" at first--and in the past occasionally I would turn on the calc after it had bounced around in my bag for some days and noticed it had "Restored" from back-up, even though the batteries were fine. All of this points to issues with powering--shorts, contact issues, etc.

I am not going to fret much more about this as I have two other working units. If I really do want a third unit (one for the office, on for home, one in reserve), new 30b's are plentiful on Fleabay (the cheapest I have seen is around USD30, including shipping to Canada), plus a six-dollar overlay from Eric, and I have a working third unit. This is not the same as trying to coax a 42S back to life--it just isn't worth the time.

That said, I am still open to suggestions.



in the past occasionally I would turn on the calc after it had bounced around in my bag for some days and noticed it had "Restored" from back-up, even though the batteries were fine.

That's something I observe, too - nevertheless I didn't experience any problems (so far?) flashing this calc. Also I don't know what's causing it since the batteries are just fine as yours. Nature's full of riddles ...


P.S.: Seems you're the third victim. Quoting p. 183 of v3.1 manual:

Two of our early HP-20b-based calculators (without USB boards built in) developed broken serial input lines in service. These lines cannot be repaired easily. Those are the only cases we know so far a WP 34S showing a blank display became unusable since it cannot be flashed anymore.

I don't have a proof, but your story sounds alike.

Edited: 29 Oct 2013, 1:11 p.m.


My original development unit (a 20b) stopped working because its serial input line went dead. Since it's equipped with a real JTAG connector I was able to reflash it through my Olimex JTAG probe. I'm using it exclusively for hardware debugging which is quite rare now.


Les, out of curiosity, what is the remaining battery voltage on the dead unit?


Where does one get the 3.2 manual? I am seeing only the 3.1 manual in the Sourceforge main download AND in the doc subdirectory of the most up-to-date Code.

That's perfectly ok - the 3.2 manual is the printed edition of February and you find the link to it here:



Ah! I see--the 3.2 Manual is available in print only, I take it? No free PDF for download?


You got it! There are less than 100 sold so far - imagine how many would that be with a parallel free pdf? No, I won't make a fortune with that printed edition; it's just a little acknowledgement after the project donations all went to the software department since they had some expenses. For design and documentation, I only need my brains, my PC, and my time.



A printed 3.2 manual would be lovely but I just put the $34 toward another 30b unit and overlays. It might seem silly and impatient of me, but I decided to give the wonky unit plus a damaged flashing cable to anyone willing to cover the cost of mailing (see my reply to Neil's post below).



It's a matter of prioritizing, as usual.



Hi Les,

I have not programmed one for a bit and would have to dig out an older computer to do it but you are welcome to send me the unit and I'll have a go.

Drop me a note off-line and we'll set something up.



Thanks Neil, but I really think I will leave it alone and just enjoy the working units I have. Bubble-wrapping and ExpressPosting the unit to you in the small Regional envelope is at least $11 each way. (Parcel Post is cheaper and slower but I trust it less.) A new 30b plus overlay would cost me just $15 more and wouldn't take up much more of your time or mine.

I think I should take out the batteries and set it aside for awhile and come back to it with a fresher perspective down the road in a few weeks. Some folks have reported units flashing normally after leaving the batteries out and just giving things a rest, so hopefully I will get lucky. I am also mindful that these new HP units just aren't made like they used to be, but still I wish I got more than two years use out of this one for my forty or so bucks.



PS. I gave in an ordered another 30b and a couple more overlays. I am a bit obsessed with having three working units, and just splurging the CAD43 in total seems easier than spending more of my time getting in a twist over this. I am not an engineer so I don't have that drive to make something work no. matter. what… In addition--and maybe I am being impatient--I am willing to give away the wonky unit and a flashing cable in need of a pin repair to anyone willing to cover postage. Just put the ad up:

Free non-working WP34S and pin-damaged flashing cable

If this still interests you, Neil, under these terms, let me know. Otherwise the stuff is free for the taking to anyone willing to pay postage.

Edited: 29 Oct 2013, 2:59 p.m.


Well, I have 3 myself as well (though only 1 is a 30b).

I have built up a few 30b's as gifts for some folks in the past year.

But we should definitely spread the love around! I think I will let it go to another good home...


PS: You have to love the Canadian postal system! It costs >$11 to ship that ~350 km down the road. I recently bought a 32S from Germany and paid $7.50 shipping -- and it was boxed!


Hi Les,

Sent you an e-mail.




I found that one unit that I purchased had serial port issues, and it turned out that the jumper JP-5 was not making good connection.

I soldered a wire across JP-5 and it fixed the serial issue.

It might not be a bad Idea to check (with an ohmmeter) that jumper JP-5 and JP-6 do indeed look like zero ohm resistors on your calculator. Perhaps your calculator failed in the same place as mine. If so it can be repaired by re-soldering across the jumpers.


Thanks for the tip, but when I open these things and start fiddling with soldering I usually am dangerous.

My fellow Canadian Miguel has claimed the calc so maybe he can look at that angle when he gets it.


Possibly Related Threads…
Thread Author Replies Views Last Post
  WP-34s ISP (flashing cable) again ;( Bernhard 16 5,878 11-01-2013, 05:02 PM
Last Post: Bernhard
  HP-Prime: issues in entering expressions fhub 30 7,897 10-02-2013, 12:32 AM
Last Post: Tim Wessman
  help flashing a hp30b to a wp34s john mantooth 3 1,677 09-25-2013, 08:58 AM
Last Post: Thomas Chrapkiewicz
  Flashing cable for HP 20 / 30B Stefan Koenig 3 1,994 09-19-2013, 05:53 AM
Last Post: Marcus von Cube, Germany
  ( Parenthetical Issues ) yes, pun intended. Matt Agajanian 3 1,613 09-09-2013, 05:46 PM
Last Post: Matt Agajanian
  USB flashing/Li-po boards patryk 6 2,478 09-08-2013, 12:31 PM
Last Post: patryk
  Help with flashing HP30s John Ioannidis 14 4,256 09-04-2013, 09:37 PM
Last Post: John Ioannidis
  Flashing at HHC2013 Kiyoshi Akima 1 1,148 08-30-2013, 09:12 AM
Last Post: Matt Kernal
  Self-made WP-34s flashing cable? Victor Koechli 6 2,966 08-15-2013, 10:11 AM
Last Post: Les Wright
  wp34s flashing successful at last Glenn Becker 2 1,463 08-04-2013, 04:33 PM
Last Post: Walter B

Forum Jump: