Touch periodic table on HP Prime


With Tim's help and recommndation, here is a touch periodic table for HP Prime :

Video on calc :

Download :


Thanks Mikael & Tim. Have downloaded for installation on my prime.




Hi Mikael,

Have just tried installing the English language version via the connectivity kit (using Tim's instructions in this post: ) & there appears to be an error. When I tap "Run" in the program menu I just get an exclamation mark & nothing seems to happen.

Also going into Edit mode (out of curiosity)an error appears on line 100 & something.

Maybe I am doing something wrong & would appreciate your suggestions.




Do you have incorrect caracters on line 100 ?
Try this method : run emulator and then connectivity kit, open HP_ELEMENTS on the calculator emulated, copy the code and past it on a new program created on the connected calculator. Save.


The French version just gives me a quick exclamation mark. The English version gives me a syntax error on line 113.

Tom L


On your calc ? read my post upper.


I think you should define elements(); before FindEl(x,y). At least that works for me.



CHOOSE & MSGBOX command has a error, which is that the dialog box of menu is out of the current "picture" =(

PD: A menu can contain more than 6 items?

Edited: 21 Oct 2013, 12:30 p.m. after one or more responses were posted


No, 6 items max.


idea for many menus


if you press next item generates a new menu bar


Prev item return

[Request for HP-TEAM]

allow menu width, with the purpose of displaying more text on each menu


0 or 1 or none == default 
2 double (2 menus width)
3 triple (3 menus width )

{ "ItemA", # },
{ "ItemB", # },
{ "ItemC", # },

{ "ItemA",
{ "ItemB", 2 },
{ "ItemC", 3 }


[ItemA][___ItemB____] [______ItemC______]

Edited: 21 Oct 2013, 12:46 p.m.


I think you should define elements(); before FindEl(x,y). At least that works for me.

Not only move elements() above FindEl(x,y) but also put a declaration for FindEl above elements() as well.



Looking good!

If you can, please do not put my name in the program there. I was just showing how to make touches work (which your code provided a great base to do so) and would prefer not to have my name in there. Might cause someone to think it was an official HP thing or something like that. Also, I do not want to take away from your work on the really long and difficult parts.




No problem.


Ha disregard, found the program in the program, i was looking in the app folder.

all is well, great app!!!!!

Edited: 22 Oct 2013, 2:47 p.m.


Okay, i am stupid! I cannot for the life of me get the Elements program into the emulator or real.

Instead of telling you what i did, does anyone have a step by step from the unzipping to the loading.

okay, here is what i did:

1. unzipped and stored the results in the Prime Connectivity kit.

2. found the HPPL file and physically copied it to MYCALC with all the other HPPLL and the created file for the emulator PIPE_hp89 folder
3 its there and even shows up as a program on the emulator, but will not function.

so instead of telling what i did wrong, how did you guys and gals do it?


All that does is places it into the "Contents" tab in the connectivity kit.

At this point,

1) open the conn. kit.
2) select the "Content" tab on the left border of the window (by default, the "Calculators" tab appears)
3) click on Programs, and open the HP_Elements_EN program
4) copy the source code
5) Click on the Calculators tab and go to Programs. Right click Programs and select new. Rename it whatever you want.
6) Paste the source code and save.


Or just right click on it, "send to class", and it goes.




it is not me,

unzipped to program file folder I made in connectivity folder

copied to MyCalc and Content emmulator folder, see above

sent to emulator with "send to class"

get syntax error line 113

check, all programming there

however file HPPL is 43 k but file on emulator shows 23K or 0K
even though it is all there in the program tab


have done Hans way and Tims way

even toasted everything and re downloaded zip file and unzipped. same outcome. I will keep working but very frustrating, in know it is there but 43K does not show up in Content under Programs or Emulator under Programs even though the file is there.



The issue is not you. Rather the program file has an error (guessing Mic had both the FR and EN versions in the calc and so calling "elements()" worked since it was finiding it in the french version) and that makes the sizing stuff a bit strange. Could also be that there is something with the sizing that doesn't work directly when a transfer comes in and there is an error like you see.




still trying to hack away at it.

Thanks Tim!


Send me an email (via forums) and I will email you the version I have in which the bug was corrected.



Thanks, Geoff


Sent you the .hppgrm file -- basically repeat the same steps as before, and it should work without you having to edit anything.

1. Place into the correct folder:

C:\Documents and Settings\<user>\My Documents\HP Connectivity Kit\Calculators\MyCalc

2. Fire up conn. kit -- you'll see it in the Content and the Class tabs.

3. Connect calc or emulator to conn. kit.

4. In the Class tab, open the Programs and right click HP_ELEMENTS_en and choose to send to the class.


Well, success sort of,

runs in emulator but WILL not run on the real.

followed your instructions plus a plethora of hacks and all i get on the real is

Error: Syntax error

followed by

Syntax error in program line 23 when I Esc the file.

All three text views look identical:CONTENT, EMULATOR and REAL (NCC1701) in my case.

As i said, when copied directly to MYCALC folder it shows up on content and class tabs. When CLASS tab selected and Send To Class executed i get the file in the real but with 0kb, the complete code in the editor and the above error messages!

Could it be the version

TOTALLY FRUSTRATING as i have been transferring my APPS and programs back and forth, to and fro, here and there.

So it works on the emulator along with all my created apps and programs but will not work on my PRIME.

I have deleted all aspects of the elements file, reloaded the connectivity kit and virtual, and still na-da.

Get to play with it on the emmulator though ;-)


p.s. thanks for helping.


p.p.s the offending code on the real is identical to the working code on the emulator AAAAAAAARRRRRRRRGGGGGGHHHHHHHH!


Change your integer format to hex on your calculator

Edited: 23 Oct 2013, 9:55 a.m.


Did i miss that somewhere ;-(

would have saved alot of grief ;-)

all done and works!

Thanks all and Han.



Hi Mic,

You should include The programs as text files in the archive.

there is a mistake in your program:

The function elements() is calling FindEl(x,y) and vice versa.

In order to make Check happy, your must add the line

before the elements() function


Very cool.

When you get around to an update, I suggest you end the color codes with an 'h' so that it works even if you are not in hexadecimal mode.



Hi Mic,

I tried the version in your post and I receive a "Syntax error in program line 113. I suppose it is the bug that has been talked about, so I just would like to ask you if you have a more recent debugged version.

In other news ;-)

1- I had to change the decimal mark from my preferred "," to a ".". If not, the syntax error occurs in line 1. No surprise on that, but that would be nice if the calculator could manage this regional settings, so there is no need for manual tweaking to do on the source code to make it work.

2- Something a little strange happens if I set the decimal mark to comma rather than dot. Be aware that I am just playing with the emulator and have not made to much reading of the manual). The problem happens if I try to do the manual conversion : ";" as list separator and comma rather than dot as decimal separator. When I do that the comment bars "//" provoke a syntax error so I have to delete them. I may not be doing this correctly

Thanks and regards,



I get ERROR LINE 113 message?

Possibly Related Threads…
Thread Author Replies Views Last Post
  HP Prime touch periodic table : new version Mic 4 2,015 11-25-2013, 05:29 PM
Last Post: Terje Vallestad
  Touch periodic table on HP Prime - revisited Terje Vallestad 2 1,430 11-23-2013, 11:47 AM
Last Post: Mic
  How to create a touch button [HP Prime] uklo 1 1,240 11-02-2013, 02:03 PM
Last Post: Marcus von Cube, Germany
  Tic Tac Toe touch for HP Prime Mic 6 2,443 10-25-2013, 03:02 AM
Last Post: Mic
  Periodic table for HP Prime Mic 15 4,492 10-19-2013, 12:20 PM
Last Post: Joseph Ec
  HP Prime touch button SanS 3 1,545 10-10-2013, 12:24 PM
Last Post: Han
  HP41 Functions Address Table (F.A.T.) Antoine M. Couëtte 6 2,218 07-21-2013, 02:48 AM
Last Post: Antoine M. Couëtte
  The first periodic table of elements for HP39gII Mic 0 924 11-08-2012, 06:55 AM
Last Post: Mic
  Variation table for HP39gII Mic 15 4,422 08-13-2012, 05:05 PM
Last Post: Bunuel66
  OT: Tactile Touch Screen Ethan Conner 2 1,228 03-29-2012, 03:54 PM
Last Post: Garth Wilson

Forum Jump: