Is my HP Prime broken ?


So, I seem to have lost all my Apps. When I hit the Apps button, the calculator reboots and returns to the home menu. I've tried using the reset button several times to no avail. Previously, the Spreadsheet App has behaved strangely and had locked the calculator or caused it to reboot, so I don't know if this is somehow related. Anyway, I'm wondering if I need to contact HP customer support for a replacement.


Possibly something has become corrupted in there. Sure wish I could figure out what. :-( There are 3 things to do.

1. Hold backspace down after resetting the unit. That bypasses loading files. Power down and clean copies should be saved to flash. (provided something on the flash file isn't so badly screwed up the OS can't overwrite it or something)
2. Try the ON-APPS-ESC. However, this seems to be finicky compared to how it worked before. Most people seem to report more success holding down the APPS-ESC and then ON.
3. Hold C F O on a boot after reset and format the flash drive.



The first two suggestions did not work. On the third, I don't see a format option.


I tried the Evaluation Ck Bad Flash and got the result NG.


The format option is in the 4th option (FLS utility) and then 3 if I remember right.

I'm not certain if that NG means there is a problem, or if you didn't happen to push a button in the correct sequence or something like that. I don't really know much about the factory test menu and I've seen it give me all sorts of "Bad" results simply because it seems to be designed for a specific sequence and any deviation seems to mess things up.



That seems to have worked. Thanks.


OK. There's something seriously wrong with the Spreadsheet App. It's causing reboots again and it gives errors when attempting to follow the example in the User's Guide. I'm staying away from it lest I again end up having to reformat the flash drive.


Well, I just figured out that if you try to use the Spreadsheet App while the calculator is set for RPN entry then not only won't the App work properly, but it will crash the calculator, cause reboots and even result in a corrupted flash drive. All Apps that won't work with RPN entry should be blocked (low lighted) on the display so that they can't be accidentally used.

Edited: 13 Oct 2013, 5:52 p.m. after one or more responses were posted


Using the PRIME while set to the RPN mode shouldn't corrupt anything (IMHO). I suspect that this should be a bug on Tim W.'s bug list. I'm concerned that RPN has some odd behavior since you can't use many of the PRIME's more advanced functions while set to RPN. This certainly reduces RPN's usability since you have to consciously switch out of that mode if you want to use some other functions on the PRIME (such as advanced graphing). Anyone else think that is not intuitive?


Can you please define "more advanced functions"?

If you mean advanced graphing, then like all other symbolic screens you should enter ' ' first since it is expecting a symbolic object.

I am correcting this by automatically inserting them when editing an empty item to clarify things. It already does this in other places, but not in the symbolic screen. That should at least clarify what is expected.



Possibly something has become corrupted in there.

Generally speaking it could be H/W at this stage or just corrupt(ed) in crucial areas , I'd like to think odds on it's gonna be corrupted.
Just finding a way of restoring/rewriting is the key now..

Does this thing have a protected boot loader ? and/or an rom image on board ?

EDIT:Ah nice to see success come in there whilst I was typing :)

Edited: 13 Oct 2013, 11:22 a.m.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Broken keys on HP Prime? Tarcisi C 0 1,459 12-10-2013, 05:59 PM
Last Post: Tarcisi C
  Broken HP-97 to spare? davorin 3 1,691 08-29-2013, 01:08 AM
Last Post: davorin
  Working around broken Spice battery connections Les Wright 7 2,581 06-06-2012, 06:50 PM
Last Post: Mike T.
  [WP34S] Once Working TVM Now Broken Les Wright 6 2,161 05-07-2012, 02:07 PM
Last Post: Marcus von Cube, Germany
  [WP34S] Chi-Square Functions Broken in 2935 Les Wright 7 2,296 05-03-2012, 11:10 AM
Last Post: Les Wright
  WP 34S Amtel SAM-BA download broken Howard Owen 6 2,088 09-27-2011, 06:34 PM
Last Post: Marcus von Cube, Germany
  34S broken build :-( - Please update! Marcus von Cube, Germany 0 792 07-26-2011, 03:07 AM
Last Post: Marcus von Cube, Germany
  HP-41 Permanent broken Post Fix aj04062 8 2,354 05-18-2011, 12:04 PM
Last Post: Raymond Del Tondo
  is more valuable a 41cx broken calculator than a good one? Gonzalo Fernandez (Spain) 4 1,477 03-10-2010, 04:55 AM
Last Post: Gonzalo Fernandez (Spain)
  Broken Rom/Ram switch on RAMCARD bill platt 5 1,622 12-09-2009, 12:49 AM
Last Post: Thomas Chrapkiewicz

Forum Jump: