HP Prime bug in EDITMAT


It appears that EDITMAT only works with the built-in matrix names. If I create a matrix named Zvals then a "warmstart" happens. On the emulator, the program crashes.

I have Zvals appearing in my memory browser as both a real number and matrix. The real number Zvals appears multiple times, too.

Lastly, how does one "delete" a variable? I tried PURGE(Zvals) which did not work.


Wow, I have somehow managed to corrupt the memory to the point where my calc seems unstable.


Try ON-SYMB for a warmstart. Please let me know if you figure out what did it.

Also, please if possible plug the unit into the connkit and backup the device. I'd like a copy of that if possible.


Edited: 26 Sept 2013, 12:27 p.m.


Try ON-SYMB for a warmstart. Please let me know if you figure out what did it.


I simply did a warmstart like you said. However, the memory is still corrupt. It is hard for me to pinpoint what I did to cause the instability and corruption of memory, but what I have basically been doing is creating an app based off of my graph 3D program. Here are what I see as the issues:

Variables appearing multiple times both as same types and different types. I have, for example, Zvals appearing multiple times as a real number (how do I delete variables?) and Zvals also appearing as a matrix.

There seems to be a major bug in the matrix handling and/or app handling. I grabbed some video footage of the calc crashing, even.

Edit: Doh! Just caught your edit -- I deleted the app which appears to fix a few issues, but I still am having problems with duplicate variables that don't even show up in the connkit.

Edited: 26 Sept 2013, 12:37 p.m. after one or more responses were posted


Well, to clear the calculator you can either hold BKSP on boot (avoid loading files), or the 3 finger salute (ON-APPS-ESC).




Even more interesting -- there is nothing to back up!

Apparently any program I open (from the connkit) shows:

export programname()


and that's it. No user variables show up either. Should I do a hard reset and see if I can cause the crashes again? :-O

Edit: ON-APP-ESC does not seem to work. Another oddity is that my app now has shoved itself into the Function app.

Edited: 26 Sept 2013, 1:03 p.m.



The same happens with EDITLIST(user defined name). The prime crashes.

So if you want to edit a matrix or a list that you named, you need to store that in one of the predefined M0,...,M9, or L0,...,L9, because they can be edited with the built-in editors (unless produced by EIGENVV - - see below).

Here are some previous comments I posted earlier on google comp.sys.hp48:

Complex entries work in the editor (with built-in matrices M0-M9), so no problem there. I initially wanted to enter the matrix in the command line, e.g., [[(2,3) 6]], and that doesn't work. The comma doesn't get recognized, and when you press Enter, you get [[ 2 3 6]].


Create any real 3x3 matrix, store in M1
Store in L1
Open the list editor and try editing L1

-> HP Prime has stopped working.


I was pleasantly surprised that the Prime knows how to integrate 'SIN(x)*LN(x)' in CAS view (which the HP50G cannot), but then, looking at the answer, 'Ci(x)-COS(x)*LN(x*SIGN(x)', pressing the help button on the Ci integral (i.e., cosine integral, highlighted in the CAS catalog) brings up the definition of the Ei integral. (However, in help tree view, the correct definition comes up).


BTW, same problem with the sine integral (Si) - - the help screen gives the definition of the exponential integral, and the Si is not even listed in tree view (under special functions).


Try ON-SYMB for a warmstart. Please let me know if you figure out what did it.

Also, please if possible plug the unit into the connkit and backup the device. I'd like a copy of that if possible.


Hi Tim, I tried to send you an email via the forums, but I don't know if it reached you. If you could PM me your email I can send some more details and backups.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Sending little images to the Prime (...and Program name bug?) Erwin Ried 19 7,319 12-10-2013, 05:35 PM
Last Post: Erwin Ried
  [HP Prime] Plots containing complex numbers bug? Chris Pem10 7 3,637 12-05-2013, 07:40 AM
Last Post: cyrille de Brébisson
  [HP Prime] plotfunc() bug in CAS Chris Pem10 2 2,410 12-04-2013, 02:46 PM
Last Post: Chris Pem10
  HP Prime Spreadsheet Copy bug Michael de Estrada 1 1,819 12-03-2013, 11:34 PM
Last Post: Walter B
  HP Prime Matrix TERRIBLE bug and question uklo 19 5,164 11-25-2013, 12:10 PM
Last Post: Mic
  HP Prime graphing bug BruceH 1 1,495 11-19-2013, 08:14 AM
Last Post: Joe Horn
  [Prime] Shutdown timer bug? Cristian Arezzini 2 1,641 11-16-2013, 10:34 AM
Last Post: Cristian Arezzini
  HP Prime: Linear Solver app bug BruceH 0 1,154 11-15-2013, 06:36 PM
Last Post: BruceH
  Possible bug with sqrt function in the HP prime Michael de Estrada 6 2,502 11-15-2013, 12:49 PM
Last Post: Michael de Estrada
  [HP Prime] Calculating Prandtl Number with Units (bug found in USIMPLIFY) Timothy Roche 1 1,357 11-13-2013, 04:07 PM
Last Post: cyrille de Brébisson

Forum Jump: