(deleted post)



#21

This Message was deleted. This empty message preserves the threading when a post with followup(s) is deleted. If all followups have been removed, the original poster may delete this post again to make this placeholder disappear.


#22

I hate to tell you that's not true. Download http://sourceforge.net/p/wp34s/code/3450/tree/trunk/windows/bin/wp34sgui.exe and you'll get emulator build 3450.

d:-)


#23

This Message was deleted. This empty message preserves the threading when a post with followup(s) is deleted. If all followups have been removed, the original poster may delete this post again to make this placeholder disappear.


#24

Quote:
I tried downloading the file you suggested at the link provided, and it did not work for me.

Yes, this EXE alone doesn't work of course.

You can get a working emulator if your download all the following files from this link:

http://sourceforge.net/p/wp34s/code/3450/tree/trunk/windows/bin/

wp34sgui.exe
emulator.dll
1 Medium 34s V3.skin
2 Compact 34s V3.skin
3 LED 34s V3.skin
wp34s_V3_medium.bmp
wp34s_V3_compact.bmp
wp34s_V3_LED.bmp

Franz


#25

This Message was deleted. This empty message preserves the threading when a post with followup(s) is deleted. If all followups have been removed, the original poster may delete this post again to make this placeholder disappear.


#26

Quote:
That didn't work either.

If it doesn't work for you, then you have done something wrong!

Nothing more than these 8 files are necessary.

Franz

#27

Why not simply sending me an email asking for a new build?


#28

BTW, I've uploaded the new versions.


#29

Quote:
BTW, I've uploaded the new versions.

Many thanks Pascal,

your QT version (with its few extra features) is very much appreciated! :-)

Franz

#30

What URL please?


#31

Same place as usual:

https://sourceforge.net/projects/wp34s/files/emulator/


#32

Pascal,

Just in case that it was an oversight and not intentional, I thought I would point out that the Linux and OSX version were updated here but not the windows version.

Marcel


#33

This should be fixed now. The Windows version had been updated in the home directory but not in the emulator directory (the Qt emulators are in both places for historical reasons).


#34

Thanks! Didn't really think of looking in the other place. Now I know.

#35

With the wp-34s-emulator-linux64.tgz on RHEL6 I get:

:~> wp-34s/WP-34s: symbol lookup error: wp-34s/WP-34s: undefined symbol: _ZN9QListData11detach_growEPii

This symbol appears to be undefined:

:wp-34s> nm WP-34s | grep _ZN9QListData11detach_growEPii
U _ZN9QListData11detach_growEPii

:wp-34s> echo _ZN9QListData11detach_growEPii | demangle
QListData::detach_grow(int*, int)

Did something go wrong when linking the binary?

Solution

You need to link against the QtXml library. Add the following line to your project file:

QT += xml

Cheers

Thomas


#36

I'm linking with XML already. Did you checked if you have a recent enough QT install on your Linux machine?


#37

Probably not:

Package 1:qt-4.6.2-26.el6_4.x86_64 already installed and latest version
Unfortunately I can't upgrade to an actual RHEL.

Thanks for your answer and sorry for bothering you.

Cheers

Thomas

#38

I couldn't run the "Native Linux" version of the QT emulator on my
older "Debian Lenny" linux either. So what I did was install the Windows version and run it under wine. That way it works even on my older Linux distro. For reasons that I don't need to go into here one of my computers needs to be kept at the older "Debian Lenny" distribution. I do have other computers that run the latest Linux versions and they run the Native Linux QT emulator just fine. I was looking for a way run the WP-34S emulator on this older Linux also that is when I came up with this solution. I hope others benefit from this tip.


#39

Installed wine.i686, started WP-34s.exe: works like a charm.

Thanks a lot!

Thomas


#40

The problem is that the emulator needs Qt 4.7 at least. On Windows & OSX, I integrate them.
On linux, I let it to the user to upgrade their Qt install because I was not sure the Qt dynamic libraries would work well on all distributions.


Possibly Related Threads...
Thread Author Replies Views Last Post
  (deleted post) deleted 2 197 11-03-2013, 06:24 AM
Last Post: deleted
  trig scales on the Post Versalog slide rule Al 12 515 09-15-2013, 06:01 AM
Last Post: John I.
  (deleted post) deleted 2 164 03-25-2013, 06:41 PM
Last Post: Eric Smith
  (deleted post) deleted 15 568 03-09-2013, 01:35 PM
Last Post: Mark Hardman
  New Blog Post: Length of a Polynomial Segment Eddie W. Shore 1 158 01-17-2013, 08:56 PM
Last Post: Namir
  (deleted post) deleted 5 257 01-07-2013, 09:39 AM
Last Post: Frank Boehm (Germany)
  Resuming an old post......................while crunching numberes aurelio 11 419 09-25-2012, 08:31 AM
Last Post: Frido Bohn
  (deleted post) deleted 7 365 09-18-2012, 11:11 AM
Last Post: René Franquinet
  HP41 post replacement experiment Bruce Larrabee 14 488 07-16-2012, 06:51 PM
Last Post: Bruce Larrabee
  Building WP-34S calc.bin from source - long post (sorry!) Nigel J Dowrick 5 299 07-14-2012, 07:41 AM
Last Post: Paul Dale

Forum Jump: