More 9114A questions for the experts...


I have opened my 9114A drive (see post a few days back), and my eject mechanism seems fine. FYI the eject button is supposed to stay out, floppy in or out. It is simply a spring-loaded button to activate the eject mechanism. When I press the button with a disc inside, it lifts the heads and ejects the floppy.

When I try to format a disc, this is what I observe:
1) Head moves over disc from outside to inside (maybe more than once)
2) Head starts from inside, making small increments. This continues to almost outside.
3) Head moves in again and then out.
4) I then get a MEDM ERR.

It looks like it formats the head but then errors out at the end of the format. Is the TOC written on the outside of the disc?

Anyone have any comments on what I can try - it definitely does not look like the eject system is gummed up - in fact, the mechanism is very clean. I cleaned both disc heads with a cue-tip doused in rubbing alcohol.

These tests were done with a regular PC 2S/HD disc with the hole covered with black electrical tape.

So is there hope for this drive?

Thanks (also for all the responses I received earlier).



I'm far from being an expert, but I'd just suggest one thing.

Do you have LIFUTIL.EXE? If Yes, try formating one disk with LIFUTIL.EXE and simply read its contents. Are you using an HP71B or an HP41C?

There is a LIFUTIL for windows, but I use the DOS version. If you want to use the DOS version and your PC is running W95/W98 (I have no knowledge, as a user, about WNT/2000, and I did not test LIFUTIL under WME or XP), do hot run LIFUTIL from a window, or a terminal under windows environment. When O.S. is starting, press [F8] and select Command Prompt Only. Run LIFUTIL under a plain DOS environment.

Hope this helps you to check if the disk is O.K. In this case, the head will move a lot of times before the disk is formatted.



Try the following. Leave the write enabled diskette in the drive, switch the drive off, wait 10 seconds, and switch it back on. The drive will enter the self test, and perform a write test on the diskette. If the FAULT light goes off, then the drive should be OK, if the FAULT light stays on, then I can think of two things:

a) the battery is marginal, so by the time the heads
move back to read what has been written, boom!

b) the heads are dirty, try cleaning them with a head cleaning diskette (any type suitable for PCs is good, but again you have to mask the Quad Density hole).



Get the program LIFUTIL.EXE somewhere from the web.
( if you don't find it, ask me, I can send it to you
directly because it is made public domain by HP ).

Only use 720KB discs, the ones with only ONE hole, and format these on a max. 16MHz DOS-PC ( pure, native, simple DOS. I never tried Windows for this). After this you can use it with a HP41 ( no experience here with 71B until now ). 41C needs a volume-label, don't forget it ( LIFUTIL wrote it by default ). LIF-discs have a special formatting scheme: 256 bytes/sector and 16 sectors/track by 80 tracks and 2 sides [ series 40 and 70 ].

It works, if you have a good battery and the 9114A has no damages.

happy programming.........Erich N.


So will the 9114 not format a "modern" HD disc if I cover the "HD hole"?

I don't have a ready source of "old" floppies available. Some gentleman offered to mail me some from overseas, but I am asking around here first.


>So will the 9114 not format a "modern" HD disc if I cover the "HD hole"?

1. LIFUTIL runs on a PC and therefore uses the disk-drive of this PC, NOT 9114.

2. LIFUTIL formats "modern" discs, if the other hole is covered.

3. But I didn't achieve to read these discs with 9114 and my HP41 ( I got error-message: NO MEDM )

Results of my own experience, maybe with other environment and equipment it can work. I never use 9114 to format discs.

These old 720K-disc work best. Don't know why, because everyone would assume that the "modern" discs would do better, because of higher density and overall quality than the older ones.

<motivating> Get these "old" discs and your system will work like a devil. I think it is easier to find old discs than to find "old" calculators.

(h)appy (p)rogramming........Erich N.


720K and 1.44M media is different. The coercivity is different for one thing, and non-HD drives may well not have sufficient write current to use 1.44M disks properly. There is no reason to expect them to work -- they are not simply 'better disks'.
I have never had much success with using 1.44M disks in 720K drives, and as my data is considerably more valualble than the cost of a disk, I use the correct ones always. 720K disks are not hard to get, at least not over here in the UK.


A couple of small points:
1. The HP-41C does NOT need, expect, or create a volume label on the LIF disk. This is one of the problems, as LIFUTIL _requires_ a volume label and it is not trivial to create a volume label with the HP-41C.

2. I have had good luck formatting LIF disks on a PC (up to 600 mhz) running anything from DOS to Windows to Windows 98. I have not tried with the "NT-based" Windows programs, but have heard rumors that "NT" will not allow the low-level BIOS routines that LIFUTIL uses.

3. I have used many different disks with the 9114B with great success, up to the 1.44mb-capable currently available products. I have not worked with the 9114(A) disk drive at all.

4. Your experience may be wildly different from mine! Give it a try and find out.

Best regards,

Dan M.


When I put the 9114 back together, the PC board in the battery pack shorted the current limiting resistor and fried it. One of the cells had its terminal exposed, and I suspect that that cell was shorted over the 5k resistor. I replaced it with a 4k7 0.5W but now the main board won't power up. My battery reads 6.5V but goes to ~0V when I switch on the 9114. I suspect that maybe one of the cells were fried and cannot supply current anymore, but I do get sparks when I short out the battery.

Current theory: either a fuse blew on the main board, or the one of the cells is dead, making the battery output voltage 4V, which is not enough to power the main circuitry.


There is no fuse on the main logic (controller) board of any 9114 that I've seen (and I've worked on -A and -B models). There is, of course, a 5A fuse in the battery pack.
You say you shorted a current limiting resistor (is this the 5k one you mentioned?). Where is this resistor? In the battery pack or on the main logic PCB? I am not aware of any 5k current limiting resistor in either place (I think there's some kind of current sensing for the regulator circuits on the main logic PCB, but 5k sounds like a very high value).
In any case, a 6V battery will not burn out any normal 5k resistor!. Is it possible that this component was actuall the 5A fuse I mentioned? If you've replaced that with a 4k7 resistor, the battery will read 6V off-load (with a voltmeter only connected) and will drop to near 0V when you try to power up the rest of the 9114 from it.
What is component reference (i.e. R7, F1, etc) and on which PCB is the part you replaced?


The resistor I replaced is on the PCB in the battery pack. It has colour code green/black/red/red(wide), and is connected in-line between the input from the battery and the output to the connector that plugs into the main board. Is this device a fuse? There are no other fuses that I can see, on the battery pack's PCB. The list of components are:

Bridge rectifier GI-DF04-438M
TPI41A (power transistor?)
Diode I29
2 resistors (above mentioned, and 150 ohm


OK, that's the older battery pack (the more recent one has a much more complicated charger circuit).
FWIW, that 'diode' you mentioned is actually a zener, and forms a voltage regulator together with the power transistor and the 150R resistor.
And yes, that component between the batter +ve terminal and the output connector is a 5A picofuse. Think about it. It couldn't be a 5k resistor -- the disk drive draws over 1A when in operation, and no way could a 6V battery cause 1A to flow through a 5k resistor.
Replace it with the correct fuse and try again.


Thanks for the info! That does make a lot more sense. I did not know (or maybe I forgot :-) about picofuses; the colour codes seem to be in mA (5000=5A). It really does look like a resistor, though ;-)

I have shorted out the fuse for now, and the 9114 powers up, but only the power light comes on - no further activity, fault light or anything.

I am busy charging the cells again. I don't get proper readings on the 12V and 5V pins on the board. I can't see how the short in the battery pack could have blown anything on the main board. What happened in the battery pack is that the fuse shorted out one of the 3 cells in the battery pack, so maybe that cell is damaged. I'll have to see tomorrow.


I would advise replacing that fuse with the right part -- if you do get a short-circuit somewhere in the drive, that battery back will supply a couple of hundred amps (!). This will not be pleasant.
IIRC, the +5 and +12V lines on the mainboard are under software control. The 12V line is only present when it's trying to access the disk drive (it's used for the drive motors). The +5V line can be turned off in software, an is turned on again when a byte comes over the HPIL interface.
There should be +5V at the 'Vc' testpoint all the time (this is a continuous supply for the HPIL chip and the RAM).
However, at power-on, the +5V line should also be present, and the +12V line should be there when it's intialising the drive. If neither appear (I think you have to have the +5V line for the +12V line to come up) then there must be a fault in the PSU section of the logic board.
Check the 'Vc' line, and then I'll suggest how to debug the other supplies.


Thanks for the help so far! Much appreciated. I get 4.93V at the Vc terminal, ~6V at the 12V terminal and ~1.8V at the 5V terminal.


OK, Vc is fine. The +12V testpoint will be at battery voltage (+6V) if the +12V chopper isn't running. That's probably right too if the +5V line is missing. So let's start by sorting out the +5V PSU.
HEre's how it should work : U105 (MC1403 I think) is a +2.5V voltage reference. The output of that goes (amongst other places) to the top end of the potential divider formed by R105 and R104. This maintains the +ve input of U101a (LM358) at +0.5V.
The -ve input of U101a comes from the tap on the potential divider formed by R107 and R106. The top end of that goes to the +5V line. R017 and R106 are chosen so that the -ve input of U101a is at 0.5V when the +5V line is correct. Thus U101a acts as an error amplifier, comparing what the 5V line _is_ (tap of R107 and R016) with what it should be (tap fo R105 and R104).
The outptu of U101a goes to the base of Q102 via R102. Q012 drives the base of Q101, which is the pass transsitor between the battery voltage and the +5V line. If U101a detects that the +5V line is too low, then it drives Q102 a little harder, which in turn drives Q101 a little harder, thus bringing the +5V line up a bit.
There is one more circuit to consider.Q103's collector is connected to the base of Q102, and its emitter is grounded. Therefore id Q103 is turned on, Q102 and Q101 will be turned off, thus turning off the +5V line to save the battery.
OK, how to debug it. Start by measuring the output of U105 (e.g at the -ve input of U104b (MC3302). If it's not 2.5V, check U105, CR102, and look for shorts on the reference line.
Then check the votlage at the +Ve input of U101a. If it's not 0.5V, check U101, R105, R104. Then check the voltage on the -ve input of U101a. If this _is_ 0.5V (even though the +5V rail is low), then check U101, R106, R107.
Now check the Q/ ouput (pin 8) of U6b (74LS74). This should be a TTL low. If it's not, then the PSU is being turned off under software control. Find out why. Check U6. Check U15 (very unlikely). Check the output of U104b (MC3302) with a 'scope. This is a reset line for the HPIL chip and power-on logic, and should go low briefly at power-on). Check CR101 too.
OK, if it's not being turned off by software control, then check the 3 transistors Q101, Q102, Q103.


I checked out this, and everything seem to check out ok. I get 2.6V at -Vin of U104b(pin 6), 0.493V at +Vin of U101a(pin 3), ~0V at -Vin of U101a(pin 2), and TTL low on the LS74. The only thing is that Q101 seems to get fairly hot - I can still touch it, but it is much hotter than any of the other components. Unfortunately I don't have a 'scope to check out the reset line. I should probably try to replace Q101.

At least I have some picofuses on order to replace my wire. I also got some old floppies from a collegue at work. If I can only get the drive to start up...

May I email you at the address in your post? It would probably be polite to take this off-line :-)

Thanks again for all the help and detailed info! Do you have a service manual for the drive?


Those voltages seem consistent with the low +5V line. The reference side seems to be working correctly. I'd have expected around 0.18V on the -ve input of U101a (pin 2) -- one tenth of what the 5V line actually is. But maybe that's close to 0 on your meter.
One thing we didn't consider is that the PSU is trying to work correctly, but something is drawing an excessive load from it. Let's investigate that. Start by unplugging both of the cables to the drive at the controller board end. Power up again. If the voltages come up now (the unit will fail the self-test, of course) then there's something failed on the drive logic PCB (or there's a short in the power cable to the drive). If the +5V line is still low, then
measure the current it's drwaing from the battery. An easy way to do this is to connect an ammeter across the power switch connections with the switch _off_ -- the ammeter will complete the circuit.
I would expect a working controller to draw < 200mA -- but a short could cause it to draw a lot more.
Of course if you _do_ have a short across the 5V line then you're going to have to check a lot of parts to find it -- the 5V line is used by most of the chips on the controller board!
Finally, you (or anyone else) is welcome to e-mail me on the address I give here to discuss anything you know I have an interest in. Which, of course, includes old HP calculators and their peripherals. I don't consider such messages to be SPAM.


> It would probably be polite to take this off-line :-)

Oh no it wouldn't ;-)

There are those of us out here quietly following this with a significant amount of interest.

Possibly Related Threads...
Thread Author Replies Views Last Post
  ALL The Experts ARE HERE! Ron Ross 1 812 12-06-2013, 01:50 PM
Last Post: Kévin Ouellet (Canada)
  Alignment disk and procedure for 9114A aj04062 1 648 03-28-2013, 04:54 AM
Last Post: Tony Duell
  9114A Drive aj04062 4 1,435 11-17-2012, 07:48 PM
Last Post: Raymond Del Tondo
  Need an experts advice: which is currently best CAS? Mike (Stgt) 18 2,403 04-16-2012, 07:48 AM
Last Post: Mike (Stgt)
  HP-9114A Drive aj04062 9 1,519 05-09-2011, 03:30 PM
Last Post: Eric Smith
  Batteries for 9114A/B M. Joury 0 452 10-07-2010, 04:09 PM
Last Post: M. Joury
  ARRGGG HP 41 double x memory experts, help Geoff Quickfall 2 679 04-05-2008, 02:05 PM
Last Post: Geoff Quickfall
  9114a open pics & strange error msg PeterP 8 1,348 05-22-2007, 05:21 AM
Last Post: Tony Duell
  9114A woes PeterP 13 1,887 05-09-2007, 06:19 AM
Last Post: Vieira, L. C. (Brazil)
  9114A drive malfunctions shortly after receipt Les Wright 2 679 04-13-2007, 12:48 PM
Last Post: Les Wright

Forum Jump: