WP34s Programming woes



#10

I purchased a WP34s, prgramming cable and usb/serial adapter from Eric Rechlin, so I know I've probably got quality goods.

However I've tried every combination of usb adapter, erase/reset/power on, MySamba and wp-34s-flash-windows program, 3-sets of new batteries, etc. and have been unable to flash my WP34s with the newest software version. I've tried doing this on both Windows 8 and 7 with no success.

The programming cable certainly erased everything the first time. bit the connection to the WP34s isn't very tight and can be flexed a little. I'm wondering if it might be a cable issue.

Any suggestions?


#11

Can you tell us more about the error message(s)? Do they appear after a short delay or instantaneously?


#12

Both WP34sFlash and MySamBa say they are unable to connect to the WP34s. When I check the 'debug' box in WP34sFlash, it also says "no reply".

I've used three different USB/Serial converters (including the one recommended by Eric). I know Windows 8 has problems with some converters, but it hasen't worked on my Windows 7 labtop either.

I understand it's difficult to know what state the WP34s is in as there's no indication on the display - but I've followed the directions in the manual on how to do this, and every variation I could think of.


#13

Have you checked that you actually get a com-port when you plug in the adapter?


#14

Yes, the Com port is created when the adapter is plugged in and the proper port number is selected in the flash program(s). The adapter supplied by Eric has LEDs that flash as the program attempts to connect to the WP34s.

I've read here somewhere that the WP34s sometimes has problems syncronizing - but I think I've made enough attempts to eliminate that as a possibility, unless it's a real issue.


#15

Frederick,

Please follow the procedure given in the manual (App. A). In case of trouble turn to the troubleshooting guide (App. G).

d:-)

#16

I was comparing the different responses of WP34sFlash and MySamBa:

WP34sFlash: would try to connect and the LEDs on the USB adapter would double blink three times - after a couple of seconds would say it couldn't connect.

MySamBa: would just immediately say it couldn't connect - but I didn't notice any activity on the LEDs indicating a signal was being sent.

As I was doing the reset/on and Send File cycle a few times with MySamBa to verify the lack of a signal - suddenly there was this frenzy of activity on the LEDs that lasted for about 30 seconds. After it stopped, I disconnected and turned the calculator on - and it had worked! Version number 3.2T3375!

Unfortunately, I have no idea why after about 100 attempts it finally flashed.

I suspect again, that the problem lies with the somewhat loose connection between the cable and the WP34s - the time it worked, the calculator was sitting on it's side with the cable running out the back. However, I had run through various positions several times before without success.

Or perhaps the authors included an internal lotto program that you must win in order for it to flash - so that only the extremely dedicated succeed?


#17

WP34sFlash has been written by converting MySamba source code. The protocol, timings, etc are supposed to be the same except WP34sFlash tries "harder" to connect.
Why they sometimes differ is a mystery to me (the author of WP34sFlash).

But the way flashing serial communications are implemented by the HP-30B ARM motherboard makes it unreliable.


#18

I'm glad to have my calculator back and my thanks to everyone who worked so hard to give us this great calc. It's very reasurring to know that the flashing does work eventually if you persevere.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Simple? programming question [WP34S] Shawn Gibson 3 219 03-15-2013, 11:56 AM
Last Post: Didier Lachieze
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 156 10-04-2012, 04:59 PM
Last Post: Paul Dale
  [WP34S] Documentation for Advanced Programming Commands and Techniques Les Wright 4 208 04-08-2012, 02:17 AM
Last Post: Paul Dale
  [wp34s] Incomplete Gamma on the wp34s Les Wright 18 643 12-06-2011, 11:07 AM
Last Post: Namir
  [wp34s] Romberg Integration on the wp34s Les Wright 2 190 12-04-2011, 10:49 PM
Last Post: Les Wright
  HP-97 card reader woes GanjaTron 5 198 02-27-2009, 08:47 AM
Last Post: Randy
  9114A woes PeterP 13 481 05-09-2007, 06:19 AM
Last Post: Vieira, L. C. (Brazil)
  41c 1/2N battery woes hal 2 128 11-08-2005, 03:36 AM
Last Post: James F. Chumbley
  HP-67 Card reader woes Jim Creybohm 3 158 09-20-2005, 11:48 AM
Last Post: David Smith
  Custom Programming vs. Pre-packaged programming Eddie Shore 3 207 01-24-2005, 03:42 AM
Last Post: Karl Schneider

Forum Jump: