HP-67 Read Error



#2

Hi everyone, I recently acquired an HP-67 from a coworker that had bad batteries and the card reader was gummed up. I replaced the battery pack, cleaned the calculator, and replaced the roller with o-rings. I tried the RC fuel line repair on the roller, but it wasn't thick enough and didn't accept the cards. The calculator acted like it wrote cards, but I received errors reading cards; they won't get completely through without giving me an error. I tried to replace both capacitors on the main logic board with 4.7 uF electrolytic caps, but then I started getting errors with writing and reading. Those were the only caps (one yellow with a red dot and the other brown with a red dot) other than the ceramic cap on the logic board I could find to replace. I see 3 very small silver metal barrel caps on the card reader board. Did I replace the wrong caps? The red dot was the neg side, right?


#3

Ok, I've done some additional troubleshooting. I found some wires for the RW head broke and I re-soldered them. I still had read/write errors, so I replaced the yellow cap (above the inductor on the logic board). It started writing again. I also found the o-rings were rubbing, so I tried a different silicon tube and that improved the card movement. The card moves much smoother and it reads, but not reliably. It still fails with an error about 4 out of 5 tries. Does anyone have any ideas how to make it a little more reliable or is this normal behaviour from the HP-67?


#4

Try adjusting the asymmetric cam that the pinch roller sits on. By turning the slotted end, say an eighth turn at a time, you raise or lower the pinch roller


#5

I agree, most of the card reader errors are caused by less than optimal pressure/force between the replaced rubber and idler. That is why it is so important to get concentric, properly sized orings or tube.

Some errors are caused by bad connections from the leaf spring contacts. Make sure these are good. Adjusting the flat headed screws raises and lowers the spring. Make sure they are all level (except the curved one) with the top surface of the plastic housing


Edited: 31 Mar 2013, 7:43 a.m.

#6

Quote:
I see 3 very small silver metal barrel caps on the card reader board.
They are hermetically sealed tantalums. Never a problem. Jedi mind game: These are not the bad capacitors you are looking for.

Quote:
...The red dot was the neg side, right?
Wrong. Red dot side = +. So now your replacement caps are questionable. I would re-install the originals correctly as they are virtually never the problem, it is almost *always* mechanical. FWIW, in HP land, the square PC pad is + or pin 1.

The correct o-ring size is 005. 7/64" ID, 15/64"OD with 1/16" thickness. Installing it on the wheel expands the OD to the correct 0.250" - the same diameter as the base of the metal shaft extending from the black plastic worm gear.

Refer to this article: HP-67 Internals

You can confirm proper switch action with an ohmmeter. With the plate attached with at least the four upper screws, remove the processor board and connect your ohmmeter to one of the connections marked Gnd these locations:

HDS/ = card over head

MTRS/ = edge of card detected, start motor

WPS = write protect, edge of card clipped

If the switches do not go from infinity to less than 2.0 ohms with a card inserted past all contacts, insure that the plate is absolutely flat against the case front and it is held with at least the center two and top two screws. The plate *must* be tight against the front for the switches to work correctly.

If the plate is in place and the switches are still not behaving, it would be time to carefully clean the pc board contact pads with a clean pink pencil eraser being sure to remove all crumbs. Do the same for the ends of the leaf switch contacts, go slow and carefully, you do not want to bend anything. The contacts almost never need adjustment, only a light cleaning.


#7

Thank you for all the advice! I replaced the cap and just cleaned the contacts for the switches, instead of testing. I still get the same results. I tried adjusting the cam a little one way and then the other and I found the spot where it gets the least number of errors. It acts like it's something with the switches. Sometimes it doesn't even recognize the card until I push it into the roller or wiggle it a little (and sometimes it gives me an error right away). I found that if I get an error and reinsert the card then push clx to clear the error, it accepts the card and 4 out of 5 times it works (it's when I have to load both sides that becomes a pain). I don't have any more time today to work on it (studying physics), so when I get a chance to adjust the leaves and check it with a multimeter, I'll post back my results.


Possibly Related Threads...
Thread Author Replies Views Last Post
  [HP Prime] "Error while checking exact value with approximate value, returning both!" Chris Pem10 13 1,775 12-06-2013, 05:12 AM
Last Post: parisse
  MS advert shows spreadsheet with obvious error BruceH 3 757 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  HP PRIME: command to read the SERIAL ? Joseph Ec 9 2,000 11-01-2013, 12:43 AM
Last Post: Joe Horn
  HP Prime: Rounding error in determinant Stephan Matthys 3 579 10-25-2013, 09:29 PM
Last Post: Walter B
  HP Prime Error: Summation Upper Bound > 1000 HP Pioneer 2 499 10-25-2013, 11:32 AM
Last Post: steindid
  Prime Error or Mine? toml_12953 12 1,344 10-22-2013, 10:35 AM
Last Post: toml_12953
  Explaination on How to Reset Caculator in Users guie: error Harold A Climer 5 832 10-15-2013, 02:11 AM
Last Post: cyrille de Brébisson
  Repair of HP-34C - Error 0 and Error 9 Jeff Kearns 3 595 10-11-2013, 12:29 PM
Last Post: Randy
  Do You Think a Listing Error Was Made? Jim Johnson 13 1,271 09-04-2013, 09:23 AM
Last Post: Eddie W. Shore
  HP Prime: Error reports : Here Patrice 111 5,978 07-24-2013, 05:52 PM
Last Post: Thomas Klemm

Forum Jump: