Dead 50g after 3 months



#2

Well turn up for the books today: my 50g purchased in December just dropped dead. Have replaced all batteries, tried to hard reset it, removed the SD card etc. Totally dead, duff, snuffed it, a-gonna. Nothing happens - won't power up.

Was using the CAS to do some basic substitution which I could have probably done on paper and it just turned off. I think it was punishing me for being lazy.

Anyone dealt with HP service on such issues before?

Using Emu48 at the moment but it's painful cranking open a ThinkPad, logging in and waiting for it to boot to do a calculation.

(and before anyone asks, I haven't played with the CPU speed!)


Edited: 8 Mar 2013, 5:56 p.m.


#3

Man, that doesn't sound good. Was this a brand-new unit in December or did you purchase from someone else second hand? Surely it is under at least a year warranty from HP if new, right?

Best wishes on getting a speedy replacement. I'd call up HP immediately if you have warranty and I'll bet they send you a new one 2nd day shipping. They've always been extremely fast - 2 day service - on printer parts for my office. Never had to deal with a calculator issue though, as I've never had one break...

Please let us know how it goes!

Jed


#4

This was a brand new unit. Im in the EU (UK) so I've got a statutory 2 years warranty.

I'll call them on Monday and see what happens. I deal with HP server kit and I've had bad experiences so will see what happens.

I'll try the retailer (yes this was bought from a shop!) as well as they are a small company so they might be able to handle it for me.

#5

Did you try Joe Horn's solution:

Quote:
Just in case it isn't obvious, please be aware that it takes a fast
hand to do this correctly. You have to press and hold down the
backspace key IMMEDIATELY, the very moment that the warmstart begins.
This is much more difficult to do on a 49g+ than it is on a 49G.
If you can force a warmstart by pressing ON+C, then do it this way:
Press ON and hold it down, then press and release the C key (while
still holding down the ON key), then SIMULTANEOUSLY release the ON key
and press & hold the backspace key. Sounds complicated but it ain't.
If "Try To Recover Memory?" is displayed, then take a deep breath,
then press and release NO and IMMEDIATELY press & hold the backspace
key. This one's the most difficult; there can be no more than ONE
PRECISE INSTANT between pressing the NO key and pressing the backspace
key. A fraction of an instant is even better but is not required.
If the crash is so bad that none of the above work, then perform a
paperclip reset with the backspace key held down, which will force the
reset to pause midway with the screen turned on but blank. To resume
the reset and bypass your libraries, momentarily release the backspace
key and immediately press & hold it again. "Momentarily" means "of
duration greater than zero time and less than or equal to one precise
instant".
If the paperclip reset doesn't work, you can fake it into thinking
that you're going to update the ROM without actually doing so. Here's
how to do that: Press and hold BOTH the + key and the - key while
performing a paperclip reset. You will see the screen turn on but
remain blank. Release the + and - keys. You will see the ROM Update
menu (1:Update Code, 2: Self Test, 3:Secret Menu [hidden]). Press 3
to show the Secret Menu (actually it's the same one ordinarily
obtained by pressing ON+F). Now take a deep breath, press and release
ON and IMMEDIATELY press and hold the backspace key. This will force
the reset to pause midway with the screen turned on but blank. To
resume the reset and bypass your libraries, momentarily release the
backspace key and immediately press & hold it again.
ALL of these techniques will result in "DROP Error: Too Few Arguments"
or "Memory Clear" being displayed, and no libraries shown when you
press the LIB key. If libraries appear when you press LIB, you were
not fast enough; repeat the procedure more briskly.
Hope this helps!
-Joe-


#6

There's no power to the unit at all by the looks - no result. Can't even get into diagnostics menu. Looks like a hardware problem. Its bricked as in totally kaput.

#7

It was pure genius from HP (or was it Kinpo?) to put the boot loader in flash and then sell the thing without a JTAG interface. I have one of those... it's utterly frustrating.


#8

Kinpo this one for certain. Sure it was made in the same factory Casio use - it smells and tastes (don't ask) the same as my FX991ES.

There probably is a JTAG interface somewhere but it might require soldering to get at it. I haven't opened it up yet to have a look - hopefully it's not got a resin blob over the CPU.

I'm not about to take it to bits if I'm doing a warranty return though :-)


#9

"it smells and tastes" LOL. I remember when we purchased the older HP units 48, 42 and 41 the first thing we did was smell that distinct HP "new smell". Sure do miss that with the newer models.

#10

What happen if you connect your 50G with the USB cable ? Does it power on ? What about the 'backup battery'? I never change them and don't know what happen if they are dead.


#11

Absolutely nothing - tried both :(


#12

"Warranty" is the key word, I think you must get a new unit.

#13

Replying to my own post..

HP are sending a replacement out and a box to send the old one in.

They wanted me to send it back first but I complained profusely until I got hold of someone who could authorize it. This was after them saying to take it back to the retailer for 15 minutes. And that was after being bounced around three different departments. And this was after being on hold for 10 minutes.

Strangely HP UK were unaware they sold calculators...

3-5 days wait approximately.


#14

[...Strangely HP UK were unaware they sold calculators...]

I think that about sums up the current state of the union...what an unfortunate turn of events! So many wrong turns for HP over the years. :-(

#15

New retail packed replacement received in post today. Rather good service - no complaints.

Sending old one back tomorrow.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Previously dead WP 34S is resurrected! JayV 2 207 04-18-2013, 12:41 AM
Last Post: Walter B
  Does anyone want dead 82001 battery packs? Michae Altmann 6 363 03-15-2013, 07:32 PM
Last Post: Harald
  More or less dead HP-67 Bernd Ulmann (Germany) 7 355 02-09-2013, 12:53 PM
Last Post: Ignazio Cara (Italy)
  HP-29c keyboard dead 2nd row problem Xavier A. (Brazil) 6 344 07-17-2012, 07:09 AM
Last Post: Xavier A. (Brazil)
  WP 34S and 'dead' HP20B Rob Willett 17 753 10-20-2011, 06:49 PM
Last Post: Egan Ford
  The calculator is dead - viva la HP 15C Limited Edition Joerg Woerner 38 1,419 09-04-2011, 08:44 AM
Last Post: hpnut
  offtopic: is HPCALC.ORG dead? x34 2 164 03-15-2011, 06:44 PM
Last Post: DeboT
  30b Dead 5 Key Norman Dziedzic 10 431 02-03-2011, 03:36 PM
Last Post: Norman Dziedzic
  Dead HP-31E, where do I start? Paul Gaster 12 526 01-18-2011, 09:16 AM
Last Post: robert rozee
  Brain dead, need help with program briggleman 7 294 11-16-2010, 01:13 PM
Last Post: Michael Meyer

Forum Jump: