Update of Emu71 to v1.03



#2

Emu71 v1.03 is available at http://hp.giesselink.com.

Changes to v1.03:

  • improved execution speed of KML "Scancode" command in some situations
  • changed "Locale" KML command (in difference to Emu28 and Emu42 the Locale now reference to the keyboard layout and not to the keyboard input locale any more, this allows now i.e German-German as keyboard input locale but a Swiss keyboard layout)
  • expanded "Single Instance" option to 2nd generation, now the name of the state file of the caller instance is send to the running instance
  • fixed a silly bug at port configuration preventing the configuration of ROM images using an odd number of chips (i.e. JPC ROM rev. E with 48KB = 3 chips * 16KB)
Christoph

#3

Thank you very much! I only wonder why BEEP isn't working (Sound: Wave, flag -2 clear and flag -25 set). Well, the beeper doesn't work on my physical HP-71B either, so no problem :-)


#4

Quote:
I only wonder why BEEP isn't working (Sound: Wave, flag -2 clear and flag -25 set).

My emulators cannot emulate the beepers over the OUT opcode because of speed reasons. The only way is patching the ROM, decode the arguments (frequency & duration) and call a PC internal beeper routine.

In the delivered KML files "REAL71BM.KML" and "REAL71BL.KML" the ROM patch for beeping is disabled.

Remove in the Global section the '#' in the line

#       Patch    "BEEP.71B"
to
        Patch    "BEEP.71B"

and beeping should work. The flags -2 and -25 are ignored in the current version, the beeper is always on. The next version of Emu71 will watch the flag -2 (BEEP ON/OFF).


#5

This has worked, thanks! Now to fix my physical unit one of these days.


#6

What? You mean having it working in simulation hasn't shamed the real unit into working?


#7

Looks like it's totally shameless - still not a sound after hearing the loud noise of its virtual sibling...
I opened it once and resoldered the buzzer wires and it did beep for a while, but then got mute again. As the soldering iron I used in the occasion was not appropriate for the task, I didn't proceed any further lest I damaged it.

#8

It has shamed me into fixing it. Happily beeping now. It turns out it was due to a discontinuity in the inductor wiring, next to one of the leads. Is there an updated service manual? The motherboard in my HP-71B is slightly different.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Update of Emu71 to v1.05 Christoph Giesselink 0 151 09-24-2013, 04:22 PM
Last Post: Christoph Giesselink
  EMU71 on a web page! hugh steers 13 640 07-14-2013, 12:47 PM
Last Post: Namir
  EMU71 to go71b--is there a way? Les Wright 12 541 06-25-2013, 07:08 AM
Last Post: Mike (Stgt)
  RPN-67 Pro updated to v1.2 Willy R. Kunz 29 1,285 06-12-2013, 04:32 PM
Last Post: Willy R. Kunz
  Update of Emu48 to v1.55 Christoph Giesselink 4 318 05-26-2013, 05:28 PM
Last Post: Andrew Nikitin
  Update of Emu42 to v1.17 Christoph Giesselink 1 143 05-15-2013, 09:30 AM
Last Post: CompSystems
  Update of Emu28 to v1.27 Christoph Giesselink 4 241 05-02-2013, 04:36 AM
Last Post: Mike (Stgt)
  Update of Emu71 to v1.04 Christoph Giesselink 8 421 04-18-2013, 04:11 AM
Last Post: Mike (Stgt)
  Update of Emu48 to v1.54 Christoph Giesselink 1 163 01-23-2013, 05:28 AM
Last Post: Mike (Stgt)
  Update of Emu42 to v1.16 Christoph Giesselink 2 189 10-30-2012, 05:39 PM
Last Post: aurelio

Forum Jump: