[41CL] Trouble compiling CLWriter.cs


I have the correct version of .NET on my device it appears, and I execute this command:

C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\csc.exe /t:exe CLWriter.cs

The compiler starts, but it outputs the following error message:

"CLWriter.cs(3,17): error CS0234: The type or namespace name 'Ports' does not exist in the namespace 'System.IO' (are you missing an assembly reference?)"

Any help on getting a compiled version of CLWriter.exe?


Hello Dan,

I just tried it with Visual C# 2008 Express Edition (.NET 3.5) and it's working.

I have created a solution called CLTools and inside it I have created 2 projects
one for CLReader and one for CLWriter.

They both compile and execute correctly.

I also tried the following command lines ...

C:\WINDOWS\Microsoft.NET\Framework\v3.5\csc.exe /t:exe CLReader.cs

C:\WINDOWS\Microsoft.NET\Framework\v3.5\csc.exe /t:exe CLWriter.cs

They both compile and execute correctly.

I also tried you're command lines and I got the same error as you.

So we are both missing the Ports library of the .net 4.0 framework.

I have checked the online .net framework documentation and it's still supported.

So we just need to find/download/install the missing library.

I will get back to you when I have found it

Best regards


Edited: 16 Feb 2013, 8:10 p.m.


Found it!

Microsoft .NET Framework 4 (Standalone Installer)


a) download the installer file

b) run the installer

c) do a windows update

d) reboot

e) retry your command and it should work (it worked on mine)

Best regards,


Edited: 16 Feb 2013, 9:36 p.m.


Thank you! I got the download to work! I can now use the serial port to update my -41CL!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Usefulness of Woodstock Cs without their C Matt Agajanian 5 2,719 12-10-2013, 02:05 PM
Last Post: Geoff Quickfall
  HP-41CL setup troubleshooting Xavier A. (Brazil) 2 1,887 12-02-2013, 06:29 AM
Last Post: Xavier A. (Brazil)
  [41CL] New Extra Functions version Monte Dalrymple 0 1,099 11-08-2013, 04:32 PM
Last Post: Monte Dalrymple
  So, latest 41CL / Library 4 config is... Gene Wright 4 2,002 09-22-2013, 02:59 AM
Last Post: Ángel Martin
  HP-41CL anyone? Matt Agajanian 8 2,928 08-31-2013, 12:27 AM
Last Post: Sylvain Cote
  trouble flashing wp34s under Linux Glenn Becker 8 2,771 07-23-2013, 02:21 AM
Last Post: Marcus von Cube, Germany
  [41CL] A couple more rhetorical questions Monte Dalrymple 1 1,242 07-12-2013, 09:28 AM
Last Post: Ángel Martin
  TVM WP34s trouble Jim P 4 1,755 06-28-2013, 07:31 AM
Last Post: fhub
  Trouble dumping Pioneer ROM via IR Neil Hamilton (Ottawa) 6 2,484 06-20-2013, 08:14 AM
Last Post: Neil Hamilton (Ottawa)
  41CL :TROUBLE IN FILE TRANsFER aurelio 22 6,111 06-18-2013, 03:44 PM
Last Post: aurelio

Forum Jump: