HP-97 suddenly not working


I recently acquired a very nice HP-97. The card reader needed the sticky wheel repair, but the seller kindly included a baggie full of the proper sized o-rings with the purchase. Also the printer didn't feed paper too well, but that seemed like an easy fix as well.

Before I got to fixing those two problems, I used the 97 as a desktop calculator for a couple of weeks, enjoying just having it for a while before I attempted repairs. It came with a good battery pack and a 2 prong charger. I would unplug it at night, and leave it plugged in during the day while I was at my desk. I wanted to use if for a while before I took it apart, just in case I ruined it somehow.

A few days ago, disaster struck. I turned the 97 on for the day, and all I got was a string of 0's with a negative sign at the extreme left. A little research tells me that the ACT chip is probably burned out.

I went ahead and disassembled it, noting the location of the ACT, and did the aforementioned repairs. Quite easily accomplished with the resources here on MoHPC, so thank all of you who have posted about those particular repairs. Of course I was hoping that by disassembling/reassembling the unit it would be revived by some miracle, but it was not to be. Still all 0's when I turn it on.

So this leads to my questions. Is there a way to test the ACT chip ? I saw a post by Ignazio where he cannibalized a 97 to use a a test bed, but since he's in Italy, and I'm in the US, I doubt that he can help. Are there other ways to test it? I have an oscilloscope, but am a mechanical type, with electrical dyslexia.

I thought about cannibalizing my HP-25, but I'd rather not. I'm in the process of getting it working, and would rather have both working reliably. Of course if the 25 fails to come through, that ACT would be available.

Also, could it be something else? Maybe there are other chip failures that produce a similar result.

Finally, could the way I charged the unit every day have lead to the demise of the ACT? It was never plugged in without the battery pack, even though the manual says that wouldn't damage the unit, but might lead to improper results.


A failure of the ROM/Anode driver could cause that, but it's less likely.


Is that a chip that's more readily available than the ACT?

Thanks for the info. I'll look into that.


No, the ROM/Anode driver chip is specific to the calculator model, so it is less readily available than an ACT.


See if it powers up with _only_ the battery pack. If not, you may have a failure in that path (pack, connectors, etc.) that is making the 97 run off just the AC adapter, which won't work.

I'm sure you'll get a lot of (better!) advice shortly, so don't take the HP-25 apart just yet.


Edited: 15 Feb 2013, 6:08 p.m.


Checked that, and yes, it does power up with only the battery pack. Beautiful display too. Can't get over how nice the larger LED's look. Now if only it worked.


Do you always get exactly the same thing when you turn it on? One thing that occurs to me is it may be that the ACT is not reset properly. POR is pin 18 of the ACT it should pulse high briefly and then drop to near zero, however if it was not being reset correctly I would expect more random behavior. Do you have a meter that you can check voltages? On the ACT pin 12 is ground, and pin 1 Vss 6.25V and pin 2 Vgg -12V.


Yes, the behavior is very consistent. Just all 0's with a negative sign on the left side. No flicker or other strange afflictions, and no response to any keyboard inputs. I can't even get it to feed paper with the paper feed button, preventing me from gauging the success of my repairs.

I assume POR is Power On Reset. I see it in the service manual. Do you have any idea how high of a voltage pulse on pin 18 I should be looking for? I'll check and see how Vss and Vgg look as well.

It looks like there are a couple of other scope traces to test for, but I'm not sure I'll know what it means if they don't match mine.


Yes POR is Power On Reset, I have used that abbreviation for so many years now I don't even think about the words any more. Mine settles at about 0.166 V I don't know how high the pulse goes it is very quick, but I would expect that it goes to near battery voltage, it you really wanted to know I could hook up my digital scope and capture the pulse. As for scope traces if you need help understanding them and have a digital camera take pictures of the scope traces and send them to me, and I can try to help. You can send me emails through the forum it seems pretty reliable.

Edited: 16 Feb 2013, 11:12 p.m.


Did you make any progress on your 97? I recently got a 67 which is very similar to the 97 except it being a handheld without a printer. I was in the process of editing a program on it when the program counter went to all 0's and I could not enter anything in program mode, when I switched it off and on I get a single digit on the extreme left and an exponent of 00. In my case it does respond and appears to do math correctly but I cannot change the display format.

To test out the chips in it, I socketed all of the chips in my spare 97 at tested them in there. Now on difference between the 67 and 97 is the the column lines from the keyboard in the 97 are connected to the PIK chip but in the 67 they are connected to the input lines of ACT, so once I was sure my ACT was OK, I removed the PIK and connected the keyboard column lines to the appropriate pins on the ACT and then installed ROM 0 from the 67 and it worked except of course they key functions did not match the 97's keytops. It worked well enough for me to determine that either ROM 1818-0231 or 1818-0232 is defective, so now I will have to hunt for parts.

If you are not getting anywhere with your 97 I would be willing to test the chips for you, if keyboard input is not working the fault may be ROM 0 as it appears to contain the keyboard code.



I thank you for your interest. I haven't had a chance to take it back apart and test the ACT per your instructions and the service manual.

I may take you up on your offer to test the chips pending those results. I hope to have time to work on it this weekend.

In your case this link: http://www.sphere.bc.ca/test/hp-parts/hpparts2.html appears to have a wide variety of HP chips for sale. I didn't see your -0231 or -0232 ROMs on there, but he may not have it listed. He didn't have an ACT, but you might e-mail him about your ROMs.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 3,503 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 2,201 10-14-2013, 01:46 PM
Last Post: BruceTTT
  [41CL] Problem with PowerCL ... not working Doug (NYC) 5 1,622 01-22-2013, 07:18 PM
Last Post: Doug (NYC)
  42S exit key not working dwsmith 4 1,397 11-05-2012, 10:59 AM
Last Post: dwsmith
  HP-46 not working Ignacio Sánchez 1 837 10-24-2012, 11:17 AM
Last Post: Donald Williams
  [WP34s] last QtGui version not working fhub 8 2,054 08-31-2012, 05:08 PM
Last Post: fhub
  Modfile not working with Win 7 x64 Richard Wagoner 6 1,900 07-04-2012, 10:32 PM
Last Post: Diego Diaz.
  Working on HP's again Les Koller 49 10,240 06-20-2012, 01:29 AM
Last Post: Thomas Radtke
  held breath, found tapes & drive working Garth Wilson 9 2,539 06-12-2012, 12:52 AM
Last Post: Garth Wilson
  Working around broken Spice battery connections Les Wright 7 2,147 06-06-2012, 06:50 PM
Last Post: Mike T.

Forum Jump: