HP49g Complex Numbers



#24

Does anyone know how to insert complex numbers into the HP 49g? The old HP's had an angle key on the space key where you could just type in the magnitude, hit the angle key, and type in your reference angle. I really really need to figure this out so I can work with phasors. Any help would be greatly appreciated.

Jason


#25

Set Flag 27 and use menu of cmds given by (red right shift) CMPLX


#26

I need to enter the complex number with a magnitude and an angle, (ie polar form), not rectangular form. Does anyone know how I can do this?

#27

On the 49G the angle symbol is ALPHA RightShift 6.

Regards,

James


#28

When I use the alpha rightshift 6, the thing still doesnt work... Found something in the manuel said to type in

[3 (alpharightshift6)4]
and in rectangular mode, it should give

[2.99269 .20926]

but, it really gives

[0 0]

Does anyone know what is wrong? I really hate this calculator by the way.


#29

Hi;

the "[" and "]" are used to enter nth. dimesional vectors. You should use "(" and ")" as delimiters for complex numbers.

It will work.

Cheers.


#30

When I use "(" and ")", it did the same thing to me...
(0,0)


#31

Hi;

I tried a lot of flag settings and some CAS and related settings (as far as I could relate myself), but I simply could not simulate such situation.

In the 48 series, being the HP49G included, 2D vectors and complex numbers have different delimiters -[] against ()- and have some different restrictions on some operations. If you edit [2 2], Matrix Writer is invoked; if you edit (2 2), command line edit tools become available. I thought these differences would lead to different input procedures. Wrong.

I cleared flag -103 (real mode) and no change: (4 (angle-symbol)3) returns 93.9848,0.3486). I set Exact Mode and Approximate Mode and I got the same results.

I am a lot curious to know what's going on. This seems to me as a lot easy to be checked and too compromising to be a version failure, I don't know. (type VERSION [ENTER] to check for the O.S. version).

I'm feeling as being teased, challenged!

Hope someone finds the answer, because I'm gonna keep delving into the 49's guts...


#32

I cleared flag -103 (real mode) and no change: (4 (angle-symbol)3) returns 93.9848,0.3486).

Huh? Ok, "93.9848,0.3486}" must be a typo for "(3.9848,0.3486)". But even then, I expect that you must've entered (4 (angle-symbol) 5).

Anyway, getting [ 0. 0. ] or (0.,0.) as a result does indeed seem to be too drastic an error to be accounted for by using an old "ROM" revision. For what it's worth, if your ROM revision is lower than 1.19-6, then it's worthwhile upgrading it, although I doubt that it would solve this paticular mystery. Visit http://www.epita.fr/~avenar_j/hp/49.html for the latest ROM and a summary of changes that have been made since 1.10.

Jason, am I correct in assuming that you get these same results no matter what numbers you use? The only way you should get a result of [ 0. 0. ] would be to enter a magnitude of 0 (or maybe something very close to zero), and I find it hard to imagine any flag setting that would give you that result when the magnitude is 3.

If you find out what's going wrong, please let us know. This is the sort of thing that tends to keep me awake, and even when I fall asleep it's liable to sneak into my dreams.

Regards,

James


#33

... I mistyped the "(" for "9" (the [SHIFT] key in my keyboard is failling...). Also, the (4 , 5º) is correct, instead of (4 , 3º); and I try to track all errors before posting...

Thanks, James.


#34

...and I try to track all errors before posting...

Me too, but I wrote "...when the magnitude is 3." where I should've written "...when the magnitude is 4.", so you're certainly not alone.

What's written is not necessarily the opinion of the author.

Regards,

James


#35

So, let's both say to ourselves "Welcome to world of humans", ahn?

(I'm somewhat tired... I didn't sleep any second this last night... and writing soft stuff is relaxing, does not demand so much "e-nergy". Sorry and thank you, guys.)

#36

I have also been trying to reproduce this and haven't been able to.

I have a feeling that Jason is doing something different from what I'm reading here.

#37

I haven't been able to duplicate your results. With the 49G in rectangular and degrees mode, [3 alpharightshift6 4] ENTER gives me [ 2.99269215078 .209269421232 ].

Does the ALPHA RightShift 6 sequence at least give you the angle symbol in the command line?

Which ROM revision are you using?

Maybe some flag setting?

Regards,

James


#38

alpharightshift6 gives me the correct symbol.

I dont know how to check my ROM version, and I have flag 27 checked.

I am also in rectangular and degree mode.

I have flag 27 checked and I have no idea if there should be another flag checked, the manual doesnt specify anything.

Thanks for your help,

Jason


#39

Ok,

I think I know what is wrong. When I have it in RPN, it works, however, it will not work in Algebraic mode. Does anyone know how to do this in algebraic mode or is everyone a hardcore RPN? I am used to TI's, but when I was a freshman, they told me that I needed the HP... they lied.


#40

Hi;

do you have the means to generate a backup and send me? I think this is gonna be the last shot: I'm backing-up my HP49G's memory and I'll load yours on mine. I set mine to algebraic and it works perfectly fine, too.

I must confess I'm an RPN addicted, but I have NOTHING against algebraic-based operating systems or languages. It's a mater of preference, only. I program on TCL/TK (not a "language", instead a "tool command" language), C++, Pascal and I gave my first steps on programming with FORTRAN. All of them demand algebraic syntax.

Please, I'm anxiously waiting to "see" what's going on your HP49G.

Cheers.


#41

Sorry dude, I dont have a cable to go to my computer. I have the 1.0 version of the ROM for whoever was asking. Cant really update that either w/o the cable. I guess I am just stuck converting back and forth, I will live I guess. Thanks to everyone who tried to help, I must have a weird setting or something.


#42

Hi, Jason;

I'm still intrigued. What about a Memory Lost? Do you have any sort of data you can't loose?

If you wanna try, press

[ON] [F1] [F6] together;
release [F1] [F6];
release [ON]

I did not try it in my HP49G, but in the 48 series, this leads to:

 Try to recover memory?

[YES] [NO]

Select [YES] and star over. Let's keep talking about the Hp49G; I'm sure you'll have good surprises from it. Algebraic or RPL style...

Cheers.


#43

Whenever I do the ON F1 F6 thing, it goes into a cold boot or something. It gets stuck in an endless cycle. I think the manual said it was a self check, but I let it run for about 10 minutes and it kept cycling through. I had to do a warm reboot to stop it.

I have no idea what is going on.


#44

Hi Jason,

To get to the "Try To Recover Memory?" screen, release the F6 key before the F1 key. If you release the F1 key before the F6 key, then (as you found) it goes into a self-test sequence, just as if you had used the ON with F6 key combination.

As for ALG mode, I don't know much about it; it seems awfully complicated to me. It could be that trying to use the 49G in ALG mode is just as difficult as trying to use a TI. But I tried entering a complex number and a vector in ALG mode, and it worked just fine. I also tried it on a 49G with the old 1.18 ROM (in both RPN and ALG modes), and didn't see any difference there.

I highly recommend getting a serial cable to connect your 49G to your PC. Note that you don't need to buy the full "Connectivity Kit"; the software part is freely available at, among other places, http://www.hpcalc.org/. This will allow you not only to upgrade your ROM, but to download software (see what's available at hpcalc.org), backup your calculator to the PC, and develop your own programs on the large screen of your PC.

Come to think of it, I got a free "Connectivity Kit" (a CD-R of software, serial cable, and adapter for the 48 series), the 49G AUG, and the newer 49G Pocket Guide from HP by calling the support number in the back of the User's Guide. I don't know if HP is still doing that, but it's probably worth a try.

Regards,
James


#45

PS:

In the event that HP isn't so generous anymore (or in your country), it shouldn't be difficult to make a "do-it-yourself" 49G serial cable, especially if you already have the 49G-to-49G cable and the adapter to fit the 48 series.

If you also have a 48 series serial cable, you can just jumper the two together. If you don't have a 48 series cable, you could use some other serial cable (or connector); an old serial mouse might be a good source.

Search http://www.hpcalc.org/ for things like "serial cable" or "I/O" for some pointers on making your own cable.

Regards,
James


#46

I reset the memory like you said James, and it works now. Thanks a lot, really helped. I used a TI all through HS, so the HP in algebraic isnt such a stretch for me. Thanks everyone, you all helped a lot.

Jason


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime: complex numbers in CAS. Alberto Candel 1 347 12-06-2013, 02:36 PM
Last Post: parisse
  [HP Prime] Plots containing complex numbers bug? Chris Pem10 7 645 12-05-2013, 07:40 AM
Last Post: cyrille de Brébisson
  Complex Number Entry on Prime Jeff O. 19 1,283 11-16-2013, 12:34 PM
Last Post: Jeff O.
  comparing numbers on the WP 34S Kiyoshi Akima 7 659 10-19-2013, 09:28 AM
Last Post: walter b
  HP Prime: Operations with Large Numbers Eddie W. Shore 0 180 10-19-2013, 12:24 AM
Last Post: Eddie W. Shore
  HP Prime complex results Javier Goizueta 0 207 10-06-2013, 12:59 PM
Last Post: Javier Goizueta
  HP Prime Solving Nonlinear System of Equations for Complex Results Helge Gabert 11 910 09-30-2013, 03:44 AM
Last Post: From Hong Kong
  HHC 2013 room numbers David Hayden 2 307 09-20-2013, 05:34 PM
Last Post: sjthomas
  [HP-Prime xcas] operations with complex numbers + BUGs + Request CompSystems 9 770 09-08-2013, 10:40 PM
Last Post: CompSystems
  TED Talk: Adam Spencer: Why I fell in love with monster prime numbers Les Bell 3 397 09-05-2013, 12:54 PM
Last Post: Ken Shaw

Forum Jump: