[41CL]Updating ROM images with a Clonix


I thought that I would use a NoVRAM module to update the new ROM images in my 41CL instead of buying a USB to serial port converter. The problem I had is that the ROM format that Monte uses does not seem compatble with the ROM format that Diego uses. When I attempt to configure the NoVRAM with a Monte-supplied ROM image, the ROM contents for the bank are all zero as shown by the programming software.

I assume that some conversion is necessary. Can anyone clue me in as to a conversion tool, and what the difference is between the two formats?



The .rom format used for those images is the same one that is used for all of the images on TOS (I don't remember the details, but it's two bytes to hold each 10-bit word). I am pretty sure that others have used a Clonix to load stuff into a CL, so it may be that there is something amiss with the configuration of the NoVRAM.


Hello Dan,

Monte is correct about the 2 bytes/10 bits format, a 4K module takes 8K bytes on a file.

I have several NoV-64 and Clonix-D modules an except for a special case (that I still need to investigate) they always works perfectly (thanks Diego 8-)).

Remember that the NoV-64 module is by default configured with HEPAX RAM and Flash for ROM. You have to copy the ROM to the Flash side of the module using the ClonixConfig application.

If I remember correctly and I think I tried it once, you can select the module in the utility as a Clonix-D module and it will also work but without the RAM/HEPAX functionality.

Could you specify the exact file you are trying to copy to the CL using the NoV-64 module ?
I am working today but I can try it tonight if I known which file to test.

Best regards,



Never had any trouble using Clonix and NovRAM on the CL - in fact I used to use that method for my rom images update on the CL before I got proficient with the serial link - more direct, saves a few steps which becomes *very* convenient when you´re changing the code on a weekly basis.




Thanks everyone for responding.

I did some more testing, and I believe that I have found a bug in Deigo's latest Clonix Configure program.

I had stored Monte's ROM image files in a subdirectory in the directory I was running the utility from. I selected the appropriate file from this subdirectory, but the module code would be empty. I then noticed that Diego's configure program was creating a zero-byte file in the directory I was running the configure program for, of the same name as the one I selected from the sudirectory. It apparently then tries to load data from this empty file, which explains why I get an empty module.

When I moved Monte's ROM image files to the same directory I am running the Clonix Configure program from, everything worked just fine.


Hi Dan, all,

As usual, I pick up the thread at a very late stage, when most ideas/solutions have already been posted. However...

Dan, from your post I think that you're trying to use a .ROM file from an "external" directory. Just to point out: the .ROM images used to configure any of my modules *must* be placed in the same directory where the ClonixConfig utility is running from.

This is stated so in the ClonixConfig user manual, at the end of the "Installation" chapter (pg. 2):

"Some files have received new names like ClonixConfig.exe, Flash06b.exe or Flash12b.exe; so you can still keep the previous versions if you want, or just erase the old ones.

Please note that these files must be in the same directory where your .ROM image files are."

Hope this helps, please do not hesitate in mailing me or post in case my understanding of the trouble was not accurate or you need further assistance.

Best wishes... still from Caribbean :-)




Yes, I had copied the 41CL ROM files into a subdirectory of the Clonix directory that I had created. As I was easily able to navigate to the subdirectory and select the ROM file (without any errors), I did not think to check the manual for any limitations of the ROM file location. It was only after I recognized an empty file of exactly the same name was created in the parent directory that I understood what was happening.

Thanks for your help! I was able to successfully transfer several ROM files from my computer to the 41CL flash memory using the NoVRAM module, configured as a Clonix LP. It is not a 'fault' of the Clonix, but I find that I will need to invest in a serial port setup in order to transfer other files, as some of the images like to 'interfere' with the operation of the calculator when I am trying to copy them from the physical ROM page into 41CL RAM.


Hi Dan,

Good to know you've managed to get it working as expected.

I'd like (some others here may also...) to know a few more details on these "interferences" between ROM's and the calculator.

Can you provide further info?

Thanks for your attention and all the best.



Diego, here are the requested details;

I loaded the following ROM images into pages 8-D of my NoVRAM, configured as a Clonix LP;

Library-4 Toolbox ROM
Library-4 AMC-OSX ROM
Library-4 Sandmath ROM, Page 1
Library-4 Sandmath ROM, Page 2

When I turn on the calculator, one (or more) of these ROM images auto-executes a function to check for the Library-4 ROM, likely expected in page 4 is my understanding, and displays "NO LIBRARY".

When I enter ALPHA mode to input the address information for the YMCPY command, each character press sends the 41CL into a catalog 3 listing (with ALPHA mode still active!) such that I cannot enter the 'from' and 'to' addresses required to copy the ROM images to RAM.

I hope that answers your questions. :-)



Hi Dan,

Probably Ángel will have a more detailed answer but, if I'm not wrong, the LIBRARY4 SW package require the usage of the four banks.

The current ClonixConfig utility (v3.5) only handles banks 1 & 2.

The new version (v4.0) will allow users full four banks selection; this new version has been tested during the last weeks and will be released in the next few days.

It's taken a while since many of the modules' core firmware have undergone some "surgery" to cope with the requirements of this four banks handling.

Stay tuned!

Best wishes.



The operation of the software when it is in the Clonix module is unimportant. It only exists in the module as a holding place to be copied into 41CL flash memory.

The problem is that there are obviously entries in the RAM polling points, and this prevents the 41CL from behaving properly during the time that I am attempting the copy.

This will be potential limitation of this method for any module that uses the memory locations of the ROM polling points in a non-standard way.


There shouldn't be any conflicts provided that you're not writing the Library#4 in any other page but , er... the fourth. That's the important thing to do, and the Clonix allows for that - pls. note that no other banks are used, only the "main" one. Probably Diego was thinking of the PowerCL - which does indeed have four banks.

HTH, let me know if you still have issues and I'll send you the latest versions of the modules just in case.



Hi Ángel, Dan,

Thanks for the correction note. Seems that your SW portfolio is wider than I can handle from the top of my head... and I'm not getting younger... (it also counts) :-)

Dan, the thing should work as Ángel noted (LIBRARY into page 4); since the Clonix is just a mere container in this context.

I'd like to have a look at it, if you can send me the files you're working with I'll try to find out what the trouble could be.



Edited: 12 Feb 2013, 7:58 p.m.


No, I was not loading Library-4 into the 4th page. I was just randomly loading images (six at a time) into pages 8-D. That is why the interference when trying to copy them from pages 8-D into 41CL RAM.


Mystery solved then!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Sending little images to the Prime (...and Program name bug?) Erwin Ried 19 7,319 12-10-2013, 05:35 PM
Last Post: Erwin Ried
  Updating Prime Les Koller 8 3,516 12-08-2013, 02:44 PM
Last Post: aurelio
  HP-41CL setup troubleshooting Xavier A. (Brazil) 2 1,896 12-02-2013, 06:29 AM
Last Post: Xavier A. (Brazil)
  HP-41 Clonix&NoV's SW Update. (For the non-Primer's guys out there... :-) Diego Diaz 21 5,759 11-13-2013, 09:00 AM
Last Post: Ángel Martin
  [41CL] New Extra Functions version Monte Dalrymple 0 1,107 11-08-2013, 04:32 PM
Last Post: Monte Dalrymple
  So, latest 41CL / Library 4 config is... Gene Wright 4 2,014 09-22-2013, 02:59 AM
Last Post: Ángel Martin
  HP-41CL anyone? Matt Agajanian 8 2,947 08-31-2013, 12:27 AM
Last Post: Sylvain Cote
  HP-Prime CAS nice images CompSystems 9 2,709 08-28-2013, 12:00 PM
Last Post: Juergen Keller
  [41CL] A couple more rhetorical questions Monte Dalrymple 1 1,253 07-12-2013, 09:28 AM
Last Post: Ángel Martin
  41CL :TROUBLE IN FILE TRANsFER aurelio 22 6,130 06-18-2013, 03:44 PM
Last Post: aurelio

Forum Jump: