[WP34s] Possible problem with matrix inversion


I just tried the matrix inversion command with a simple 4x4 matrix. Calling M-1 directly from the keyboard makes the calculator shut down (!). Sometimes the VERS screen is displayed instead.

However, if the same M-1 command is used from within a program, everything works fine:

  001 LBL A
002 M-1
003 END
Used this way, the command is executed as expected. The same applies to M-1 calls from the library, e.g. the matrix editor MED.

All this applies to Version 3.1 3325 as well as the new 3.2 3350 (updated a few minutes ago). So, is it the firmware or is there a problem with my hardware?



I just tried the matrix inversion command with a simple 4x4 matrix. Calling M-1 directly from the keyboard makes the calculator shut down (!). Sometimes the VERS screen is displayed instead.

Have you tried it on the emulator, too?

I just did it (also 4x4) and had no problems.



The emulator works fine. It's "the real thing" that behaves that way.



Hmmh, I just tried with build 3335 on my "real thing" and everything worked fine.

My matrix (chose some arbitrary values without thinking much):

 1   2   3   4
0 1 4 9
7 6 5 4
1 0 -1 1
How's your matrix looking?



How's your matrix looking?

It's looking great, of course. 8-)

Since the early Eightes I'm using a simple test matrix, taken from a book on numerical algorithms I bought back then:

      5   7   6   5                  68 -41 -17  10
7 10 8 7 -41 25 10 -6
A = 6 8 10 9 Inverse = -17 10 5 -3
5 7 9 10 10 -6 -3 2
This, as well as a 4th...6th order Hilbert matrix, usually is the first thing I try with new matrix software.

But I do not think the matrix itself is the reason for this strange behaviour. I fear something went wrong with the crystal/IR upgrade and it's actually a hardware problem. The same BTW happens with the LINEQS command. I just wonder why everything is fine as soon as the same functions are called from within a program. Strange.



I fear you're right. Your matrix inverts on my calculator just fine. I can't tell you, however, how the quartz / IR shall effect your calculations - maybe Marcus knows more about that particular case?



Dieter, I suspect your hardware is broken. What does BATT say? Can you switch to SLOW mode and try again?


BATT returns 2,9 V, and after SLOW the same thing happens: M-1 turns the device off, and in some cases it displays the VERS message.


Edited: 5 Jan 2013, 5:33 p.m.


M-1 and LINEQU function pretty much the same underneath. They both perform a Doolittle LU decomposition with partial pivoting and then solve the system of equations (many times for M-1).

I've no idea what is causing your problem :-(

- Pauli

Edited: 5 Jan 2013, 8:03 p.m.


Dieter, have you tried re-flashing the 34s software?



Yes, of course a firmware update was the first thing I tried. But the problem showed up with version 3.1 3325 as well as 3.2 3350. It seems to be a hardware problem.


Possibly Related Threads…
Thread Author Replies Views Last Post
  AFTER HP-Prime update, Shift+Matrix CRASHES Joseph Ec 3 2,042 12-06-2013, 11:06 AM
Last Post: Joseph Ec
  HP Prime Matrix TERRIBLE bug and question uklo 19 5,120 11-25-2013, 12:10 PM
Last Post: Mic
  HP Prime: editing a matrix Alberto Candel 6 2,339 11-20-2013, 06:26 PM
Last Post: Helge Gabert
  Absolute Value and Matrix BruceTTT 5 2,117 11-11-2013, 11:52 PM
Last Post: Walter B
  WP-34S Matrix operations with routine-local registers? Tom Grydeland 1 1,184 09-04-2013, 10:46 AM
Last Post: Marcus von Cube, Germany
  Matrix Characteristic Polynomial - Reloaded. Ángel Martin 12 3,434 08-22-2013, 05:33 PM
Last Post: Thomas Klemm
  Matrix Richard Berler 3 1,426 08-18-2013, 06:24 PM
Last Post: Paul Dale
  Advantage/CCD Matrix Challenge Ángel Martin 1 1,165 08-09-2013, 06:22 PM
Last Post: Thomas Klemm
  [HP -Prime CAS] List, Matrix, Vector as one Array? CompSystems 0 991 07-26-2013, 05:22 PM
Last Post: CompSystems
  ELO - Domination Matrix Kimberly Thompson 0 831 06-21-2013, 05:34 PM
Last Post: Kimberly Thompson

Forum Jump: