Date & Time disappear on WP 34S


Since a couple of weeks now I have remolded an HP30B into a WP34S. All seems to work well, as far as I can judge, but I have a problem with Date and Time. If I set Date and Time, some time later (an hour? a couple of hours?) the settings seem to have disappeared. As soon as I switch on the calculator Date starts with Dec. 1 of 2007 and Time starts running from scratch.
Stopwatch works perfect: I have tested it for about half an hour. So I don't think there is a problem with the installed condensators and the x-tal.
What can be the problem?

Edited: 9 Dec 2012, 6:53 a.m.


Did you activate the crystal? See p. 185.



Hello Walter
what do you mean by "activate"? As soon as the crystal is installed and the two capacitors (I wrongly named them condensators) are in their place, the clock is enabled. Isn't it?


May I repeat? Please see p. 185 of the manual.



Have seen the page (in Manual_wp_34s_3_1_X.pdf, page starting with "First, however,...") and did all the things mentioned there. What specifically are you aiming at?


That's p. 196 in my manual ;-) Please look at the most recent edition - you find it here or here. On p. 185, look for ON + C.


Edited: 9 Dec 2012, 9:44 a.m.


Before your answer I already downloaded the newest manual. The ON+C command gave indeed: Crystal? Installed and a second press on C said Wait... plus an OK. So I think my calculator works in the clock domain. Now I will try to put Time and Date into the machine and then see how it behaves.


Don't worry! In the images named calc_xtal(_full).bin and calc_ir(_full).bin the crystal is enabled by default. You have the stopwatch which is only available in these images. ON+C only works with the standard image.

Now back to your problem: Have you ever seen the message "Restored" or "Reset" when turning on or operating the calculator? This would indicate a power failure which might have killed the RTC settings. What does BATT return? What does BATT return if called from a tight loop?


At least one of my WP 34S shows "Restored" sometimes, although the battery has 3.0V and the calculator did just safely rest on my desk, turned off of course.


I have the same problem. My guess is that there is a current surge at turn-on that causes this, but I have no idea why. I need to investigate in more detail.


Hello Marcus
No, after turning on the calculator I never receive a message Restored or the like, that normally pops up after an update. But after a couple of hours of not using it, I noticed a delay of about 1.5 to 2 sec. before the calculator was starting. In that case I knew that things were going wrong. But now that I have reflashed the device I will see what will happen. I will leave it alone for a couple of hours and then turn it on.


The delay shows that the device has turned off completely and needs to restart the oscillator. This is not normal. :-(


Sounds reasonable. I will see if the problem returns. In that case I will resolder the three components (xtal plus caps).


Had a similar problem with reset and restored messages at power up. In my case discovered in both machines that the battery/batteries would drop off the circuit due to weak battery spring tabs.

Any short jolt, like placing the calc on the table would cause the battery to disconnect. Putting it in my flight bag would result in restored messages..

Fixed it by ensuring the calc case screws were tight and by installing two thin shims on the battery tops. Made mine by folding a small sheet of paper twice (four sheets thick).

When the battery hatch is slid closed it firmly presses the batteries into the contacts. Also bend the contacts upwards.

This may help.



Makes perfect sense. My first HP-20b had a little safety bolt for each battery. It held down the battery reliably. These two bolts apparently became victims of cost cutting – you can see their traces still in the plastic mold (compare the picture on p. 182 of the manual).



24 Hours after upgrade to latest firmware: time and date are correct.


So obviously it was the crystal lacking activation - I had a similar problem recently. Glad you solved it as well.


Possibly Related Threads…
Thread Author Replies Views Last Post
  [WP-34S] Unfortunate key damage with update to V3 :( svisvanatha 5 3,151 12-10-2013, 11:37 PM
Last Post: Les Bell
  WP-34S (Emulator Program Load/Save) Barry Mead 1 1,784 12-09-2013, 05:29 PM
Last Post: Marcus von Cube, Germany
  DIY HP 30b WP 34s serial flash/programming cable Richard Wahl 2 2,495 12-04-2013, 11:14 AM
Last Post: Barry Mead
  Prime: how to detect date format giancarlo 1 1,467 12-02-2013, 11:21 AM
Last Post: Michael de Estrada
  [HP Prime]How to get Discrete-Time Fourier Transform uklo 0 1,514 11-18-2013, 08:02 PM
Last Post: uklo
  WP 34S/43 ?'s Richard Berler 3 2,033 11-10-2013, 02:27 AM
Last Post: Walter B
  My FrankenCulator (wp-34s) FORTIN Pascal 4 2,114 11-09-2013, 06:18 PM
Last Post: FORTIN Pascal
  WP 34S Owner's Handbook Walter B 5 2,644 11-09-2013, 05:34 PM
Last Post: Harald
  wp 34s overlay and programming. FORTIN Pascal 6 2,863 11-08-2013, 01:28 PM
Last Post: Nick_S
  m.dy in display of WP-34S Harold A Climer 3 1,915 11-05-2013, 11:28 AM
Last Post: Andrew Nikitin

Forum Jump: