[WP34s] What am I doing wrong?



#12

Finally I am about to flash a HP30b to become my first "hardware" WP34s. :-) Everything required should be there: A computer running XP SP3, equipped with two physical on-board RS232-ports, which are reported by the OS to be configured as COM1 and COM2, set to 9600 baud and 8N1, I got the HP programming cable and there also is the MySamba flash tool (modified version from the WP34s sourgeforge site).

I followed the steps as described in the manual, and everything works fine from step A1 to A8 - the display finally turns off as it is supposed to. However, the next step (press ON/CE and the display should stay blank) will not work - the 30b turns on. In other words: all I get is a reset 30b.

What am I doing wrong here, and where should I look for the cause of this? The 30b is new, so the batteries should be fresh.

Dieter


#13

Dieter, the essence of the instruction sequence outlined by Walter is that you need to press ERASE while the processor is running. This is easiest if you press ERASE and ON at the same time. The ON key will wake up the processor, it will "see" ERASE, and it will clear the flash memory, including the bit that controls SAM-BA boot mode. Press ON again to make sure the processor is executing the SAM-BA code before you start the transmission.

If this does not work, the connection of the programming cable to the contacts of the calculator might be problematic.

#14

Dieter, did you hold down ERASE all the time from A4 to A7?


#15

Walter, of course the Erase button was pressed all the time, just as described in the manual. Pressing Reset (cf. A5) turns off the calculator (while Erase is still held down). ON/CE turns it on again (with Erase still pressed). After this step the Erase button is released, as described in A7. Another short press of the Reset button turns of the device, but the following ON/CE does not make it look dead - it comes back with 0.00 as usual.

Marcus, I am not sure if you want to suggest a different procedure. What exactly (step-by-step) do you want me to try and see if this will work or not? Is there a way to check if the cable and/or connection is okay or not?

Dieter


#16

As stated in my first post, the whole procedure is about shorting the terminals of ERASE and Vdd while the processor does something. Walters procedure is the fool proof procedure to ensure this. I have the feeling that something is wrong with your cable. Pressing ERASE should short two diagonally positioned pins on the cable. Se manual contains the details. You can replace the ERASE function of the cable by a piece of wire as stated in Walter's manual.

Another thought, try the following procedure:

Turn the calculator on. It should show 0.00.

With the cable pugged in, assert ERASE.

Press some arbitrary buttons on the calculator.

If it doesn't seem to freeze, the cable contacts must be the problem.


#17

Quote:
If it doesn't seem to freeze, the cable contacts must be the problem.

Okay - before I try this: what problem will I have if the calculator actually does freeze ?-) What's to do then?

Dieter


#18

Then it is in SAM-BA boot mode as desired. Press RESET, then ON and send the .bin file via MySamba.

Edited: 18 Nov 2012, 2:14 p.m.


#19

Ok, I tried it. Connected the cable to the serial port and the calculator, turned it on, pressed Erase - nothing happens. The 30b continues to work as usual.

I took another look at the manual. It says: "The following procedure will work only with fresh batteries or an external 3V supply". The batteries that came with the calculator have voltages of 2,98 and 2,95 V (without load). May this explain the problems?

Dieter


#20

That's as good as 3V. The reason I put that sentence in was the battery draining problem mentioned one page before.

#21

Dieter, either your cable or the connector is at fault. You can send me both the cable and the calculator and I'll try it here, if you are interested.


#22

Ah, that would be great. I'll send another message through the forum's email system.

Dieter


Possibly Related Threads...
Thread Author Replies Views Last Post
  [HP-Prime - Geometry App] What is wrong with this ? Jean-Michel 2 332 10-27-2013, 06:26 PM
Last Post: Jean-Michel
  HP Prime: What's wrong with this program? BruceTTT 6 477 10-16-2013, 11:14 AM
Last Post: Eddie W. Shore
  Correct me if I am wrong Denis Doyon 51 2,804 08-14-2013, 02:53 PM
Last Post: Carey
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 315 10-04-2012, 04:59 PM
Last Post: Paul Dale
  Wrong answer when evaluating log(10^-12) Daniel Greenidge 4 377 01-26-2012, 05:54 PM
Last Post: Daniel Greenidge
  [wp34s] Incomplete Gamma on the wp34s Les Wright 18 1,168 12-06-2011, 11:07 AM
Last Post: Namir
  [wp34s] Romberg Integration on the wp34s Les Wright 2 378 12-04-2011, 10:49 PM
Last Post: Les Wright
  What is wrong with this HP-19C Michael de Estrada 3 328 05-03-2010, 01:41 PM
Last Post: Michael Meyer
  Pi wrong? Bruce Bergman 13 770 03-30-2010, 11:53 PM
Last Post: db (martinez, ca.)
  what's wrong with this program? / STO error hpnewbie 21 1,200 09-01-2009, 08:13 PM
Last Post: hpnewbie

Forum Jump: