42S exit key not working



#6

Hi there,

I am having problems turning my 42S on. The on/exit button feels normal but it wouldn't turn it on. I then did a hard reset with XEQ and E, along with the exit button, and the 42S turned on. However, pressing shift/exit to turn it off doesn't work now. To make things stranger (to me), I can do a Machine Reset by pressing exit and square root together. So the Exit button seems to respond for resets, but not for turning the calculator on or off. Any suggestions on what to do?

thanks


#7

Hi.

Do you have data stored on it that should not be lost? If not, try the 'Memory Clear' sequence: [ON][Sigma+][XEQ]

If it is related to any corrupted RAM contents, that should do it.

Success!

Luiz (Brazil)

#8

Hi,

I have an experience of such kind of behavior of a heavily used 42S.

The main cause was the deadly worn membrane switch contacts at the ON key.

The ON key of the 42S requires relatively high current than other keys at turn on.

In other words,the resistance of the contact at the ON key must be lower than a Kilo Ohms.

The resistance of a worn membrane switch tend to go high to cause such kind of problems.

Dead membrane switch at ON key

Lyuka

#9

Does it behave normally if you press down on the left side of the bezel underneath the LCD?

look @ THIS website for diagrams of the keyboard contacts


#10

Yes, I tried turning it on while pressing down on the area just to the left of the exit button, or to the left of the lcd. That works.

Edited: 5 Nov 2012, 11:00 a.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 576 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 373 10-14-2013, 01:46 PM
Last Post: BruceTTT
  HP-97 suddenly not working Brad Barton 10 349 02-25-2013, 08:15 PM
Last Post: Brad Barton
  [41CL] Problem with PowerCL ... not working Doug (NYC) 5 260 01-22-2013, 07:18 PM
Last Post: Doug (NYC)
  HP-46 not working Ignacio Sánchez 1 131 10-24-2012, 11:17 AM
Last Post: Donald Williams
  [WP34s] last QtGui version not working fhub 8 385 08-31-2012, 05:08 PM
Last Post: fhub
  Modfile not working with Win 7 x64 Richard Wagoner 6 281 07-04-2012, 10:32 PM
Last Post: Diego Diaz.
  Working on HP's again Les Koller 49 1,528 06-20-2012, 01:29 AM
Last Post: Thomas Radtke
  held breath, found tapes & drive working Garth Wilson 9 376 06-12-2012, 12:52 AM
Last Post: Garth Wilson
  Working around broken Spice battery connections Les Wright 7 360 06-06-2012, 06:50 PM
Last Post: Mike T.

Forum Jump: