Update of Emu71/Win to v1.02



#2

I just updated Emu71/Win to v1.02 available at http://hp.giesselink.com.

I decided to publish my HP71B KML scripts now with Franz Huber's keyboard mapping files for US, UK and German keyboard mapping. Many TNX to Franz. In difference to before there's no batch file to select the keyboard mapping file any more. The updated KEYB71B.KMI file now contain a switcher using the new KML "Locale" command for including KML blocks dependent on the current keyboard input locale. The old KEYB71B.KMI keyboard mapping isn't supported any more.

Sorry, the syntax of the "Locale" command isn't documented so far. The argument of the Locale command is a decimal number representing a keyboard locale. A Null value for the primary or secondary locale ID part is like a wildcard. Only the first matching locale block content will be included, following matching locales are skipped. The "Locale" command will not be limited to Emu71/Win only, all beta versions of my other emulators contain the "Locale" command already but I cannot make any publishing dates for them so far.

Check the Emu71 CHANGES.TXT file for the other changes please.

Christoph


#3

Thanks for the updates and thanks for Franz for contributing too!

I looooooooooooove your emulator!

Namir


#4

Quote:
I looooooooooooove your emulator!

Yes, I love all of Christoph's EmuXX too! :-)

I saw that Christoph didn't include my special KML-version 'HP-71B Super-Keyboard' which allows to directly click on all labels/functions on top of the keys, so here's this file if anyone is interested:

http://www.hpmuseum.org/guest/fhub/superkbd.zip

Franz

#5

When I read along the CHANGES.TXT there is not too much for me in there, but I understand what kind of work it is to set up such an emulator/simulator. BTW, I assume the bugfix in function findndevice() was _not_ triggert by my hint. :)

Ciao.....Mike


#6

Actually, the (minor) bug in findndevice() comes from my HP-IL code in Emu71/DOS.

The fix from Christoph is absolutely right!

Thanks, Mike and Christoph!


#7

Yes, Christoph told me so. But I hope it was not me why he fixed it now.

Ciao.....Mike


Possibly Related Threads...
Thread Author Replies Views Last Post
  [HP Prime] My .02 take. Jim Creybohm 14 665 11-07-2013, 04:58 PM
Last Post: Paul D. Fox
  Does the HP Prime software only work with Win 7/ 8 ? Michael de Estrada 3 282 10-12-2013, 02:52 PM
Last Post: John Ioannidis
  Update of Emu71 to v1.05 Christoph Giesselink 0 141 09-24-2013, 04:22 PM
Last Post: Christoph Giesselink
  EMU71 on a web page! hugh steers 13 600 07-14-2013, 12:47 PM
Last Post: Namir
  EMU71 to go71b--is there a way? Les Wright 12 519 06-25-2013, 07:08 AM
Last Post: Mike (Stgt)
  RPN-67 Pro updated to v1.2 Willy R. Kunz 29 1,192 06-12-2013, 04:32 PM
Last Post: Willy R. Kunz
  Update of Emu48 to v1.55 Christoph Giesselink 4 287 05-26-2013, 05:28 PM
Last Post: Andrew Nikitin
  Update of Emu42 to v1.17 Christoph Giesselink 1 135 05-15-2013, 09:30 AM
Last Post: CompSystems
  Update of Emu28 to v1.27 Christoph Giesselink 4 230 05-02-2013, 04:36 AM
Last Post: Mike (Stgt)
  Update of Emu71 to v1.04 Christoph Giesselink 8 394 04-18-2013, 04:11 AM
Last Post: Mike (Stgt)

Forum Jump: