Problem with HP41CV


I have a HP41CV. If I take the batteries out for over 24 hours and then put them back in and then press the 'On' button the calculator comes on and works completely normally, everything works.

But if I shut it off or it shuts itself off it will not come back on. At all. The ONLY way to turn it back on is to pull the batteries out and wait over 24 hours to put them back in.

Does anyone know what is causing this?



Have you tried a 'master clear', or MEMORY LOST procedure? Based on what you mention the memory contents are kept even after 24 hours without batteries (I have one that kept memory contents after two days without batteries).

Hope it solves the problem.


Luiz (Brazil)


Oh, I almost forgot, Luiz, no I get the MEMORY LOST screen EVERY time the calculator comes on...


Well I tried some fresh batteries. And it is working fine with them.

But this raises more questions than it answers.

I understand about the batteries coming back while they are out of the calculator enabling the calculator to turn on. And I can imagine them becoming weaker and not being able to turn it on again, but...

First why does it work normally as long as I am using it if the batteries are that low? Does it really take THAT much more energy to turn the calculator on than to run it?

Also these batteries are 10 days old TOPS! They are Energizers and their pull date is March 2017! I don't have ANY accessories plugged in and the calculator has not been on much.




Do you have the means to test each battery for their amps capacity? Chances are you'll find one of them with internal problems.

Let's think it over: consider you have a battery that starts OK and have its internal resistance (impedance) to slowly raise as it discharges. The HP41 power control circuits may not sense voltage reduction up until some low value, but for as long as the batteries supply enough current, it runs OK. When you turn it off, chances are the offending battery immediately drops its voltage or reduces the current capacity, but after resting for some time (maybe less than 24 hours) it would work closer to a good battery. I'd consider temperature, even though it would be a few hundredths of degrees up.

Why not? It's only chemical compounds inside, no microcontroller to tell us what's happening!

I remember one time when I bought fresh, new batteries for my HP41C and right after pulling the pack in it went up with the BAT indicator lit. I felt furious about it because at that time, here in Brazil, we had to prove the goodies we bought were the same as the one we were trying to replace as for defective reasons or any malfunction. Batteries were never replaced once we left the store. I was lucky noticing I wrongly placed one of the batteries, it was with their poles inverted. Once correctly set, the indicator turned out. What called my attention was the fact that the HP41 worked fine, even with less than 4Vcc from the set (actually, it should be closed to 3Vcc), but because the batteries were fresh new, there was current enough to keep it running. Only the BAT indicator was lit.


Luiz (Brazil)

Edited: 17 Sept 2012, 12:49 a.m.


Okay I really blew this one. I had two identical calculator on my desk and I picked up the wrong one. (To many distractions I guess..)

So I am back to my original problem.




Can you try the fresh batteries in the one with the weird symptoms? Let's see what happens.

IN any case, I'd not give up testing the batteries for their ampacity.


Luiz (Brazil)


thanks a lot for hanging in there Luiz (I felt like an idiot when I discovered I was testing the wrong calc... must be getting old...)

Yes I put brand new batteries fresh out of the package in the the 'weird' calculator... (and I tried them in the 'good' calc) I'm pretty sure this set of batteries is okay.

In case you missed my last post, the 'werid' calc ALWAYS displays 'MEMORY LOST' when it comes on. And like I said in the first post, it will only come on after the batteries have been out of it for 24+ hours. I've tried every trick I know to get a HP41 going (and I know a lot of them) but this has me stumped so far. I probably will figure it out eventually but I thought I best find out if anyone has had experience with this problem or a similar problem.


I had the same exact problem on 3 different HP41's 2xCV 1xC.
After running the service module (Clonix-D Thanks to Diego), I was getting "Bad D/S" errors. They eventually stopped responding even after 24 hour battery removal. Now all 3 are happily reincarnated as 41CL's and living a new and faster life, thanks to Monte.

I highly recommend that you run the service module before wasting more time if the problem is the D/S chip(s).

Edited: 17 Sept 2012, 3:41 a.m.


Thank you Kerem, I actually asked Monte how I could get my hands on a service module. He suggested that I could use a Clonix. I haven't looked into that yet. I guess this is further motivation to do that.


Hi Bruce, Clonix is a good investment, I would highly recommend it if you are going to keep and use your HP-41. Also if you have the same D/S problem which I had, there is little option (other than trying to replace the D/S chip) but to replace the main board with 41CL. If I remember correct Diego has a USB cable with Clonix module that may help you not only to provide the service module now but also able to transfer files to/from 41CL-PC in the future(as well as provide USB power). I hope this helps. Regards, Kerem


That is interesting!

I have recently bought an almost dead (corrosion due to battery leak) tall key 41C. I installed the main board and back with the battery contacts of my 41CV (which had a bad display driver).
This "tall key 41CV" now shows the exact same behaviour as yours. And so far I have not been able to work out why. My batteries are almost new and work fine in my other 41CV.


In the service manual it says to check capacitor C9 and IC U2. I'm going to try that next, sometime this morning. (I have both parts if they are defective.)


The problem was a bad power supply chip U2 (1826-05660). I replaced it and the calc is working perfectly!


Only thing is I can get the case to fit back together and I'm going nuts trying to fixer out what is preventing that.

Time to take a break....


And thanks for sharing!


Edited: 17 Sept 2012, 4:01 p.m.


Thank you for helping Luiz... I am sure I will need more.



Bruce, this is great, congrats. I would like to find out more about this, how/where did you find the replacement U2 chip? I may consider having one or two in hand in case if my non-41CL's have a similar problem. Thanks.


I had a brand new chip on hand. It is probably the last one in existence. You'll probably have to get one out of a dead HP41.


Thanks for the info! Is there a schemtic online somewhere? If not, I am sure it's on the Museum DVDs - I'll have a look when I get home. Hopefully the power supply chip in the otherwise dead 41C is still OK.

Edited: 18 Sept 2012, 4:15 a.m.


Hopefully the power supply chip in the otherwise dead 41C is still OK.
That's why 'Never toss them away' is a wise advice...


Luiz (Brazil)

Possibly Related Threads…
Thread Author Replies Views Last Post
  hp41cv memory modules tim peterson 10 3,672 11-07-2013, 11:09 PM
Last Post: Garth Wilson
  HP41CV Mike Powell 12 3,521 10-30-2013, 08:17 AM
Last Post: Mike Powell
  HP41CV Bry Sun 11 3,313 10-22-2013, 12:52 PM
Last Post: Geoff Quickfall
  HP41cv expiriences of a new user Wolfgang 28 7,142 02-13-2013, 08:02 PM
Last Post: Mike Morrow
  A simple question about the HP41C or HP41CV Antoine M. Couëtte 6 2,392 12-16-2012, 04:06 AM
Last Post: Antoine M. Couëtte
  HP41CV drains battery. Schematics? Harald 15 4,292 03-18-2012, 09:22 PM
Last Post: Luiz C. Vieira (Brazil)
  HP41CV batteries John Abbott (S. Africa) 3 1,500 03-02-2012, 06:15 AM
Last Post: John Abbott (S. Africa)
  HP41CV faulty Steve Hunt 6 2,013 12-27-2011, 12:45 AM
Last Post: Kerem Kapkin (Silicon Valley, CA)
  Repair HP41CV. Help needed. Kees van der Sanden 4 1,596 10-11-2011, 07:44 AM
Last Post: Ronald P
  Interesting HP41CV? Dimitri Simitas 2 1,188 02-20-2010, 03:48 AM
Last Post: Klaus

Forum Jump: