HP-97 Write Error



#8

Hi All,
Working on a recently purchased HP-97. I repaired the card reader and printer with help from posts and articles on this site. Thanks!
Now the card reader will read cards fine. The motor pulls the card smoothly and quietly. If I try to write data or write programs it comes back with Error.

I've tried:

- checking the 3 contacts with an ohmmeter. The Motor one closes when I first insert a card. If I push a little further, the WPS closes. Then if I push farther, the Head switch closes. All three open when there is no card. I assume that's correct? Any more to check with the WPS?

- I've rotated the eccentric shaft 1/4 turn in 3 different positions. No change. Do I need to make finer adjustments to try?

What else should I check or try?


#9

Hi.

I'd check if any of the head coils is not interrupted. IIRC there are four coils serially built in two pairs. Should check with the schematic, though.

Success!

Luiz (Brazil)


#10

I didn't check the head because the read was working fine, but I did try the adjustment procedure on the WPS - tightened screw until it closed and then backed off 1/4 turn. That seemed to help matters as now it will write ok some of the time. However in removing and re-inserting the flex ribbon cable several times, now it is de-laminated and I had great difficulty inserting it one last time. I'm afraid if I take it apart one more time, it'll be totally dead.

I read some various posts on replacing this flex cable with something else, but those were from 10 years ago. Is there any best-practice method for replacing the card reader flex ribbon cable these days?


#11

Hi.

I must confess I never had to replace it, but I am aware of what you mean. I was wondering about it and I think it is not going to be difficult finding a replacement. Consider that new flex cables may be found in several different dimensions and # of conductors. If it is wilder it can be, then cut it sideways; if it is longer, it can be bent; and if it has more conductors than you need - maybe the conductors are 1/2 wider than the original with twice as much conductors in the same space - chances are you can fit it in a way only the necessary conductors will fit.

Not a solution, I know, but if you check amongst the existing flex cables you will find for sale which one(s) get closer to the one in the card reader, it is a matter of trying out. Mostly of what we do here in Brazil... ;) Nothing fancy, I know, but in some cases we have problems solved.

Success!

Luiz (Brazil)


Edited: 29 Aug 2012, 7:34 a.m.


#12

Another solution would be to remove the connectors altogether and just solder some regular ribbon cable in its place. Less convenient for disassembly in the future but probably trouble-free. There are some inline ribbon cable connectors that could be used too if you wanted to go to the trouble. Most everything should be available from Mouser or Digi-Key.

#13

Update:

I ordered headers and cables needed to replace the flex cable with an IDC 26 wire IDC cable. However before going forward with the mod, I decided to rebuild the battery pack since it seemed to be losing charge quickly. With the new battery pack, the write seems to be working fine. So I'll just hold on to the parts in case I need to disassemble in the future.


#14

Hi.

Chances are you had one (or more) faulty cell(s) in your previous battery pack. If we consider that writing magnetic cards, along with printing and LED display driving are the most current-consuming operations (cannot be sure about running programs), a good current-source is always desirable. So, if with a new pack it writes OK, I'd test each of the old cells if wishing to identify the offender.

Cheers and congrats!

Luiz (Brazil)


Possibly Related Threads...
Thread Author Replies Views Last Post
  [HP Prime] "Error while checking exact value with approximate value, returning both!" Chris Pem10 13 2,666 12-06-2013, 05:12 AM
Last Post: parisse
  MS advert shows spreadsheet with obvious error BruceH 3 1,177 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  HP Prime: Rounding error in determinant Stephan Matthys 3 867 10-25-2013, 09:29 PM
Last Post: Walter B
  HP Prime Error: Summation Upper Bound > 1000 HP Pioneer 2 739 10-25-2013, 11:32 AM
Last Post: steindid
  Prime Error or Mine? toml_12953 12 1,974 10-22-2013, 10:35 AM
Last Post: toml_12953
  Explaination on How to Reset Caculator in Users guie: error Harold A Climer 5 1,277 10-15-2013, 02:11 AM
Last Post: cyrille de Brébisson
  Repair of HP-34C - Error 0 and Error 9 Jeff Kearns 3 904 10-11-2013, 12:29 PM
Last Post: Randy
  Do You Think a Listing Error Was Made? Jim Johnson 13 2,058 09-04-2013, 09:23 AM
Last Post: Eddie W. Shore
  HP Prime: Error reports : Here Patrice 111 9,503 07-24-2013, 05:52 PM
Last Post: Thomas Klemm
  PARTFRAC error. Romeu Medeiros 2 735 06-23-2013, 10:27 PM
Last Post: Romeu Medeiros

Forum Jump: