Restoring an HP65 (trying to .... few pics)



#33

ciao a tutti,

I have purchased an HP65, mainly because I needed a card reader block, since one of mine has a damaged head.

However, when it has arrived, it looked better than described, and before using it as a donor, I wanted to try a restoration.

It has been cleaned inside out from the oxidation,nothing too bad, but presents anyway.

All I get is a very faint "0" with some missing segments.

If battery is attached directly to the card reader engine, this runs.

The two power supply transistors get burning hot after few seconds that the unit is powered on.

Where should I start from ?

Pictures have been taken before any operation was done, the contact plate that is misplaced in picture 1 has been put in the right place ...

Thank you very much for any help and any hints provided !!

Alberto









#34

hello alberto,

i would recommend to start the repair WITHOUT the card reader board connected ... check at first the voltages generated on the logic board and in case you have a scope you should inspect the PHI signal ... these are VERY essential testings before oing on ... look in the HP-forum there are several postings concerning the generating of the operating votlages and the according circuitry ... in case the you are able you get the calc to work WITH DISCONNECTED card reader, i can let you know some hints for the card reader ...


peter from Austria


#35

Hello Peter,

thanks for your help, I'll try to measure some values and I will report the results.

As a general rule, the PCB has been cleaned with Deoxit, is it advisable to rinse it with Isopropyl Alchol or Ultrasonic cleaning and then let it dry ?

Thanks again Alberto


#36

Ciao Alberto and thank-you for sharing this repearing job of the 65. This is the first time I see such a calculator opened and it's quite different if compared to the HP67, so that I will follow this post with pleasure....
I ask you please to tell me when you have found here in Italy Deoxit and the Isopropyl Alchol, 'cause I was not yet able to find them.
I visited all the electronics and equipments shops here in my town and I found only adry cleaner named "LIFE"....
Then I would like to smile saying that you calculator's display looks like a "predatorian" one....you know what I mean, the movies' character "PREDATOR"

A presto and compliments for your new machine.

Aurelio


#37

ciao Aurelio, ciao a tutti,

in Italy the only way to have deoxit is thru TAS (the italian site), there is a seller in Bologna I'm not affiliated in anyway to TAS or to him.
There you can have Deoxit D5 for 23 euro + shipping, but he can also sell you deoxit 100.

Let me know if you need the link to him, but I'm sure you will find it, take care Alberto


#38

Quote:
There you can have Deoxit D5 for 23 euro + shipping, but he can also sell you deoxit 100.

I have bought a 25 ml bottle of DeOxit D100L for 25,70 euro in The Netherlands, last April. I tried cleaning a corroded HP-21 pcb with it, but unfortunately it did nothing. I am sure it is a quality product and maybe it works well for cleaning contacts etc., but in my experience it is no good for cleaning corroded pcb's.

#39

Hi Alberto,

If the two transistors on the logic board are getting hot, then you most likely have problems with the dc-dc converter. As Peter says, check the three voltages Vcc, Vss and Vgg. I would recomment you replace both transistors, the 2nF capacitor and all diodes in the dc-dc converter. Check all the "Kemet" tantalum capacitors as well, although they are apparently good quality components, they can fail.

Cheers,
John

Edited: 18 June 2012, 7:44 p.m.


#40

I'll certainly do so, over the weekend, and post the results ...

I went thru the documentation published by Tony Dwell, but couldn't find the part number for the transitors,

does anyone know it, or knows an equivalence ?

thanks again Alberto


#41

hello alberto,

i want to confirm the statements of John, he is a great specialist on the hp-65 and has a lot of experience ... concerning the replacement parts John described it in an expertise and stated

Q1 - 1854-0094 -> PN3646
Q2 - 1854-0550 -> 2N3904

... be careful in using a battery pack with the original charging unit - i think it is better to use an external power-supply ...

... attention in cleaning CORRODED parts especially the hybrid unit -> because the corrosion diffundes to the inside of the hybrid and generates faults to the 6 discrete chips inside !!!

... as i mentioned before - in case the dc-dc unit is operating okay supply voltages are okay - the PHI signals are generated by the led driver and are fed to the hybrid IN pins - in case you have NO okay signals on the OUT pins -> the hybrid will be faulty and you can stop further actions OR you have a hybrid in spare !?

... Tony Duells description of the chips is very helpful and a good base for error tracing ...

... conclusion over all: for trying to repair the card reader it is ESSENTIAL that you have a working logic board/display/keyboard ...

good luck from Austria

peter


#42

Please,can anyone post a picture of the hybrid components ?

I keep reading about this two parts, as mentioned in Tony's material but I can't figure out (actually I don't have the unit in front of me)how these look.

Hope I have not damaged them when cleaned the PCB with Deox....
thanks in advance, Alberto


#43

here i am again ... i have attached a picture of a CORRODED hybrid ... the green arrows show them ...

it should ONLY demonstrate, what happens with corrosion ... in this case the hybrid wasn't working anymore and I opened it for demonstration ...

peter from Austria


#44

Thank you for uploading this picture! I have always wondered what was inside, now I know :-)


#45

Dear All,here is what I did :


step 1:I have taken a known working PCB and plugged into the keyboard PCB of the unit under restoration. Result is that the unit was working.
We can assume that the keyboard PCB, the LED and the anode cathode ICs are working on the unit I'm trying to restore.


step 2:put the working pcb back in its own keyboard PCB and measured the values :

Vss : 6,28 Volts

Vgg : -12,53 Volts

Vcc : 7,95 Volts


step 3:I have then measured the values in the unitunder restoration :

Vss : 3,14 Volts

Vgg : 0,97 Volts

Vcc : 3,62 Volts


Both units have been power with only the very same charged battery pack. The unit under restoration has the card reader removed.

What's your guess ??

Thanks again, take care Alberto


#46

Alberto,

oki doki ... step3 don't look fine ... take the steps John recommended ... change transistors ...

peter


#47

Dear Peter, dear All,

on my way to work this morning I stopped at the electornics parts shop and I have purchased a new set of transistors.

This is what I have been given :

1854-0550 (forum suggested 2N3904) found 2N3904 e BC182

1854-0094 (forum suggested PN3646) found P2N2369

I have replaced both transistors, firstly with a P2N2369 and a BC 182, the voltages remained the same and both transistor remained cool.

Then I have replaced the BC182 with the only 2N3904 I have found, voltages remained the same but both transistors are now getting hot, less than before though.
P
I'm restoring an HP55 that has a keyboard issue, but the PCB works well. Should I get components like capacitors and diodes from there in case I can't find them new ?


Thanks again, what else can I try now ??


#48

Dear All,

this is a small image (due to size limitation) of the board.

I have pointed out all the components that I believe belgon to the PSU

still I have been able to recognize only one diode.

What components are those the I have indicated with a question mark ?

Thanks again Alberto



#49

Please, ignore this last post, Ignazio (thank you so much) as
pointed out this link :

PSU for Classic units

where all this information are available, still I have now a to-do list that must be accomplished ...


#50

Alfredo,

... the link is very GOOD ...
i strongly recommend to find/use the replacement transistors mentioned by John ... my impression is, that the oscillator doesn't work ... important besides Q1 + Q2 is the capacitor C2 with 2nF ... try to get the right replacements ...


hope this helps ...

peter


#51

Dear Peter,

I have been able to find all the diodes and some of the
capacitors, the 3.3 micro and the 15 micro.

I have not been able to get the 2 nF ceramic, neither the 22 micro and the 60 micro.

At first I'll replace the dioeds, than I'll post the results ...
thanks again, take care Alberto


#52

Dear All,

this is what I have done so far :

1. replaced the transistors : no improvements

2. replaced the zener with a 6.2 V (6.0 was not available) : no improvements

3. replaced all the 1N34A : Vcc is now 6.76 !!

4. replaced C1 with an used but 100% working one : no improvements other the Vccas before

5. replaced C8 and C4 : no further improvements ....

what would you suggest as next step ??


By the way, this is the orientation I have kept when substituting the diodes :



Is a correct assumption that the orange band on the upper is the catod and is rapresentd on the old ones as the first brown ring ?
I made this assumption based on the fact that CR4 and CR5 are
catod to catod connected, but please confirm it.




this is how it looks now the LB




This are the parts changed so far ...

Thanks again to everyone !

Alberto


#53

After the last works have you other news for Vss and Vgg?

Ignazio

Edited: 21 June 2012, 3:30 a.m.


#54

ciao Ignazio,

unfortunately not, they have both the same (wrong) values ...

thanks again, Alberto

#55

Alfredo,

... concerning wrong voltages on Vss + Vgg and Vcc=6,76V ... in think that oscillator works, because the rectification on CR2 gives right value, BUT NOT on CR1, 3 + 5 ... may be diodes are faulty or appropriate capacitors CR3, 6 + 7 ... you should use 1N34A or equivalent and be sure that the tantals are okay ... concerning the diodes look for "farnell" MICROSEMI 1N34A (€ 1,51)... CR5/C7 deliver Vss and C2/C6/CR1/CR3 voltage doubler assembly Vgg ... make sure that these components are okay ...

peter


#56

ciao Peter,

all the diodes have been changed with 1N34A, I have found exactly the same type.

I'm in the process of changing the capacitors, but I have not been able to find a couple of values, so I'm thinking of taking these off a working spare board of an HP55.

Hope to post soon some good news !

P.S. althought Alfredo is a nice and famous name here in Italy (who doesn't know the song Amami Alfredo), mine is Alberto :)


#57

Peter, one more thing ...

Also in a couple of previous messages, you wrote C2 but the value of capacity and the arrow pointes to C1.

Which one is the one you mean is involved in Vgg ??

Also, what is the value for C6 ??

take care Alberto


#58

Alberto,

First off all please excuse the wrong prename, thanks
... concerning C6 it should be C4, my mistake !!! summarized again

Vgg <-- C2/C4/CR1/CR3
Vss <-- C7/CR5

... tantal -> check the polarity and that they are not damaged

C2/C4 - 3,3uF and C7 - 22uF ... okay

peter


#59

This Message was deleted. This empty message preserves the threading when a post with followup(s) is deleted. If all followups have been removed, the original poster may delete this post again to make this placeholder disappear.


#60

ciao a tutti,

so far, I have changed all the discrete components,

both by using new replacements, as for the transistors, diodes (including the zenr) and the 3.3 and 15 microF capacitors,
or using components recovered from a known working board for the other two capacitors and for the transformer.

However, the only Voltage I have been to take back to normal value is Vcc.

Would anyone suggest to remove ICs and inspect the conditions of traces under thos components ?

Thanks again, Alberto !



#61

ciao a tutti,one more update on this project.

Since all the discrete components had been changed, I had decided to start removing the ICs as well and measure the PSU values.

The hybrid is very sensitive, easy to break, so I started with the three ROMS : 1818-0074 (lower left), 1818-075 (lower right) and 1818-0073 (upper right).

Well, these are the values :

without all the three roms:

Vss : 5,06 V

Vgg : -11 V

Vcc : 6,26 V


with the 1818-0074 soldered back:

Vss : 4,95 V

Vgg : -10,87 V

Vcc : 6,24 V


with the 1818-0074 AND 1818-0075 soldered back:

Vss : 4,80 V

Vgg : -10,71 V

Vcc : 6,25 V


with all the three ROMS soldered back:

back to the old values ....


Then I desoldered a 1818-0118 from a HP55 , it should be a ROM 1024*10 with the same pin out of the 1818-0073 that looks to be the guilty on my HP65 board.

The values are :


Vss : 4,80 V

Vgg : -10,71 V

Vcc : 6,25 V


but still the display doens't work.

It's getting better, but still I'm missing something ....

What else should I try ?

Thanks for help, Alberto


#62

Alberto,

Look for the PHI 1/2 signals IN + OUT with a scope ... look the picture I posted before ... on the left side, where the test pins are located, you see PHI 1/2 OUT and on the lower side of the board there are the PHI 1/2 inputs pins, leading from the display drivers, where the PHI is generated ... in case you have NO PHI 1/2 OUT - as a function of the hybrid - may be that the hybrid is faulty ??? ... these PHI signals are very essential !!!

peter


#63

ciao Peter,

the problem is that I don't have a scope,can I take a measure with a meter ?

take care Alberto


#64

Alberto,

on the PHI 1/2 OUT level should be abt. 3,6v NOT near 0v and NOT abt 5v ... ON EACH OUT pins !!! ...

it would be better to watch the signals with a scope ... but for a rough diagnose the voltage says if oki or not ...

peter


Possibly Related Threads...
Thread Author Replies Views Last Post
  OT--Nat'l Semiconductor NS-7100 pics anywhere? Matt Agajanian 25 1,890 12-15-2013, 08:39 AM
Last Post: gene wright
  HP65 Prices - have I missed someting? Harald 9 472 05-17-2013, 06:54 PM
Last Post: ClausB
  Cheap rare HP35 and HP65 report Waon Shinyoe (China) 4 303 02-20-2013, 08:47 AM
Last Post: Frank Boehm (Germany)
  restoring HP29C - help needed Alberto Fenini 9 416 11-25-2012, 07:56 AM
Last Post: Alberto Fenini
  So any pics / videos from HHC 2012 bluesun08 6 351 10-01-2012, 04:49 PM
Last Post: aurelio
  HP67 motor in HP65 card reader - too slow Harald 4 285 05-21-2012, 06:52 PM
Last Post: Dave Shaffer (Arizona)
  Restoring an HP-55, advice appreciated ! Alberto Fenini 4 274 05-15-2012, 03:43 AM
Last Post: Alberto Fenini
  HP65 program cards compatibility aurelio 2 219 05-04-2012, 04:43 AM
Last Post: aurelio
  Most worn out HP65 ever Harald 7 312 05-03-2012, 07:45 PM
Last Post: Harald
  HP65 related: I know it belongs in the adds, but I need advice. Luiz C. Vieira (Brazil) 2 155 04-07-2012, 07:31 AM
Last Post: Luiz C. Vieira (Brazil)

Forum Jump: