held breath, found tapes & drive working


Last night my HP-71's Forth/Assembler module died, crashing the computer, and, in my effort to find what caused the crashing, lost all my RAM-resident files. I'm not happy to lose the module, but better that one than my HPIL or math module! The little computer has been so stable, that with my 160KB of RAM, I haven't used the tape drive in probably 15 years, maybe more. Anway, after I figured out the problem and was ready to re-load things, I got out the 82161 tape drive and my collection of tapes. I didn't know what I would find, since some of the posts here in the last few years expressed doubt that the tapes could last that long, either because the emulsion peels away from the backing or the pad deteriorates. I powered the tape drive up from a power supply and clip leads clipping to the battery terminals in the bottom since the batteries were worthless many years ago, put in tape after tape, read out the catalogs, and loaded files. What a relief! It all worked.



Good news are always good news!


Luiz (Brazil).


Having my share of nail-biters and close calls, this is good news, indeed! Congratulations!


With that much RAM you may be able to load the lost module's LEX file in RAM in a similar way as I did for the MATH module (Article #908).


The Forth module has to take over an absolute address space though and cannot be moved around like other modules. I did find that a couple of my tapes had a LEX file that's in that module however, the part I need the most if I don't do any more Forth on the 71 for the moment, so I happily loaded that in. I will still be watching for a replacement module, but it's not a high priority. I have a second 71 but not the modules to fill it out like the first one. Now if someone would just make something like a NoV-64 for the 71, the only thing it would not replace is HPIL, and some of its need would go away if the new module had a serial port. With the dead Forth/Assembler ROM module, I even have a shell to build the new module into. Come to think of it, I also have a 4K RAM module I got for $10 for that very purpose.

Edited: 7 June 2012, 3:38 p.m.


It is very unusual for a ROM module to fail.

Is the module completely non-operating? Can you still access the hard-addressed part of it (i.e. PEEK$("E0000",16) returning "6400E4050E8F11EB"?)? If yes, you could still use it with the Forth ROM soft-addressed files in RAM.


I've never heard of mask ROM failing either, but neither of my HP-71's will work at all with it plugged in. Upon power-up, there's an immediate crash, with the beeper making strange whispering noises and all kinds of junk zooming through the display, and I can't even get an INIT 1, 2, or 3. The problem came on suddenly. However, since the night of the problem (and narrowing it down to this module and removing it), I've had the computer running a program 18+ hours a day on a project, with no further problems.


I recently had a deep crash on my HP-71B. The HP-71B was non-operating (weird display) and the INIT 2 test reports the third system ROM as bad, even after several INIT 3 reset and battery removal. I had to completely discharge the HP-71B internal supply to recover, then the internal ROM was tested ok again!

It can happen that some HP-71B bus components (maybe internal RAM) get in abnormal state (configured to incorrect address - over the 3rd internal ROM in my case). Since the configuration is completely driven by software and that there is no master reset, the situation can only be recovered by a complete power cycle. But due to the very low consumption of CMOS chips (of that time), a simple short battery removal or module removal is very often not enough.

In your case, it may be that the soft-addressed part of the Forth module went into an abnormal state, covering the system ROM. You could try to completely discharge the HP-71B system supply with the Forth module inserted. To discharge the internal supply, I connect the 2 extreme pins of the card reader port with a 100 Ohms resistor (with batteries removed of course, and mind the ESD!).


With both 71's, immediately after unplugging the module, the computer operation was back to normal, without having removed the batteries. With the module plugged in, I couldn't do anything at all. As soon as the module was unplugged, the ROM tests were normal. I will try the discharge with the module plugged in on the back-up 71 though.

The only severe crash I have ever had came as a result of doing DIM X$[length](how many), ie, wrong order, in a text file when I tried TRANSFORMing to BASIC. Even INIT 3 wouldn't bring it back. For complex programs, I like to write in text, with indentation, white space, and no line numbers, sometimes with long, descriptive variable names which get replaced by a search-and-replace before TRANSFORMing to BASIC. Then a subprogram adds the line numbers and removes blank lines and comments before doing the TRANSFORM. The original text file is kept of course.

There were a coule of times I got a MEMORY LOST when I turned it on, but a tip from a friend about buttons getting pressed in the attache case prompted me to have a woodworker friend make me a thin wooden box to slide the HP-71 case into. The 71 in its case with the quick-reference booklets and key overlays fits snugly but not tight. That was over 15 years ago, and there have been no MEMORY LOST occasions since then (until the Forth ROM died).

Edited: 8 June 2012, 9:13 p.m.


In your case, it may be that the soft-addressed part of the Forth module went into an abnormal state, covering the system ROM. You could try to completely discharge the HP-71B system supply with the Forth module inserted. To discharge the internal supply, I connect the 2 extreme pins of the card reader port with a 100 Ohms resistor (with batteries removed of course, and mind the ESD!).
Well, the module sat in the drawer for several days now, so I removed the batteries from the backup 71 which has nothing else in it including any programs to worry about losing, plugged the Forth module in, pressed ON and / together for several seconds, then put the batteries back in and turned it on, and it seems to work normally. The 71 I use is busy working on something it will be done with in a few hours, but I might wait until the end of the project (a few days?) to try the Forth module in it again.

I work with ESD-sensitive parts all the time, so I'm quite familiar with the handling precautions.

When the module quit before, the program had been running for many hours, uninterrupted, then suddenly beeped and gave an untrue error message that something was not found (a label, a device on the loop, or something else-- I don't remember), then it crashed totally and INIT 3 would not bring it back.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [HP Prime] Calculating Prandtl Number with Units (bug found in USIMPLIFY) Timothy Roche 1 1,337 11-13-2013, 04:07 PM
Last Post: cyrille de Brébisson
  OT--Found!!! An HP reference on 'The Big Bang Theory' Matt Agajanian 0 1,105 11-08-2013, 10:23 PM
Last Post: Matt Agajanian
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 4,120 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 2,671 10-14-2013, 01:46 PM
Last Post: BruceTTT
  HP-65 Video Tapes - Anyone have a Copy? Bill (Smithville, NJ) 3 1,767 10-09-2013, 07:40 PM
Last Post: Paul Berger (Canada)
  Hand Held Products RS232 to HP-IL aj04062 11 3,417 08-31-2013, 07:12 PM
Last Post: Paul Berger (Canada)
  HP-fonts - Where can I found? Csaba Tizedes (Hungary) 4 1,642 08-23-2013, 05:01 PM
Last Post: Csaba Tizedes (Hungary)
  OT - Converting 9 track 6250 bpi tapes Marcel Samek 0 895 05-31-2013, 08:26 PM
Last Post: Marcel Samek
  Fun things found by running strings on the 39gII emulator bhtooefr 11 3,718 05-16-2013, 12:40 AM
Last Post: Mic
  Athana DC100A Tapes inaki 6 2,035 03-14-2013, 01:55 AM
Last Post: David Ramsey

Forum Jump: