Working around broken Spice battery connections



#9

I obtained my 33C with one of the tabs broken, and since I continued to wedge in full size AA NiMH batteries in time the second one gave way too in time.

I now have proper size battery packs, but my workaround has been to wedge aluminum foil between the remaining nub of connector and the battery termini. This is only partly satisfactory--things function, but the connection is fussy and if not complete or snug enough the low-bat dot begins to flicker even if the battery is fully charged.

I understand this is a ubiquitous issue with the Spice series so I hope someone has a more enduring solution.

TIA,

Les


#10

i think katie posted something a few years ago involving beryllium sheet and rivets. whatever it all was; it looked like a better fix than the original factory solution.


#11

db, what a memory!

Here's an old thread about this.
Small Parts was bought by Amazon a while back, you can the parts from them them.

Here's a picture of a so-so replacement:


Edited: 5 June 2012, 1:14 a.m. after one or more responses were posted


#12

Katie, I don't see a working link.

Canadians can't order from Amazon.com. Amazon.ca offers a different spectrum of products, and not this. I am sure I can find something similar here.

Can you comment on the specs of the little screws. Size? I am assuming they are also made of a conductive material.

I thank you for this. I really want a more enduring fix for those contacts. I am concerned that just cramming little bits of aluminum foil puts undue strain on that circuit board and something will give way. Moreover, I worry that loose foil bits could short the battery and kill it or even do something worse.

I'll look for beryllium copper and little screws this week.

Les


#13

Sorry about that. I've fixed the link.

I use 0-80 x 1/4" screws made out of brass but really any metal will work. 0-80 screws are easy to find on-line you don't need Amazon (I can buy them in my local ACE hardware store). I used beryllium copper because it's easy to work with and doesn't deform too easily making it ok as a spring material, but not great. Perhaps someone knows a better material for this.

Edited: 5 June 2012, 1:21 a.m.


#14

Maybe check Radio Shack for some battery holder that could be be scavenged for the contacts. Since our kids are now grown I also have a collection of old battery-operated toys that are chock full of odd parts.


#15

What about using contacts from some of the old calculators such as those made by Unisonic, NSC, etc.?

#16

I've used the aluminium foil 'fudge' in my HP32E and HP34C for about 30 years and while not ideal it seems to help considerably if the foil is held in place by a little soft adhesive (pritt stick in my case)- certainly intermittent battery contact was never a problem though I tend not to swap battery packs very often.

Unfortunately the HP32E has succumbed to the other dreaded spice problem of 'foam fatigue' so hasn't worked reliably for a couple of few years now - one day if Randy isn't too busy I might ask him if he can fix it.

Mike T.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Broken keys on HP Prime? Tarcisi C 0 151 12-10-2013, 05:59 PM
Last Post: Tarcisi C
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 571 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 373 10-14-2013, 01:46 PM
Last Post: BruceTTT
  Is my HP Prime broken ? Michael de Estrada 10 394 10-13-2013, 11:16 AM
Last Post: Mike Powell
  OT--'The Big Bang Theory' and RPN/HP--Any connections? Matt Agajanian 19 718 09-05-2013, 08:27 AM
Last Post: Adrien Bertrand
  Broken HP-97 to spare? davorin 3 233 08-29-2013, 01:08 AM
Last Post: davorin
  CLASSIC/SPICE KEY LEGENDS Mike T. 2 202 08-21-2013, 04:53 PM
Last Post: Mike T.
  HP Spice Legacy in the former CCCP (MK-61) Mike Morrow 17 667 04-07-2013, 08:25 PM
Last Post: db (martinez, ca.)
  HP-97 suddenly not working Brad Barton 10 348 02-25-2013, 08:15 PM
Last Post: Brad Barton
  [41CL] Problem with PowerCL ... not working Doug (NYC) 5 260 01-22-2013, 07:18 PM
Last Post: Doug (NYC)

Forum Jump: