NoV-64, CLUTILS 2H, and Library #4


Yesterday I received my new NoV-64 from Diego and started playing with it. Initially it didn't seem to be working. The HEPAX part worked fine but I couldn't seem to get any other ROMs to load. I eventually found the problem. CLUTILS 2H was causing the issue. I was loading that ROM at page E and the yfnz3b ROM at page F. The CLUTILS ROM was not showing up and it was hiding anything at higher pages. All other ROMs seemed to load and work fine.

So maybe someone can tell me what I am doing wrong. Here is the procedure I used:

1.  I used Warren Furlow's Module File Utility to convert (extract?) the ROM file from the MOD file.  
I got a checksum error but from reading other posts I believe that this is to be expected. I
did have it display the FAT and everything looked correct so I assumed that the conversion worked.

2. I used ClonixConfig to write the ROM to the NoV-64.

Two seemingly simple steps. As I stated above, every other ROM worked correctly. The CLUTILS ROM and any ROM written to a higher page number failed to show up. So, what am I doing wrong?

When searching for answers I visited the main page of the forum and noticed that Ángel Martin had released Library #4 and assorted ROM's to accompany it. So I thought, AH, I'll got that route. There were ROM images included for Library #4 itself and for CLUTILS 4H. Well I'll just write those ROMs to my NoV-64. That didn't work either because ClonixConfig does not seem to allow adjustment of the assigned page when NoV-64 is selected as the target--the option to change page value is grayed out so I can't load Library #4 to page 4.

Any help would be much appreciated.




Hi Marwan, looks like you´re having some issues but there´s a lot of moving parts in there so we´ll have to take it one at a time.

I don't have a NoV-64 so can't replicate your exact configuration. Also I'm not really familiar with the NoV-64 configuration details, like soft-settings on address 0x4041 - which may or may not have anything to do with this?

This is what I gather form your description:

- You're not seeing the CLUTILS_2H when burned into page #E, nor the YFNZ which is on the next page #F. I assume this is using CAT_2, but what about the CCD CAT'2?

-This is not the case for other modules, i.e. they show as expected also when burned in the same two pages,

A couple of initial actions and suggestions for troubleshooting:-

0. Make sure there isn't any XROM id# conflict (sorry I had to say it). CLUTILS uses XROM id#12, or 0x0C

1. Try it with CLUTLS alone, i.e. no other module in the NoV-64 (is it possible to not include the HEPAX?), say CLUTLS on lowest possible page#. Is it shown?

2. Do as it is but swapping pages #E and #F and see if there's any changes

3. burn the CLUTILS into a lowerer numbered page and see it the same pattern occurs with the other modules upstream.

There really isn't anything special or different to CLUTILS that would affect the CAT'2 operation, so ths is rather strange.

Let me know if that makes any difference. Also, let's solve the issue with the "standard" modules and worry about the Library#4 later on, if you don't mind.



Hi Ángel,

Unfortunately my first post was probably not complete enough. Here is what I have tried already:

0.  No port conflict.  Same machine with MMUDISabled so on-board 
CLUITLS does not cause a problem.
1. I have tried it with CLUTILS alone (but with HEPAX still
active). I don't know about not including HEPAX--Can I
do that by simply selecting CLONIX-D as my target? This
is a question for Diego.
2. I have tried swapping pages.
3. I have tried burning to page C (lowest available page)

Tests I have conducted since receiving your reply:

1.  CLUTILS in page C ROM bank 1 (x4100 = 100).
YFNS in page F ROM bank 2 (x4100 = 200).
Neither show up in cat 2. I would have expected YFNS
at least to show up after I switched banks. This
appears to me to be some sort of weird conflict with
the NoV-64.

2. YFNS in page F ROM bank 1 (x4100 = 100).
CLUTILS in page C ROM bank 2 (x4100 = 200).
YFNS show up when ROM bank 1 is selected CLUTILS does
not show when ROM bank 2 is selected.

3. With CLUTILS in page C ROM bank 2 "YFNS" PLUG4H "AOSX"
PLUG4L. MMUEN. This is YFNS 2B. Both YFNS and AOSX
show up fine but CLUTILS does not appear (CCD CAT"2).

4. Configured as in 3 (above) set ROM to disabled (x4100 = 000).
Turned calculator off and on. Then set ROM bank back to 2
(x4100 = 200) turned calc off and on again. CLUTILS did not

5. Just as an experiment (I know it won't run) I tried loading
CLUTILS4H. As expected I get the warning "NO LIBRARY" and
it shows up in CAT_2. More and more this looks like a
weird problem with CLUTILS2H and NoV-64 OR my conversion
using the Module utility is not actually working.

Do you by any chance have ROM version of the CLUTILS 2H ROM? If so could you possibly email it to me at "mjoury at gmail dot com".

Thanks for your help,


Edited: 22 May 2012, 2:28 p.m.


absolutely, I´ll send you the ROM file right away. It's possible that the ROM extract from MOD had a glitch, we'll soon see.

While it gets there, pls. try the HEPAX ¨BCAT¨ function - that is "HEPAXA_ BCAT" and see what it reports on the page where the ROM is supposed to be at...

Other quick tests using the HEPAX:

- DISASM the first 10 bytes of that page. Anything there at all?

- HEXEDIT with the address p000. Anything there at all?

Edited: 22 May 2012, 2:45 p.m.


Hi Ángel,

That was it! Worked great with the ROM you sent me.

The next part of the problem is probably for Diego to answer--how do I load Library #4 on a NoV-64.

Thanks very much for all your help!



Great! Thanks for using the ROM, it makes me feel good about all the hours put into it :-)

Best wishes,


I think that we should all be thanking you for all the stuff that you have given us over the years!


Hi Marwan, Ángel, all... :-)

You're right Marwan, the current publised version 3.0 of the ClonixConfig utility does not allow page #4 to be used on NoV-64.

Since Ángel decided to put his effort in building this awsome piece of software: "Library #4", to gain full advantage of this (usually unused) take-over page, I prepared a new version (3.4) which allows any page (#4 - #F) to be mapped.

The new version was supposed to be published past weekend, but I had to attend some personal issues and updating my web site was delayed.

The archive with ver. 3.4 is available here.

My home page may still take a couple of days to show the correct link though.

Hope this helps.

Best wishes.



Thanks Angel and Diego! Your hard work and contributions are very much appreciated by many HP-41 enthusiasts!




Thank you Diego.

I'll grab the latest version immediately.




Let us know how it fares... I think you'll be the first Lib#4 user on NoV-64 (Geir permitting... :-)

I tested it on Clonix and NoVRAM - works like a charm.

I'll use the new ClonixConfig to test it on Clonix-D and USB41 as well, but I don't expect any trouble.


Geir just got an awesome new toy; My other passion (the 41) will have to wait a few days;

See here :)


You are almost far enough north to not need an equatorial wedge!!


With this scope, I don't need it regardless :)

Edited: 24 May 2012, 4:18 a.m.


You do if you want to take long-exposure photographs - otherwise you will get field rotation!


Sure - but it will be a while before I get into long exposures...


Hi Geir,

Hope you also share some of the pics you'll take with this awsome piece of optical technology...

Some others here will certainly appreciate ;-)

Cheers from 18º 30' N



Go ahead guys, don't be shy and hijack this thread :-)

I'm kidding of course, this is the beauty of real-life posting - and I'm also expecting some pics soon!


Hi Diego,

It suddenly occurred to me (somewhat belatedly) that the NoV-32 and NoV-64 module were not compatible with the FORTH module because it used page #4 and a memory location was used in page 4 to set the NoV configuration (x4100). How will that work in conjunction with Ángel's Library #4?




You're correct, the Library#4 is not compatible with the diagnostics, FORTH and LaitRAM modules - so choose your weapons carefully :)

Seriously that shouldn't be any major drawback given the specificity of those modules.

More important to bear in mind is the disabled HP-IL Printer (switch on the IL module) - which also relocates the printer ROM to page#4.


But don't you worry about the NoV-64 settings: their addresses on page#4 are purposedly RESERVED and not used by the Library#4 - so it should be fully compatible.

Let us know if you run into issues though.



Hi Ángel,

Thank you for your very swift response. I had not yet gotten completely through the Library #4 docs so I had missed that.




Hi Diego and Ángel,

I have successfully configured ROM bank 2 of my NoV-64 to load and run Library #4. Thank you both very much for your quick responses to my various queries. My current configuration is:

ROM Bank 1    Page          ROM Bank 2    Page
CCD OS/X C Library#4 4
--FREE-- E --FREE-- E

RAM Bank 1 Page RAM Bank 2 Page

The initial idea was to run certain ROMs out of the HEPAX RAM pages and that when switching I would switch both ROM and RAM pages together. At this point I have moved away from that approach and have just placed YFNS 3B in both RAM banks that I use so that it is available in either RAM configuration. I realize that it would be just as easy to run YFNS 3B out of 41CL RAM but I like having it immediately available when I plug in my NoV-64. Currently initial configuration for me on the CL is:


Which clears the MMU registers and disables YFNS 2B in page 7.

Furthermore, disabling the NoV-64 ROM (setting location x4100 to 000, 001, 002, or 003) will free up pages C, D, and F (E is already available) for any modules I want to load from the 41CL while still allowing me access to YFNS functions. I also have a copy of CLUTILS 2H in CL RAM if I need it.

The other thought is to try copying Library#4 and it's associated programs into 41CL RAM pages and loading them from there. That would free up the NoV-64 ROM space for ROM images that I would like to use on my regular HP41CV. I would still probably keep YFNS 3B on the NoV-64 either in ROM or in RAM (more likely in RAM).

I am still playing around with the new libraries and considering various options for how I would like my machine configured. If I encounter any issues I'll be sure to let you know.




Hi there,

Thanks for the feedback Marwan.

Hope you keep exploring the many Library#4/CL/NoV functional possibilities and (of course) enjoying all your new HP-41 gear... :-)

All the best from Dom. Rep.


Possibly Related Threads…
Thread Author Replies Views Last Post
  HP-41 Clonix&NoV's SW Update. (For the non-Primer's guys out there... :-) Diego Diaz 21 5,657 11-13-2013, 09:00 AM
Last Post: Ángel Martin
  Library#4 Modules mass-update and New Overlays Ángel Martin 0 1,234 11-09-2013, 05:55 AM
Last Post: 'Angel Martin
  [HP Prime] Constants Library Values Timothy Roche 24 7,249 11-02-2013, 04:17 PM
Last Post: Les Koller
  [HP-Prime CAS] Vector Calculus Library CompSystems 7 2,699 10-31-2013, 12:48 PM
Last Post: Han
  Equation Library/App for the Prime Harold A Climer 3 1,702 10-30-2013, 10:14 AM
Last Post: CompSystems
  Equation Library on the PRIME Harold A Climer 0 1,041 10-26-2013, 10:01 AM
Last Post: Harold A Climer
  CASplus Library for HP-Prime CompSystems 1 1,195 10-05-2013, 12:44 AM
Last Post: CompSystems
  The Rich HP Calculator Library Eddie W. Shore 0 857 09-27-2013, 10:19 PM
Last Post: Eddie W. Shore
  So, latest 41CL / Library 4 config is... Gene Wright 4 1,981 09-22-2013, 02:59 AM
Last Post: Ángel Martin
  Cleaning exiting library programs patryk 2 1,296 09-14-2013, 12:36 PM
Last Post: patryk

Forum Jump: